отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Catalyst 4900 непонятная проблема с selective Q-in-Q

Доброго дня всем!

Столкнулся с совершенно непонятным глюком, и не знаю, толи я что-то не так сделал, толи коммутатор что-то не так делает.

Имеем: Каталист 4900 с модулем. В модуль вставлены TwinGig. Работаем с портом Ge2/19. IOS - Software (cat4500e-ENTSERVICESK9-M), Version 12.2(54)SG

интересующий кусок конфига:

interface GigabitEthernet2/19
 description **  KM 69 **
 switchport trunk allowed vlan 777,779
 switchport mode trunk
 switchport nonegotiate
 switchport vlan mapping 11-27 dot1q-tunnel 777
 switchport vlan mapping 110-124 dot1q-tunnel 777
 switchport vlan mapping 210 dot1q-tunnel 777
 switchport vlan mapping 430 dot1q-tunnel 777
 switchport vlan mapping 432-433 dot1q-tunnel 777
 switchport vlan mapping 435-438 dot1q-tunnel 777
 switchport vlan mapping 442-443 dot1q-tunnel 777
 switchport vlan mapping 445 dot1q-tunnel 777
 switchport vlan mapping 703 dot1q-tunnel 777
 switchport vlan mapping 2000 dot1q-tunnel 777
 switchport vlan mapping 2307-2308 dot1q-tunnel 777
 switchport vlan mapping 2335-2337 dot1q-tunnel 777
 switchport vlan mapping 3997 dot1q-tunnel 779
 mtu 9198
 logging event link-status
 storm-control broadcast level 0.90
 storm-control action trap
 l2protocol-tunnel stp

Сразу оговорюсь: из всех транслируемых этим портом вланов в самом коммутаторе присутствуют 2. 703 и 3997. Теперь внимание - фокус.

ВСЕ вланы, в том числе и 3997 обрабатываются без проблем. Исключение - 703.

В настройках ничего подозрительного не вижу. В порт включен коммутатор.

Со стороны 4900 в подключенный коммутатор MAC адреса по 703 влану пришли. Обратно же С подключенного коммутатора, на порту с4900 ни одного из MAC адресов 703-го влана нет.

c4900#sh int gi2/19 vlan mapping
VLANs on wire                    Translated VLAN     Operation
------------------------------   ---------------     --------------
1                                     777            selective QinQ
11-27                                 777            selective QinQ
110-124                               777            selective QinQ
210                                   777            selective QinQ
430                                   777            selective QinQ
432-433                               777            selective QinQ
435-438                               777            selective QinQ
442-443                               777            selective QinQ
445                                   777            selective QinQ
703                                   777            selective QinQ
2000                                  777            selective QinQ
2307-2308                             777            selective QinQ
2335-2337                             777            selective QinQ
3997                                  779            selective QinQ

Вроде все нормально расписано.

Причем затык именно с c-vlan 703. так как я ставил этот тег как в 777 так и в 779 S-vlan. Не работает ни там, ни там. Я уже грешным делом подумал, что c-vid не должен совпадать ни с одним из s-vid(бред, конечно, но все-же). Так нет. vid 3997 - присутствует в каталисте, и его транслирование на этом порту прекрасно работает. Так что я теряюсь в догадках, чем мог не понравиться именно c-vid 703....

2 ОТВЕТ.
New Member

Хочу дополнить.. Попробовал

Хочу дополнить.. Попробовал сменить c-vid на находящиеся рядом 702 и 704. Ни в том ни в другом трансляция не работает. При этом в самом каталисте 704 есть, а 702 - нет.

Создал трансляцию на c-vid 699 и перенес в него ip интерфейсы - все заработало...!!!

Перезагружать каталист не пробовал. Пожалуй это единственное. Объяснить неприязненное его отношение к c-vid 702-704 у меня не получается.

New Member

Хоть ответа я и не дождался,

Хоть ответа я и не дождался, все-же напишу сюда средство решения. Видимо какой-то глюк с использовавшимся мной на то время софтом. Проблема решалась перезагрузкой коммутатора, но могла всплыть в любой момент с любой трансляцией и любым портом. Дело доходило до того, что в один порт C-VID транслировался нормально, а в соседний - нет. Глобально проблема решилась при переходе на Version 15.1(2)SG3.

48
Просмотры
5
Полезный материал
2
Ответы