отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

CISCO 1921 и NAT

День добрый!
Есть Cisco 1921 k9, на ней настроен доступ к интернету по протоколу PPTP.
Из циски наружу все пингуется, имена резолвятся, все прекрасно.
Но при подключении внутренней сети с клиентских машин железяка себя как-то станно ведет.
При пинге, например гуглового днс, один пакет проходит и вслед за ним еще с десяток пропадает.
Трансляция NAT показывает что мол все хорошо.

Ниже конфиг.
interface GigabitEthernet0/1 - порт к провайдеру
interface GigabitEthernet0/0 - LAN

Скажите что вы все про это думаете, что у меня не так.

show version
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9_NPE-M), Version 15.3(3)M6, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 04-Aug-15 03:33 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)


Current configuration : 3418 bytes
!
! Last configuration change at 11:50:45 UTC Sun Jun 12 2016
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
ip domain name local.lan
ip name-server 77.88.8.8
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
rotary-group 0
initiate-to ip 172.16.3.14
!
!

license udi pid CISCO1921/K9 sn ***********
!
!
username admin privilege 15 password 7 ***********
!
redundancy
notification-timer 120000
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 10.2.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address dhcp
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip pim dense-mode
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
ppp pfc local request
ppp pfc remote apply
ppp chap hostname ********
ppp chap password 7 ********
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip nat inside source list NAT interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 172.16.3.14 255.255.255.255 10.15.180.1
!
ip access-list extended NAT
permit ip 10.2.1.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end



show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 172.19.54.15:1 10.2.1.2:1 8.8.4.4:1 8.8.4.4:1
icmp 172.19.54.15:1 10.2.1.2:1 93.158.134.3:1 93.158.134.3:1
udp 172.19.54.15:49366 10.2.1.2:49366 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:49522 10.2.1.2:49522 8.8.4.4:53 8.8.4.4:53
tcp 172.19.54.15:53958 10.2.1.2:53958 62.128.100.55:443 62.128.100.55:443
tcp 172.19.54.15:54002 10.2.1.2:54002 81.19.104.42:443 81.19.104.42:443
tcp 172.19.54.15:54006 10.2.1.2:54006 62.128.100.221:443 62.128.100.221:443
tcp 172.19.54.15:54008 10.2.1.2:54008 192.168.1.1:80 192.168.1.1:80
tcp 172.19.54.15:54011 10.2.1.2:54011 62.128.100.49:443 62.128.100.49:443
tcp 172.19.54.15:54013 10.2.1.2:54013 37.252.248.78:5938 37.252.248.78:5938
tcp 172.19.54.15:54016 10.2.1.2:54016 91.203.178.85:35271 91.203.178.85:35271
tcp 172.19.54.15:54019 10.2.1.2:54019 10.7.2.200:35271 10.7.2.200:35271
tcp 172.19.54.15:54021 10.2.1.2:54021 192.168.1.1:80 192.168.1.1:80
tcp 172.19.54.15:54030 10.2.1.2:54030 91.203.178.85:35271 91.203.178.85:35271
tcp 172.19.54.15:54033 10.2.1.2:54033 10.7.2.200:35271 10.7.2.200:35271
tcp 172.19.54.15:54037 10.2.1.2:54037 192.168.1.1:80 192.168.1.1:80
udp 172.19.54.15:56285 10.2.1.2:56285 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:56394 10.2.1.2:56394 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:57087 10.2.1.2:57087 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:57840 10.2.1.2:57840 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:61565 10.2.1.2:61565 8.8.4.4:53 8.8.4.4:53
udp 172.19.54.15:63478 10.2.1.2:63478 8.8.4.4:53 8.8.4.4:53


S* 0.0.0.0/0 is directly connected, Dialer0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.0.0.4/32 is directly connected, Dialer0
C 10.2.1.0/24 is directly connected, GigabitEthernet0/0
L 10.2.1.1/32 is directly connected, GigabitEthernet0/0
C 10.15.180.0/24 is directly connected, GigabitEthernet0/1
L 10.15.180.39/32 is directly connected, GigabitEthernet0/1
172.16.0.0/32 is subnetted, 2 subnets
S 172.16.2.2 [254/0] via 10.15.180.1, GigabitEthernet0/1
S 172.16.3.14 [1/0] via 10.15.180.1
172.19.0.0/32 is subnetted, 1 subnets
C 172.19.54.15 is directly connected, Dialer0

Теги (1)
5 ОТВЕТ.
New Member

Добрый день

Добрый день

Предлагаю попробовать пинг с Cisco используя опцию:

source interface GigabitEthernet0/0

Это более правильно для тестирования функции NAT на маршрутизаторе.

Что-либо еще сказать пока сложно, так как NAT работает, где начинается потеря пакетов, пока непонятно.

С уважением, Нестеркин Алексей.

New Member

так все пингуется, я проверял

так все пингуется, я проверял

New Member

Прошу уточнить, это обычный

Прошу уточнить, это обычный пинг или с внутреннего интерфейса.

Разница большая, так как при пинге с маршрутизатора NAT работать не будет, так как запросы уходят с внешнего инерфейса. Если использовать расширенный вариант, то запрос пойдет с внутреннего интерфейса, и потребуется трансляция. 

Приложите пинг с маршрутизатора.

С уважением, Нестеркин Алексей.

New Member

пинг внешнего ресурса с циски

пинг внешнего ресурса с циски проходит удачно.

пинг с внутреннего интерфейса не пробывал если честно.

Спецы от провайдера мне посоветовали на dialer0 установить mtu 1460.

А вот на интерфейс gi0/0, который смотрит в локалку, установить mtu 1420, якобы

не каждое устройство может автоматом настроить размер пакета.

Как Вы думаете может быть в этом проблема, проверить пока у самого нет возможности

New Member

Изменение MTU на прохождение

Изменение MTU на прохождение стандартных ICMP пакетов (ping) не повлияет, так как эти пакеты небольшого размера.

Настройка MTU на внутреннем интерфейсе вообще не имеет смысла и может привести к другим проблемам.

Попробуйте все таки такой пинг:

ping 8.8.8.8 source gi0/0

С уважением, Нестеркин Алексей.

113
Просмотры
0
Полезный материал
5
Ответы
СоздатьДля создания публикации, пожалуйста в систему