Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Cisco 2811 Два провайдера

Добрый день. 

Попал в руки маршрутизатор Cisco 2811 v06 (прошивка version 12.4). Хочу настроить его на работу с двумя провайдерами. Один основной и один резервный канал. Основной "заглох", включается резервный. 

После прочтения десятка статей собрал вот такой конфиг :

track 10 rtr 1 reachability
!
track 20 rtr 2 reachability
!
track 30 rtr 3 reachability
!
track 100 list boolean or
object 10
object 20
object 30
delay down 10 up 5
!
!
!
interface FastEthernet0/0
description DI
ip address 192.168.5.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description UGL
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1/0
switchport access vlan 10
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface Special-Services-Engine1/0
no ip address
shutdown
no keepalive
!
interface Vlan1
no ip address
!
interface Vlan10
description LOCAL
ip address 192.168.10.249 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip local policy route-map PBR_SLA
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.5.1 track 100
ip route 0.0.0.0 0.0.0.0 192.168.1.1 250
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source route-map ISP_1 interface FastEthernet0/0 overload
ip nat inside source route-map ISP_2 interface FastEthernet0/1 overload
!
ip access-list standard LAN
permit 192.168.10.0 0.0.0.255
!
ip access-list extended SLA_ACL
permit icmp host 192.168.5.1 host 8.8.8.8
permit icmp host 192.168.5.1 host 8.8.4.4
permit icmp host 192.168.5.1 host 4.4.4.4
!
ip sla 1
icmp-jitter 8.8.8.8 source-ip 192.168.5.2 num-packets 5
frequency 30
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-jitter 8.8.4.4 source-ip 192.168.5.2 num-packets 5
frequency 30
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-jitter 4.4.4.4 source-ip 192.168.5.2 num-packets 5
frequency 30
ip sla schedule 3 life forever start-time now
!
!
route-map ISP_1 permit 10
match ip address LAN
match interface FastEthernet0/0
!
route-map ISP_2 permit 10
match ip address LAN
match interface FastEthernet0/1
!
route-map PBR_SLA permit 10
match ip address SLA_ACL
set ip next-hop 192.168.5.1
!
!
!
control-plane
!
!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
event manager applet ISP_1_UP
event track 100 state up
action 001 cli command "enable"
action 002 cli command "clear ip nat trans *"
action 003 syslog msg "ISP 1 is UP"
event manager applet ISP_1_DOWN
event track 100 state down
action 001 cli command "enable"
action 002 cli command "clear ip nat trans *"
action 003 syslog msg "ISP 1 is DOWN"

При перезапуске маршрутизатора track уходит в Down

*Sep 26 12:16:17.919: %TRACKING-5-STATE: 10 rtr 1 reachability Up->Down
*Sep 26 12:16:17.919: %TRACKING-5-STATE: 20 rtr 2 reachability Up->Down
*Sep 26 12:16:17.919: %TRACKING-5-STATE: 30 rtr 3 reachability Up->Down

Даже при неработоспособных траках доступ в интернет работает  через Fa0/1. Хотя, изначально, планировал использовать более мощную линию как основную подключенную Fa0/0. При физическом отключении связь прерывается т.к. резервный не поднимается.

Подскажите, где я ошибся. 

P.S. Возможно сильно замудрил?

Заранее благодарен.

181
Просмотры
0
Полезный материал
0
Ответы
СоздатьДля создания публикации, пожалуйста в систему