отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

cisco 2950 высокая загрузка cpu

Здравствуйте, у меня проблема с cisco 2950, а именно с загруженностью процессора. Суть проблемы такова, что когда cpu поднимается до 80-90% свитч падает. Пробовал все что тока мог, уже незнаю что делать, cisco падает с периодичностью два - три раза в неделю, буду благодарен за любую помошь                 

Теги (3)
22 ОТВЕТ.
New Member

cisco 2950 высокая загрузка cpu

Может опишите то что вы у же делали, что бы люди не советовали одно и тоже.

У еня был случай с высоко загрузкой на свитче. Грузил процесс, если мне не изменяет память Hulc LED Process. Помогла смена ИОСа.

New Member

Re: cisco 2950 высокая загрузка cpu

Вообще мне эта циска досталась от предыдушего админа, сам я с цисками не очень знаком, поэтому лучше приведу конфиг что б наглядней было

AAA#show running-config

Building configuration...

Current configuration : 4018 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service sequence-numbers

!

hostname AAA

!

enable secret 5 $1$l/pi$aBx0nIxzVD93mdPb/S.KB/

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 104

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/2

switchport access vlan 104

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/3

switchport trunk allowed vlan 104-107

switchport mode trunk

spanning-tree bpdufilter enable

!

interface FastEthernet0/4

switchport access vlan 105

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/5

switchport access vlan 106

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/6

switchport access vlan 107

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/7

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/8

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/9

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/10

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/11

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/12

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/13

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/14

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/15

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/16

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/17

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/18

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/19

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/20

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/21

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/22

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/23

switchport mode access

spanning-tree bpdufilter enable

!

interface FastEthernet0/24

switchport mode access

spanning-tree bpdufilter enable

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1,101

switchport mode trunk

spanning-tree bpdufilter enable

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 1,101

switchport mode trunk

spanning-tree bpdufilter enable

!

interface Vlan1

ip address 172.***.***.*** 255.***.***.***

!

ip default-gateway 172.***.***.***

ip http server

logging facility local6

logging 172.***.***.***

logging 172.***.***.***

snmp-server community public RO

snmp-server location ***

snmp-server contact ****

snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart

snmp-server enable traps config

snmp-server enable traps copy-config

snmp-server enable traps syslog

snmp-server enable traps entity

snmp-server enable traps flash insertion removal

snmp-server enable traps bridge

snmp-server enable traps stpx

snmp-server enable traps rtr

snmp-server enable traps c2900

snmp-server enable traps vtp

snmp-server enable traps vlancreate

snmp-server enable traps vlandelete

snmp-server enable traps port-security

snmp-server enable traps MAC-Notification

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps hsrp

snmp-server enable traps cluster

snmp-server enable traps vlan-membership

snmp-server host 172.***.***.*** u

!

line con 0

line vty 0 4

password password

login

line vty 5 15

password password

login

!

!

end

Cisco Employee

Re: cisco 2950 высокая загрузка cpu

Добрый День.

Несколько вопросов:

- Вы знаете, что служит причиной скачка загрузки? Приложите к теме пожалуйста:

show proc cpu sort | ex 0.00

взятую во время высокой загрузки

- Видите ли вы файлы аварии crsahinfo в памяти после перезагрузок:

show flash:

или

dir all  (и просмотр всех доступных областей памяти с помощью команды show).

- Пришлите еще "show ver"

NIk

New Member

Re: cisco 2950 высокая загрузка cpu

что служит причиной скачков загрузки незнаю, не в логах не по snmp неотображается,

прислать результат команды show proc cpu sort| ex 0.00 не могую т.к не знаю когда произойдет следующий скачок.

файлы аварии crsahinfo в памяти после перезагрузок не наблюдю.

вот sshow flash:

AAA#show flash

Directory of flash:/

    2  -rwx         112  Mar 01 1993 00:12:22 +00:00  info

    3  -rwx     3722814  Mar 01 1993 00:14:56 +00:00  c2950-i6k2l2q4-mz.121-22.E

A14.bin

    4  drwx        4416  Mar 01 1993 00:15:51 +00:00  html

  331  -rwx         112  Mar 01 1993 00:16:33 +00:00  info.ver

  332  -rwx          63  Mar 01 1993 00:17:12 +00:00  env_vars

  333  -rwx        1048  Mar 31 1993 18:04:23 +00:00  multiple-fs

  335  -rwx        4018  Mar 31 1993 18:04:23 +00:00  config.text

  336  -rwx         856  Mar 01 1993 00:46:03 +00:00  vlan.dat

  337  -rwx          44  Mar 31 1993 18:04:23 +00:00  private-config.text

7741440 bytes total (2084864 bytes free)

и результат show ver:

AAA#show ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA

RE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by cisco Systems, Inc.

Compiled Tue 26-Oct-10 10:35 by nburra

Image text-base: 0x80010000, data-base: 0x80680000

ROM: Bootstrap program is C2950 boot loader

AAA uptime is 5 weeks, 2 days, 23 hours, 53 minutes

System returned to ROM by power-on

System image file is "flash://c2950-i6k2l2q4-mz.121-22.EA14.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2950T-24 (RC32300) processor (revision R0) with 19911K bytes of memory

.

Processor board ID FOC0938Z80K

Last reset from system-reset

Running Enhanced Image

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:15:63:DF:63:00

Motherboard assembly number: 73-6114-10

Power supply part number: 34-0965-01

Motherboard serial number: FOC09373U6D

Power supply serial number: DAB0930DP5A

Model revision number: R0

Motherboard revision number: A0

Model number: WS-C2950T-24

System serial number: FOC0938Z80K

Configuration register is 0xF

Cisco Employee

Re: cisco 2950 высокая загрузка cpu

Если crashinfo никогда не создается, то скорей всего аппаратная проблема и перебой с ппитанием.

Согласно show ver свич не падал больше месяца. Последний раз был заружен по питанию. Подскажите - он после падения сам не загружается, и вам приходится включать его?. Возможно какая-то тогда проблема с ЦПУ - перегревается и выключает его.

Причину высокой загрузки можно отследить EEM скриптом типа:

event manager applet CPU

event snmp oid 1.3.6.1.4.1.9.9.109.1.1.1.1.3.1 get-type exact entry-op gt entry-val 75 exit-op lt exit-val 50 poll-interval 0.5

action 1.1 syslog msg "------HIGH CPU DETECTED----, CPU: $_snmp_oid_val%"

action 2.0 cli command "enable"

action 3.0 cli command "show clock | append nvram:cpuinfo.txt"

action 4.0 cli command "show proc cpu sort | append nvram:cpuinfo.txt"

Скрипт выполнится при достижении загрузки в 75% и запишет результаты в файл на NVRAM.

New Member

Re: cisco 2950 высокая загрузка cpu

свитч падал на прошлой неделе в пятницу, приходится самому включать, и пожалуйста подскажите как этот скрипт выполнить, если можно пошагово

Cisco Employee

Re: cisco 2950 высокая загрузка cpu

Скрипт запускается из режима" conf t" - просто копируете все строчки скрипта по очереди. Он после этого автоматически запустится и будет мониторить загрузку. При повышении в логах напишет - HIGH CPU DETECTED и соберет вывод в файл nvram:cpuinfo.txt.

Не обратил сразу внимание на версию - может в данной EEM не поддерживаться. Но стоит попробовать.

Странно, что show ver показыает время работы 5 недель... И так или иначе он не должен падать при высокой загрузке - имхо причина аппаратная, если стойкая корреляция между загрузкой и падениями (тсключает питание).

Николай

New Member

Re: cisco 2950 высокая загрузка cpu

спасибо, но почему то скрипт не прописывается, пишет что ошибки в строчках, например:

AAA#conf term

Enter configuration commands, one per line.  End with CNTL/Z.

AAA(config)#$gt entry-val 75 exit-op lt exit-val 50 poll-interval 0.5

event snmp oid 1.3.6.1.4.1.9.9.109.1.1.1.1.3.1 get-type exact entry-op gt entry-

^val 75 exit-op lt exit-val 50 poll-interval 0.5

% Invalid input detected at '^' marker.

AAA(config)#

или это нормально

New Member

Re: cisco 2950 высокая загрузка cpu

А не подскажите, есть какой-либо альтернативный скрипт?

Re: cisco 2950 высокая загрузка cpu

EEM не работает на 2950! Только на платформах более высокого уроня (3560,3750 и выше).

Можно попробовать RMON.

rmon event 1 log description "CPU has crossed rising threshold"

rmon alarm 12 cpmCPUTotalTable.1.8 60 absolute rising-threshold 80 1 falling-threshold 40

(или rmon alarm 12 1.3.6.1.4.1.9.9.109.1.1.1.1.8 60 absolute rising-threshold 80 1 falling-threshold 40)

Поясню вкратце. С первой строкой более менее все понятно, создаем event №1. Далее мониторим cpmCPUTotalTable. Из определения

"The overall CPU busy percentage in the last 5 minute period. This object deprecates the object cpmCPUTotal5min

and increases the value range to (0..100)."

Подробнее можно почитать здесь http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094a94.shtml

здесь - http://tools.cisco.com/Support/SNMP/do/BrowseOID.do?objectInput=1.3.6.1.4.1.9.9.109.1.1.1.1.8&translate=Translate&submitValue=SUBMIT&submitClicked=true

или здесь - ftp://ftp.cisco.com/pub/mibs/oid/CISCO-PROCESS-MIB.oid

Мониторим с  интералом в 60 секунд абсолютное значение, если первышает 80%, то каждые 60 секунд будет срабатывать event №1. Как только загрузка упадет ниже 40% логи сыпаться перестанут. Настраивайте как вам удобнее.

База взята отсюда https://supportforums.cisco.com/docs/DOC-13944
Но прошу обратить внимание на разницу в объектах которые монторятся, в моем примере

1.3.6.1.4.1.9.9.109.1.1.1.1.8

а в образце

1.3.6.1.4.1.9.9.109.1.1.1.1.8.1

Лишняя единичка взялась потому что в примере использовано устройство с несколькими процессорами

(подробнее здесь- http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094a94.shtml#multiple), т.к. у нас устройство с одним процессором, то нам она не нужна.

Что нам в итоге все это дает - только то, что когда у нас загрузка будет большая мы об это узнаем с помошью syslog.

Мы бы могли углубиться дальше и сделать автоматический запуск скриптов при получении сообщения syslog, чтобы выполнялась команда

show proc cpu  | append nvram:cpuinfo.txt

Но опять же - данная команда не поддерживается 2950.

New Member

Re: cisco 2950 высокая загрузка cpu

теперь стало понятно почему первый скрипт не запустился, скрипт залил на циску, буду ждать логов, как от циски что то прилетит - напишу, спасибо за отзывчивость и ясный ответ

Re: cisco 2950 высокая загрузка cpu

Чтобу автомоатизироать процесс можно возпользоваться Kiwi Sylog (бесплатной версией), в нем логи сыпятся один файл. Его можно найти в папке где установлена программа - обычный txt.

Далее на помощь приходит SecureCRT. Использую анализатор файла можно при получении определенного сообщения запустить crt.bat файл.

В нем пишем C:\Programs\SecureCRT\SecureCRT.exe /s 2851, т.е. путь где устаноленна программа /s - запуск предустановленной сесси и её название 2851. Подробнее здесь - http://www.vandyke.com/support/tips/scripting/scripting_essentials.pdf

Далее настраиваем SecureCRT - нам надо чтобы при запуске файла crt.bat у нас срабатывал автоматический вход (обсуждалось мною здесь - https://supportforums.cisco.com/message/3537358), и выполнение команды

sh processes cpu | exclude 0.00%__0.00%__0.00%

возможно с помощью добавления строки к скрипту из обсуждения выше

Sub Main()

    crt.Screen.Synchronous = True

    crt.Screen.Send "username" & VbCr

    crt.Screen.Send "password" & VbCr

    crt.Screen.Send "enable" & VbCr

    crt.Screen.Send "enable_password" & VbCr

    crt.Screen.Send " sh processes cpu | exclude 0.00%__0.00%__0.00%" & VbCr

End Sub

и залогировать сессию в файл (Log File на картинке выше), тогда мы получим полностью автоматизированный процесс получения логов и сохранения вывода комашды sh proc cpu в файл.

Единственное и самое сложное чего не могу подсказать как сделать анализатор файла логов и запуск crt.bat по событию. Может быть вы знаете ответ - поделитесь знаниями.

Если есть еще вопросы - задавайте.

New Member

Re: cisco 2950 высокая загрузка cpu

к сожалению в цисках я новичок пока, и незнаю как автоматизировать анализатор логов по событию, но я сейчас активно изучаю документацию и все что связано с цисками, еще раз спасибо за советы, буду пробовать

Re: cisco 2950 высокая загрузка cpu

Анализатор логов не имеет к Cisco никакого отношения ))) Ладно удачи, если что пишите в личку.

New Member

Re: cisco 2950 высокая загрузка cpu

скрипт для анализатора логов незапускается, имеется ли альтернативный скрипт? заранее спасибо

Re: cisco 2950 высокая загрузка cpu

Не понял. Конкретнее можно?

New Member

Re: cisco 2950 высокая загрузка cpu

скрипт предложенный вами на циске не запускается

Re: cisco 2950 высокая загрузка cpu

Вячеслав давайте максимально конкретно - что делаете и что получаете. Вывод результатов в пост. Я не телепат

Скрипт должен срабатывать при достижении нагрузки на процессор 80%.

Попробуйте logging trap 7 - так будут сыпаться все логи на 172.***.***.***

Еще один очень важный момент - вводя команду rmon event 1 log description "CPU has crossed rising threshold" не ожидайте что в логах появится сообщение "CPU has crossed rising threshold" появится что-то типа

%RMON-5-RISINGTRAP: Rising trap is generated because the value of cpmCPUTotalTable.1.8 exceeded the rising-threshold value 80

Подробнее здесь  и здесь

Я так понимаю, что циска упала и не выдала логов. Попробуйте изменить цифру нагрузки на процессор чтобы она была не 80%, а меньше. Если циска все равно падаед, значит дело не в высокой загрузке процессора.

Тажже сделайте show post, должно показать passed

Также сделайте sh ver - ищите строку

System returned to ROM by ... - это указывает причину последней перезагрузки. Анализируйте.

New Member

Re: cisco 2950 высокая загрузка cpu

при вводе скрипта на циску вот что полуается:

AAA(config)#Sub Main()

                ^

% Invalid input detected at '^' marker.

AAA(config)#    crt.Screen.Synchronous = True

                     ^

% Invalid input detected at '^' marker.

AAA(config)#    crt.Screen.Send "username" & VbCr

                     ^

% Invalid input detected at '^' marker.

AAA(config)#    crt.Screen.Send "password" & VbCr

                     ^

% Invalid input detected at '^' marker.

AAA(config)#    crt.Screen.Send "enable" & VbCr

                     ^

% Invalid input detected at '^' marker.

AAA(config)#    crt.Screen.Send "enable_password" & VbCr

                     ^

% Invalid input detected at '^' marker.

SwZ-19(config)#$ sh processes cpu | exclude 0.00%__0.00%__0.00%" & VbCr

    crt.Screen.Send " sh processes cpu | exclude 0.00%__0.00%__0.00%" & VbCr

      ^

% Invalid input detected at '^' marker.

AAA(config)#End Sub

а при просмотре команды show ver видим:

AAA#show ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWA

RE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by cisco Systems, Inc.

Compiled Tue 26-Oct-10 10:35 by nburra

Image text-base: 0x80010000, data-base: 0x80680000

ROM: Bootstrap program is C2950 boot loader

AAA uptime is 5 weeks, 5 days, 21 hours, 21 minutes

System returned to ROM by power-on

System image file is "flash://c2950-i6k2l2q4-mz.121-22.EA14.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2950T-24 (RC32300) processor (revision R0) with 19911K bytes of memory

.

Processor board ID FOC0938Z80K

Last reset from system-reset

Running Enhanced Image

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:15:63:DF:63:00

Motherboard assembly number: 73-6114-10

Power supply part number: 34-0965-01

Motherboard serial number: FOC09373U6D

Power supply serial number: DAB0930DP5A

Model revision number: R0

Motherboard revision number: A0

Model number: WS-C2950T-24

System serial number: FOC0938Z80K

Configuration register is 0xF

циска последние четыре дня не вылетала, держится стабильно пока что

Re: cisco 2950 высокая загрузка cpu

Понятно.

Вообще этот скрипт

Sub Main()

    crt.Screen.Synchronous = True

    crt.Screen.Send "username" & VbCr

    crt.Screen.Send "password" & VbCr

    crt.Screen.Send "enable" & VbCr

    crt.Screen.Send "enable_password" & VbCr

    crt.Screen.Send " sh processes cpu | exclude 0.00%__0.00%__0.00%" & VbCr

End Sub

написан на Visual Basic языке. Его не надо запускать на 2950!

Если у вас установлен Secure CRT - то исполнять его надо в LogonActions см. картинку выше.

По поводу атоматизации анализа логов здесь

Короче готовое решение я вам показал, crt.bat выкладывал осталось все только в кучу собрать

vbs файл прилагаю

New Member

Re: cisco 2950 высокая загрузка cpu

хорошо, я вас понял, буду реализовывать, спасибо

Re: cisco 2950 высокая загрузка cpu

Если сильно застопоритесь пишите. Но только максимально подробно описывая свои действия и результат!

1950
Просмотры
0
Полезный материал
22
Ответы