Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Cisco 891. Помощь в настройке для двух каналов ISP

Здравствуйте!

Купили Cisco 891, пытался настроить самостоятельно. К слову, оборудование Cisco держу в руках первый раз.

Суть проблемы такова:

Есть два канала от провайдера, один подключаю в FastEthernet8, другой в GigabitEthernet0.

Как мне показалось, с моей конфигурацией работают оба канала одновременно. Если отключаю кабель из FastEthernet8, то все идет через GigabitEthernet0. Но вот если отключить GigabitEthernet0, то всё сразу падает, ничего не пингуется. Но если проверять соединение в

Cisco Configuration Professional, показывает, что соединение успешно проверено.

Ниже моя конфигурация. Подскажите пожалуйста, что мне надо дописать, чтобы оба порта работали одновременно и при падении одного из каналов, весь траффик шел через порт, на котором есть живое соедниение.

no aaa new-model

ip name-server DNS1 ISP1

ip name-server DNS2 ISP1

ip name-server DNS1 ISP2

ip name-server DNS2 ISP2

ip cef

no ipv6 cef

multilink bundle-name authenticated

interface FastEthernet8

description $ETH-WAN$

ip address xxx.xxx.xxx.xxx 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0

description $ETH-WAN$

ip address yyy.yyy.yyy.yyy 255.255.255.224

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Async1

no ip address

encapsulation slip

!

ip http server

ip http authentication local

ip http secure-server

ip forward-protocol nd

!

!

ip nat inside source list 1 interface GigabitEthernet0 overload

ip nat inside source list 2 interface FastEthernet8 overload

ip route 0.0.0.0 0.0.0.0 GATE ISP1

ip route 0.0.0.0 0.0.0.0 GATE ISP2

!

ip sla auto discovery

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 2 remark CCP_ACL Category=2

access-list 2 remark INSIDE_IF=Vlan1

access-list 2 permit 192.168.0.0 0.0.0.255

!

!

!

control-plane

!

!

!

!

mgcp profile default


Теги (1)
1 УТВЕРЖДЕННОЕ РЕШЕНИЕ

Утвержденные решения

Cisco 891. Помощь в настройке для двух к

Ну давайте диагностировать...

Выполните для начала следующее, погасив gi0:

show ip cef 0.0.0.0/0

ping 8.8.8.8

ping 8.8.8.8 so vlan1

Ну и для страховки от любых (кроме связанных с падением физики) проблем на стороне провайдеров предложенной конфигурации недостаточно. Надо создавать IP SLA пробы, к ним привязывать track'и, к track'ам - статические маршруты. Тогда доступность канала провайдера будет определяться доступностью одного (или нескольких) хостов где-то в интернете.

3 ОТВЕТ.

Cisco 891. Помощь в настройке для двух к

Ну давайте диагностировать...

Выполните для начала следующее, погасив gi0:

show ip cef 0.0.0.0/0

ping 8.8.8.8

ping 8.8.8.8 so vlan1

Ну и для страховки от любых (кроме связанных с падением физики) проблем на стороне провайдеров предложенной конфигурации недостаточно. Надо создавать IP SLA пробы, к ним привязывать track'и, к track'ам - статические маршруты. Тогда доступность канала провайдера будет определяться доступностью одного (или нескольких) хостов где-то в интернете.

Re: Cisco 891. Помощь в настройке для дву

Можно попробовать решение данной задачи разными способами, PBR, EEM. Проверьте так-же следующее:

ip route 0.0.0.0 0.0.0.0 ваш_isp1_шлюз 1 track 1 name ISP1

ip route 0.0.0.0 0.0.0.0 ваш_isp2_шлюз 10 name ISP2

!

ip sla 10

icmp-echo ваш_isp1_шлюз source-interface GigabitEthernet0

frequency 10

!

ip sla schedule 10 life forever start-time now

!

track 1 rtr 10 reachability

! сколько ждать чтобы  сообщить о том, что  шлюз недоступен. Можете настраивать на свое усмотрение от качества вашей трансмиссии. Можете для начала не указывать вообще.

delay down 20

delay up 20

командой

sh ip route track-table

можете наблюдать доступность маршрута главного.

Не забываем оценивать решения которые были вам как-то полезны.

----------------------------------------------------------- Прошу вас оценивать и отмечать полезные для вас сообщения. Please rate helpful answers.
New Member

Re: Cisco 891. Помощь в настройке для дву

Спасибо огромное за ответ, худо-бедно, все поднял - вроде как всё заработало как надо. Теперь столкнулся с проблемой проброса и открытия портов. Открыл новое обсуждение:

https://supportforums.cisco.com/message/4112304#4112304

Может быть и тут чем-нибудь поможете?)

1261
Просмотры
5
Полезный материал
3
Ответы
СоздатьДля создания публикации, пожалуйста в систему