отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Cisco C819G-4G-G-K9 PPPoE Client

Здравствуйте!

Пытаюсь настроить Cisco C819G-4G-G-K9 в качестве PPPoE клиента. Обнаружил, что не поддерживает устройство этот функционал.

В запросе соединения нет возможности выбрать PPPoE, только L2TP.

Router(config)#vpdn-group 1

Router(config-vpdn)#request-dialin
Router(config-vpdn-req-in)#protocol ?
l2tp Use L2TP

IOS c800-universalk9_npe-mz.SPA.155-3.M.bin

License Information for 'c800'
License Level: advipservices

Feature Navigator подсказал IOS с поддержкой pppoe client, это c800-universalk9-mz.SPA.155-1.T1.bin. Загрузил. Изменений нет.

Есть ли возможность заставить роутер работать в качестве PPPoE клиента?

1 УТВЕРЖДЕННОЕ РЕШЕНИЕ

Утвержденные решения
New Member

Не нужен вам vpdn. Всё что

Не нужен вам vpdn. Всё что вам нужно:

Входим на интерфейс (у вас может быть другой).

R1(config)#interface GigabitEthernet 0/0

 

Включаем его.

R1(config-if)#no shutdown

 

Активируем PPPoE на интерфейсе

R1(config-if)#pppoe enable

 

Указываем что мы являемся клиентом и откуда брать наши параметры.

R1(config-if)#pppoe-client dial-pool-number 1

 

Создаем интерфейс который будет "звонить". Номер интерфейса мы указали выше.

R1(config)#interface dialer 1

 

Получаем ip адрес от сервера.

R1(config-if)#ip address negotiated

 

Указываем размер пакета.

R1(config-if)#ip mtu 1492

 

Зададим тип туннелирования.

R1(config-if)#encapsulation ppp

 

Метка пула.

R1(config-if)#dialer pool 1

 

Заставим сервер аутентифицировать у себя.

R1(config-if)#ppp authentication chap callin

 

Указываете ваш логин для подключения.

R1(config-if)#ppp chap hostname <логин>

Указываете ваш пароль.

R1(config-if)#ppp chap password <пароль>

Если аутентификация PAP то указывает учётные данные так.

R1(config-if)#ppp pap sent-username <логин> password 0 <пароль>

Получаем маршрут по умолчанию.

R1(config-if)#ppp ipcp route default

Получаем DNS (если надо).

R1(config-if)#ppp ipcp dns request

2 ОТВЕТ.
New Member

Не нужен вам vpdn. Всё что

Не нужен вам vpdn. Всё что вам нужно:

Входим на интерфейс (у вас может быть другой).

R1(config)#interface GigabitEthernet 0/0

 

Включаем его.

R1(config-if)#no shutdown

 

Активируем PPPoE на интерфейсе

R1(config-if)#pppoe enable

 

Указываем что мы являемся клиентом и откуда брать наши параметры.

R1(config-if)#pppoe-client dial-pool-number 1

 

Создаем интерфейс который будет "звонить". Номер интерфейса мы указали выше.

R1(config)#interface dialer 1

 

Получаем ip адрес от сервера.

R1(config-if)#ip address negotiated

 

Указываем размер пакета.

R1(config-if)#ip mtu 1492

 

Зададим тип туннелирования.

R1(config-if)#encapsulation ppp

 

Метка пула.

R1(config-if)#dialer pool 1

 

Заставим сервер аутентифицировать у себя.

R1(config-if)#ppp authentication chap callin

 

Указываете ваш логин для подключения.

R1(config-if)#ppp chap hostname <логин>

Указываете ваш пароль.

R1(config-if)#ppp chap password <пароль>

Если аутентификация PAP то указывает учётные данные так.

R1(config-if)#ppp pap sent-username <логин> password 0 <пароль>

Получаем маршрут по умолчанию.

R1(config-if)#ppp ipcp route default

Получаем DNS (если надо).

R1(config-if)#ppp ipcp dns request

New Member

Спасибо вам за ответ. 

Спасибо вам за ответ. 

Все работает.

75
Просмотры
0
Полезный материал
2
Ответы