Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

OSPF нет IA маршрутов

Cisco WS-C3750G-24TS-1U  12.2(35)SE5 не получает IA маршрутов в таблице маршрутизации. В OSPF database LSA 3 присутствуют. Роутер который анонсировал данные LSA доступен.

Как действовать в этой ситуации? Спасибо!

Теги (3)
1 УТВЕРЖДЕННОЕ РЕШЕНИЕ

Утвержденные решения

Re: OSPF нет IA маршрутов

Я, кстати, нашел идентичную проблему.

https://supportforums.cisco.com/thread/2135001

Вообще, странно, что LSA не отмечается как downward. Но видимо, поведение может отличаться.

13 ОТВЕТ.

OSPF нет IA маршрутов

Нужен show run для router ospf и пример префикса, который виден в show ip ospf database, но в show ip route x.x.x.x не светится.

New Member

OSPF нет IA маршрутов

router ospf 700 vrf mn

router-id 10.183.127.18

log-adjacency-changes

area 10.183.0.0 authentication message-digest

redistribute static subnets route-map redistr-static

passive-interface Vlan724

network 10.13.70.0 0.0.0.255 area 10.183.0.0

network 10.183.127.0 0.0.0.255 area 10.183.0.0

Gateway of last resort is 10.183.127.17 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 24 subnets, 4 masks

C       10.191.183.0/24 is directly connected, Vlan721

O E1    10.191.182.0/24 [110/21] via 10.183.127.22, 03:57:44, Vlan726

O       10.183.168.0/24 [110/4] via 10.183.127.17, 03:57:44, Vlan725

O E2    10.183.160.0/24 [110/20] via 10.183.127.17, 03:57:44, Vlan725

O       10.183.144.0/24 [110/3] via 10.183.127.17, 03:57:44, Vlan725

O       10.183.128.0/24 [110/4] via 10.183.127.17, 03:57:44, Vlan725

C       10.13.70.0/24 is directly connected, Vlan724

O E1    10.182.254.0/24 [110/21] via 10.183.127.22, 03:57:44, Vlan726

O       10.13.67.16/28 [110/3] via 10.183.127.17, 03:57:44, Vlan725

O       10.13.67.224/28 [110/3] via 10.183.127.17, 03:57:44, Vlan725

O       10.13.67.240/29 [110/4] via 10.183.127.17, 03:57:44, Vlan725

S       10.183.1.0/24 [1/0] via 10.191.183.12

O E1    10.182.1.0/24 [110/21] via 10.183.127.22, 03:57:44, Vlan726

O E1    10.182.2.0/24 [110/21] via 10.183.127.22, 03:57:44, Vlan726

S       10.183.2.0/24 [1/0] via 10.191.183.12

O       10.183.127.0/30 [110/2] via 10.183.127.17, 03:57:44, Vlan725

O       10.183.127.4/30 [110/3] via 10.183.127.17, 03:57:44, Vlan725

O       10.183.127.8/30 [110/2] via 10.183.127.17, 03:57:44, Vlan725

O       10.183.127.12/30 [110/3] via 10.183.127.17, 03:57:44, Vlan725

C       10.183.127.16/30 is directly connected, Vlan725

O       10.13.66.144/28 [110/4] via 10.183.127.17, 03:57:44, Vlan725

C       10.183.127.20/30 is directly connected, Vlan726

S       10.183.65.0/24 [1/0] via 10.191.183.12

S       10.183.64.0/24 [1/0] via 10.191.183.12

S*   0.0.0.0/0 [1/0] via 10.183.127.17

#show ip ospf database summary 10.13.65.0

            OSPF Router with ID (192.168.1.10) (Process ID 702)

            OSPF Router with ID (10.192.134.8) (Process ID 603)

            OSPF Router with ID (10.23.255.5) (Process ID 499)

            OSPF Router with ID (10.192.168.11) (Process ID 400)

            OSPF Router with ID (10.183.127.18) (Process ID 700)

                Summary Net Link States (Area 10.183.0.0)

  LS age: 235

  Options: (No TOS-capability, DC, Upward)

  LS Type: Summary Links(Network)

  Link State ID: 10.13.65.0 (summary Network Number)

  Advertising Router: 10.183.127.1

  LS Seq Number: 80000009

  Checksum: 0x1087

  Length: 28

  Network Mask: /24

        TOS: 0  Metric: 3

OSPF нет IA маршрутов

Надеюсь, делаете "show ip route vrf mn"?

New Member

Re: OSPF нет IA маршрутов

Да, конечно.

#show ip route vrf mn

В данный момент меня спасает вот эта статика

S*   0.0.0.0/0 [1/0] via 10.183.127.17

OSPF нет IA маршрутов

Было бы еще здорово:

show ip ospf neighbor detail

Ну и конфиг OSPF с ABR, вдруг пригодится.

New Member

OSPF нет IA маршрутов

Dmitriy Zhiznevskiy wrote:

Было бы еще здорово:

show ip ospf neighbor detail

Ну и конфиг OSPF с ABR, вдруг пригодится.

# show ip ospf neighbor detail

Neighbor 10.183.127.22, interface address 10.183.127.22

    In the area 10.183.0.0 via interface Vlan726

    Neighbor priority is 1, State is FULL, 6 state changes

    DR is 10.183.127.21 BDR is 10.183.127.22

    Options is 0x52

    LLS Options is 0x1 (LR)

    Dead timer due in 00:00:35

    Neighbor is up for 04:48:12

    Index 3/3, retransmission queue length 0, number of retransmission 1

    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

    Last retransmission scan length is 2, maximum is 2

    Last retransmission scan time is 0 msec, maximum is 0 msec

Neighbor 10.183.127.1, interface address 10.183.127.17

    In the area 10.183.0.0 via interface Vlan725

    Neighbor priority is 1, State is FULL, 6 state changes

    DR is 10.183.127.17 BDR is 10.183.127.18

    Options is 0x52

    LLS Options is 0x1 (LR)

    Dead timer due in 00:00:38

    Neighbor is up for 05:10:53

    Index 1/1, retransmission queue length 0, number of retransmission 1

    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

    Last retransmission scan length is 1, maximum is 1

    Last retransmission scan time is 0 msec, maximum is 0 msec

TIH_3900#sh run | b router ospf

router ospf 100

router-id 10.183.127.1

area 10.183.0.0 authentication message-digest

network 10.176.127.0 0.0.0.255 area 0

network 10.183.127.0 0.0.0.255 area 10.183.0.0

network 10.184.127.4 0.0.0.3 area 10.177.0.0

OSPF нет IA маршрутов

А если сказать "capability vrf-lite" под "router ospf"?

Re: OSPF нет IA маршрутов

Я, кстати, нашел идентичную проблему.

https://supportforums.cisco.com/thread/2135001

Вообще, странно, что LSA не отмечается как downward. Но видимо, поведение может отличаться.

OSPF нет IA маршрутов

Выложите L3 топологию в двух словах. Сколько зон в OSPF какие маршруты вы хотите получать как IA. Есть ли редистрибуции из EIGRP.

Может какой distribute лист  на ABR.

Не забываем оценивать полезные посты.

----------------------------------------------------------- Прошу вас оценивать и отмечать полезные для вас сообщения. Please rate helpful answers.
New Member

OSPF нет IA маршрутов

Re: OSPF нет IA маршрутов

Могли бы вы сказать:

получаете ли вы на ABR  маршруты от 3750-го из зоны 10.183.0.0/10.13.70.0?

На интерфейсах ABR в сторону 3750 стоят ли какие-нибудь политики, или листы доступа?

На интерфейсах 3750 в сторону ABR стоят ли какие-нибудь политики, или листы доступа?

Что показывает Debug OSPF аутентификация не капризничает? Пакеты приходят от ABR?

Вполне возможно из за присутвующего приоритетного маршрута 0,0,0,0 в таблицу маршрутизации не добавляется маршруты от других зон о которых знает ABR. Попробуйте для теста убрать дефолт маршрут и проверить появятся ли IA или увеличить maximum-paths в OSPF.

Проверьте на ABR sh ip route 10.13.70.0 longer

Не забываем оценивать полезные посты.

----------------------------------------------------------- Прошу вас оценивать и отмечать полезные для вас сообщения. Please rate helpful answers.

OSPF нет IA маршрутов

"Вполне возможно из за присутвующего приоритетного маршрута 0,0,0,0 в таблицу маршрутизации не добавляется маршруты от других зон о которых знает ABR"

Восхитительно...

New Member

Re: OSPF нет IA маршрутов

Проверьте на ABR sh ip route 10.13.70.0 longer

Во всех ареях маршрут на данную сеть присутствует:

#show ip route 10.13.70.0

Routing entry for 10.13.70.0/24

  Known via "ospf 100", distance 110, metric 53, type inter area

  Last update from 10.182.127.1 on GigabitEthernet0/1.730, 20:29:36 ago

  Routing Descriptor Blocks:

  * 10.182.127.1, from 10.182.224.11, 20:29:36 ago, via GigabitEthernet0/1.730

      Route metric is 53, traffic share count is 1

446
Просмотры
35
Полезный материал
13
Ответы
СоздатьДля создания публикации, пожалуйста в систему