Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

OSPF, NSSA Area и Redistribute Route

            Здравствуйте!

У меня возникла следующая проблема, в NSSA Area не приходят внешние маршруты (Redistribute Route).

Собрал следующий стенд для проверки:

R1 (871) - R2 (1841) - R3 (7206VXR) - R4 (2811)

Конфигурация R1:

interface FastEthernet4

ip address 10.1.91.1 255.255.255.0

interface Loopback0

ip address 10.1.92.1 255.255.255.0

router ospf 1

router-id 10.1.91.1

network 10.1.91.0 0.0.0.255 area 0.0.0.91

redistribute connected subnets

Конфигурация R2:

interface FastEthernet0/0

ip address 10.1.90.2 255.255.255.0

interface FastEthernet0/1

ip address 10.1.91.2 255.255.255.0

router ospf 1

router-id 10.1.90.2

network 10.1.91.0 0.0.0.255 area 0.0.0.91

network 10.1.90.0 0.0.0.255 area 0.0.0.0

Конфигурация R3:

interface GigabitEthernet0/1.28

encapsulation dot1Q 28

ip address 10.1.90.1 255.255.255.0

interface GigabitEthernet0/1.29

encapsulation dot1Q 29

ip address 10.1.93.1 255.255.255.0

router ospf 1

router-id 10.1.90.1

area 0.0.0.93 nssa

network 10.1.90.0 0.0.0.255 area 0.0.0.0

network 10.1.93.0 0.0.0.255 area 0.0.0.93

Конфигурация R4:

interface FastEthernet0/0

ip address 10.1.93.2 255.255.255.0

router ospf 1
  router-id 10.1.93.2
  area 0.0.0.93 nssa

  network 10.1.93.0 0.0.0.255 area 0.0.0.93

     Маршрут от R1 успешно доходит до R2 (видно как E2 маршрут) и R3 (видно как Е2 маршрут). Но на R4 его нет. Нет ни в таблице маршрутизации, ни в OSPF Database.

     Такая же ситуация если делать редистрибьюцию маршрута с R2 (сделать Loopback и добавить на него сеть).

     Но если делать редистрибьюцию маршрута с R3, то он появится на маршрутизаторе R4 в виде N2 маршрута. Т.е все нормально. Но почему этого не происходит, если редистрибьюция делается на маршрутизаторах R1 или R2?

     Если area 0.0.0.93 обычная, не nssa, то внешний маршрут приходит нормально.

     Соответственно вопрос. Что не так? Возможно не хватает каких-то настроек?

Теги (3)
1 УТВЕРЖДЕННОЕ РЕШЕНИЕ

Утвержденные решения

Re: OSPF, NSSA Area и Redistribute Route

NSSA может пропускать редистрибуцию (LSA7) но не может принимать внешние маршруты E2 и E1.(LSA5) (Руководство 642-902 страница 320).  Или точнее NSSA не поддерживает редистрибуцию в нее, но подерживает редистрибуцию сквозь нее.

Еще тут: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094a88.shtml

Если использовать текущую конфигурацию что вы указали и только на R3 добавить

area 0.0.0.93 nssa no-summary

то 10.1.92.0 сеть будет видна на R4 но благодаря тому что будет маршрут 0.0.0.0

Не забываем оценивать полезные посты.

----------------------------------------------------------- Прошу вас оценивать и отмечать полезные для вас сообщения. Please rate helpful answers.
2 ОТВЕТ.

Re: OSPF, NSSA Area и Redistribute Route

NSSA может пропускать редистрибуцию (LSA7) но не может принимать внешние маршруты E2 и E1.(LSA5) (Руководство 642-902 страница 320).  Или точнее NSSA не поддерживает редистрибуцию в нее, но подерживает редистрибуцию сквозь нее.

Еще тут: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094a88.shtml

Если использовать текущую конфигурацию что вы указали и только на R3 добавить

area 0.0.0.93 nssa no-summary

то 10.1.92.0 сеть будет видна на R4 но благодаря тому что будет маршрут 0.0.0.0

Не забываем оценивать полезные посты.

----------------------------------------------------------- Прошу вас оценивать и отмечать полезные для вас сообщения. Please rate helpful answers.
New Member

Re: OSPF, NSSA Area и Redistribute Route

     Да похоже все действительно так. А если делать редистрибьюцию с R3, то маршрут на R4 появляется только потому, что он редистрибьютится в area 0.0.0.93 напрямую. Про no-summary, я знаю, но в моем случае он меня не устраивает.

     Спасибо за оперативный ответ.

257
Просмотры
15
Полезный материал
2
Ответы
СоздатьДля создания публикации, пожалуйста в систему