シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

PPPoE(Client) のトラブルシューティング

基本的な PPPoE Client の設定例

pppoe.png

Router_A(config)#interface Ethernet0

Router_A(config-if)#pppoe-client dial-pool-number 1

Router_A(config-if)#exit

Router_A(config)#interface dialer 1
Router_A(config-if)#ip address negotiated
Router_A(config-if)#ip mtu 1454
Router_A(config-if)#ip access-group 100 in
Router_A(config-if)#ip nat outside
Router_A(config-if)#dialer pool 1
Router_A(config-if)#dialer idle-timeout 0
Router_A(config-if)#encapsulation ppp
Router_A(config-if)#ppp authentication chap callin
Router_A(config-if)#ppp chap hostname user-id@isp-id
Router_A(config-if)#ppp chap password cisco
Router_A(config-if)#no shutdown

Router_A(config-if)#exit

Router_A(config)#interface Ethernet0

Router_A(config-if)#pppoe-client dial-pool-number 1

Router_A(config-if)#exit

Router_A(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

もし provider から IPアドレスを事前に通知されている場合は "ip address negotiated" ではなく

"ip unnumbered looopback0 " などとしてやり loopback 0 に ip address を指定します。

Dialer1 の IP address に unnumbered Loopback インターフェイスを使用しているときの NAT 仕様時の注意点

----

interface Dialer1

ip unnumbered Loopback0

ip mtu 1454

ip nat outside

----

上記のような場合、実際に ip address を持っているのは Loopback アドレスになるので nat の overload の設定に気を付けてください。

**** unnumbered  の場合

ip nat inside source list 1 interface Loopback 0 overload

**** negotiated  の場合

ip nat inside source list 1 interface Dialer0 overload

"ip route 0.0.0.0 0.0.0.0 Dialer1" の部分も設定されているかを確認してください。もし、特定の経路を違うインターフェイスに向けたいときは、その経路に対して static route を書いてやれば、ロンゲストマッチでそっちの経路を向くようになります。

PPPoE は基本常時接続ですが、もし、client からの call がある場合に接続する場合は以下の様に設定してください。

1.Dialer インターフェイス配下に

     Router_A(config-if)dialer group X


2.グローバルコンフィグレーションに

Router_A(config)# dialer-list x protocol ip permit


※dialer-list x protocol ip permit の部分は、dialer-list X protocol ip list Y のように、Y の部分に ACL も設定可能です。

MTU の問題

もし、プロバイダーがわからず、mtu の調整で失敗する場合は以下のコマンドを Dialer interface 配下に入れてみてください。

interface Dialer1

ppp mtu adaptive <== これ!

("ppp mtu adaptive" は自分の MTU を、相手の MRU に自動的に合わせてくれる機能。)

---

<MTUとMRUについて>

・MTU(Maximum Transmission Unit) は「1回の送信で送ることができる 最大データサイズ」

・MRU(Maximum Receive Unit) は「1回の受信で受け取ることができる 最大データサイズ」

---

上記を確認後、それでも接続ができない場合はまずは以下の debug をもとに調査を行ってください。

debug ppp authentication

debug ppp negotiation

debug pppoe event

そのほかにもトラブルシューティングをする際は以下の document などが有効

PPP のトラブルシューティング フローチャート

<http://www.cisco.com/cisco/web/support/JP/100/1003/1003936_ppp-tshoot-gen.html>

PPP パスワード認証プロトコル(PAP)の設定とトラブルシューティング

  <http://www.cisco.com/cisco/web/support/JP/102/1021/1021298_config-pap-j.html>

1615
閲覧回数
0
いいね!
0
コメント