キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

MDS FCIP設定例

以下の構成を用いた MDS での FCIP の設定例になります。

fcoe.png


先ず、FCIP で利用する GigabitEthernet interface に IP address を設定します。

MDS9222i-A(config)# interface gigabitethernet 1/1
MDS9222i-A(config-if)# ip add 192.168.1.1 255.255.255.0
MDS9222i-A(config-if)# no shutdown
MDS9222i-Aconfig-if)# exit

--- 対向のMDSと別サブネットの場合は、static route を設定します

MDS9222i-A(config)# ip route ?
  A.B.C.D  Destination prefix


MDS9222i-A(config)# ip route 192.168.2.0 ?
  A.B.C.D  Destination prefix mask

MDS9222i-A(config)# ip route 192.168.2.0 255.255.255.0 ?
  A.B.C.D    Configure the nexthop
  interface  Name of interface to use to get to destination network

MDS9222i-A(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.254 ?
  <CR>
  distance   Administrative distance
  interface  Name of interface to use to get to destination network

MDS9222i-A(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.254 interface ?
  gigabitethernet  Ethernet interface
  mgmt             Management interface
  port-channel     Port Channel interface
  vsan             IPFC VSAN interface

MDS9222i-A(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.254 interface gigabitethernet 1/1

両方の MDS で設定したのち、ping を行い、round trip time を計測します。

ping が失敗するようであれば、"show interface" コマンドで link が上がっているか、"show ips ip route" コマンドで static route が正しく設定されているか確認します。

MDS9222i-A# ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
64 bytes from 192.168.2.2: icmp_seq=1 ttl=254 time=20.5 ms
64 bytes from 192.168.2.2: icmp_seq=2 ttl=254 time=20.4 ms
64 bytes from 192.168.2.2: icmp_seq=3 ttl=254 time=20.4 ms

--- 192.168.2.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2012ms
rtt min/avg/max/mdev = 20.419/20.462/20.508/0.036 ms

MDS9222i-A# show interface gigabitethernet 1/1
GigabitEthernet1/1 is up
    Hardware is GigabitEthernet, address is 0017.94ee.39a6
    Internet address is 192.168.1.1/24
    MTU 1500  bytes
    Port mode is IPS
    Speed is 1 Gbps
    Beacon is turned off
    Auto-Negotiation is turned on
    5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    63 packets input, 25474 bytes
      0 multicast frames, 0 compressed
      0 input errors, 0 frame, 0 overrun 0 fifo
    68 packets output, 25616 bytes, 0 underruns
      0 output errors, 0 collisions, 0 fifo
      0 carrier errors


MDS9222i-A# show ips ip route interface gigabitethernet 1/1
Codes: C - connected, S - static

No default gateway

S 192.168.2.0/24 via 192.168.1.254, GigabitEthernet1/1
C 192.168.1.0/24 is directly connected, GigabitEthernet1/1

fcip を有効にした後、fcip profile、fcip interface を作ります。

MDS9222i-A(config)# feature fcip
MDS9222i-A(config)#

MDS9222i-A(config)# fcip profile 1

--- fcip で利用する GigabitEthernet に指定した ip address を指定します
MDS9222i-A(config-profile)# ip address 192.168.1.1

--- fcip が利用する最大帯域幅、最低保障帯域幅、計測した round trip time を指定します。

--- 最大帯域幅は利用できる回線容量を超えないよう、最低保障帯域は必ず確保できる帯域以上に設定しないでください。

MDS9222i-A(config-profile)# tcp max-bandwidth-mbps 100 min-available-bandwidth-mbps 30 round-trip-time-ms 20

--- fcip interface を作ります

MDS9222i-A(config)# interface fcip 1

--- 先に作った fcip profile を指定します
MDS9222i-A(config-if)# use-profile 1

--- 対向の MDS で fcip に利用する ip address を指定します
MDS9222i-A(config-if)# peer-info ipaddr 192.168.2.2

--- 圧縮を有効にします(オプション)
MDS9222i-A(config-if)# ip-compression ?
  <CR>
  auto   Auto compression setting
  mode1  Fast compression for high bandwidth links
  mode2  Moderate compression for medium bandwidth links
  mode3  High compression for low bandwidth links

MDS9222i-A(config-if)# ip-compression auto

--- fcip を越えての通信許可する VSAN を指定します(オプション) 指定がなければ全ての VSAN が許可されます。

MDS9222i(config-if)# switchport trunk allowed vsan 101

MDS9222i-A(config-if)# no shutdown

両方の MDS で設定が終了したら、fcip interface が上がているか、対向の MDS に接続されているデバイスが name server に登録されているか確認します。

MDS9222i# show interface fcip 1

fcip1 is trunking
    Hardware is GigabitEthernet
    Port WWN is 20:14:00:0d:ec:6c:37:80
    Peer port WWN is 20:54:00:0d:ec:0e:ec:00
    Admin port mode is auto, trunk mode is on
    snmp link state traps are enabled
    Port mode is TE
    Port vsan is 1
    Speed is 1 Gbps
    Trunk vsans (admin allowed and active) (101)
    Trunk vsans (up)                       (101)
    Trunk vsans (isolated)                 ()
    Trunk vsans (initializing)             ()
    Interface last changed at Tue Sep 28 12:29:57 2010

    Using Profile id 1  (interface GigabitEthernet1/1)
    Peer Information
      Peer Internet address is 192.168.2.2 and port is 3225
    Write acceleration mode is configured off
    Tape acceleration mode is configured off
    Tape Accelerator flow control buffer size is automatic
    FICON XRC Accelerator is configured off
    Ficon Tape acceleration configured off for all vsans
    IP Compression is enabled and set for auto
    Maximum number of TCP connections is 2
    QOS control code point is 0
    QOS data code point is 0
    TCP Connection Information
      2 Active TCP connections
        Control connection: Local 192.168.1.1:3225, Remote 192.168.2.2:65519
        Data connection: Local 192.168.1.1:3225, Remote 192.168.2.2:65521
      14 Attempts for active connections, 2 close of connections
    TCP Parameters
      Path MTU 1500 bytes
      Current retransmission timeout is 200 ms
      Round trip time: Smoothed 24 ms, Variance: 12 Jitter: 150 us
      Advertized window: Current: 5727 KB, Maximum: 5727 KB, Scale: 6
      Peer receive window: Current: 237 KB, Maximum: 237 KB, Scale: 6
      Congestion window: Current: 213 KB, Slow start threshold: 225 KB
      Current Send Buffer Size: 6239 KB, Requested Send Buffer Size: 0 KB
      CWM Burst Size: 50 KB
      Measured RTT : 500000 us Min RTT: 500000 us Max RTT: 0 us
    5 minutes input rate 416 bits/sec, 52 bytes/sec, 0 frames/sec
    5 minutes output rate 360 bits/sec, 45 bytes/sec, 0 frames/sec
      1097 frames input, 137356 bytes
         1097 Class F frames input, 137356 bytes
         0 Class 2/3 frames input, 0 bytes
         0 Reass frames
         0 Error frames timestamp error 0
      1100 frames output, 126232 bytes
         1100 Class F frames output, 126232 bytes
         0 Class 2/3 frames output, 0 bytes
         0 Error frames

MDS9222i-A# show fcns database vsan 101

VSAN 101:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x010000    N     50:06:01:68:3c:e0:2d:29 (Clariion)      scsi-fcp
0x020000    N     50:06:01:60:44:60:54:38 (Clariion)      scsi-fcp:

Total number of entries = 2

バージョン履歴
改訂番号
1/1
最終更新:
‎09-28-2010 04:43 PM
更新者:
 
ラベル(1)