シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel

イーサネット仮想回線(EVC)について

このドキュメントは英語版(バージョン8)の日本語訳です。日本語は直訳ではなく、日本のお客様の使用状況に沿って変更を加えている箇所もあります。

最新の内容は英語原文をご確認ください。

 

問題

従来のスイッチでは、トランク インターフェイスが存在する場合は常に VLAN タグを使って VLAN の逆多重化を行います。 スイッチは転送を行うために参照する MAC アドレス テーブルを特定する必要があります。 このため、スイッチで 2 つの処理が実行される必要があります。

 

1.)VLAN をグローバルに構成する

2.)この VLAN で MAC ラーニングを実行する

 

これに伴う課題は、有限なリソースを使用する必要があるという点です。この問題は避けられません。 802.1q VLAN タグは 12 ビット幅しかないため、構成できる VLAN は最大で 4,096 個のみです。 また、スイッチが MAC ラーニングを実行するために使用できる CAM 容量は限られているため、サポート可能なホストの数は制限されます。

最新のプロバイダー環境やクラウド環境では、これらの制限を超えて拡張する必要があります。

 

EVC の使用

イーサネット仮想回線(EVC)を使用すると、既存の 802.1q VLAN タグを最新の方法で利用できます。 従来は VLAN タグによって分類(VLAN の識別)と転送(MAC ルックアップを行うための CAM テーブルの識別)の両方が定義されていました。 今日では、EVC を使用することによってこれらの概念を分離できます。分類は VLAN タグを使用して行い、転送方法はサービス インスタンスによって定義します。 たとえば、すべてのスイッチポートで異なるお客様に VLAN 10 を割り当て、異なる MPLS 疑似配線を介してお客様ごとにトラフィックを転送できますが、VLAN 10 を実際にグローバルで構成する必要はありません。

 

動作のしくみ(イングレス)

802.1q タグ フレームは、EVC を使って構成したインターフェイスで受信されるため、フレームがどの EVC に分類されるかは、フレームのタグに基づいて特定します。 フレームに対して何を行うかを、EVC 内で定義します。 以下のような EVC 構成のサンプルを見ていきましょう。

 

interface GigabitEthernet0/2

switchport trunk allowed vlan none

switchport mode trunk

service instance 6 ethernet

encapsulation dot1q 10

rewrite ingress tag pop 1 symmetric

xconnect 192.168.1.1 33 encapsulation mpls

この構成について 1 つ 1 つ見ていきます。

switchport trunk allowed vlan none

switchport mode trunk

 

これはインターフェイスに対し、トランク インターフェイスで処理する場合のように 802.1q タグを処理するよう指定しています。ただし、実際にはこのインターフェイスを介して VLAN を使用しません。 サービス インスタンス インターフェイスで受信される VLAN タグは、スイッチで構成された VLAN とは直接関係がありません。 また、サービス インスタンス インターフェイスは MAC ラーニングを実行しません(後ほど紹介するブリッジドメイン VLAN インターフェイスを経由する場合を除きます)。 このため、このトランク インターフェイスでは、グローバルに構成された VLAN を許可することは望ましくありません。 必要となるのは、VLAN タグ処理をイネーブルにし、フレームに対して行う処理をサービス インスタンスが判断できるようにすることのみです。

 

service instance 6 ethernet

 

これはサービス インスタンスを定義しています。 数字は任意です。この特定のサービス インスタンスによって処理される VLAN とは関係ありません。「ethernet」キーワードは常に使用されます。

 

encapsulation dot1q 10

 

これは着信タグをサービス インスタンスにマップする方法を指定しています。 VLAN タグ 10 がこのインターフェイスで受信された場合、サービス インスタンス 6 に分類されます。

 

rewrite ingress tag pop 1 symmetric

 

着信タグはこの特定のインターフェイス外では意味を持たないため、フレームを転送する前にこのタグを破棄する必要があります。 rewrite ingress コマンドがこれを実行します。 この場合はタグが 1 つ削除されます。このコマンドはオプションです。これ以外にも、単にタグを削除するだけでなく VLAN 変換や追加タグの適用を含めさまざまなオプションがあります。 これらのオプションのいくつかと「symmetric」キーワードについては、後ほど紹介します。

最後に、このフレームに対する転送アクションを指定します。

 

xconnect 192.168.1.1 33 encapsulation mpls

 

これはフレームを L2VPN MPLS クラウドを介して送信するように指定しています。 この前に rewrite ingress tag pop 1 symmetric コマンドを構成しているので、フレームを VLAN タグを付けずに MPLS 疑似配線を介して送信します。 ルーティングやローカル スイッチング(接続)を含め、さまざまな転送方法があります。

 

動作のしくみ(イーグレス)

フレームが受信されると、このスイッチにどのように届いたかに基づいて、サービス インスタンス インターフェイスに送信するように分類されます。 たとえば、フレームが MPLS 疑似配線 33 を介して受信された場合、このフレームはサービス インスタンス 6 の一部であることが自動的にわかります。

 

引き続き構成の下位から上位へと見ていきます。rewrite ingress tag pop 1 symmetricsymmetric に注目します。 着信タグを 1 つポップしたため、釣り合いをとるために出力タグを 1 つプッシュする必要があります。 symmetric キーワードは常に rewrite コマンドとともに使用されます。

 

どのタグを適用するかは、encapsulation dot1q 10 コマンドによって決まります。 フレームが出力されるとき、インターフェイスは VLAN タグ 10 を適用します。 注意が必要なのは、タグ フレームを送信するアクセス レイヤ デバイスは従来のレイヤ 2 スイッチである場合が多く、正しい分類を行うためには、送信するタグを受信したタグと同じにする必要があるという点です。

 

Flow Direction.png

 

ステップ バイ ステップの例

以下はサンプルのトポロジです。2 つのアクセス スイッチが異なる VLAN を処理しています。 サービス インスタンスは青の PE と紫の PE で構成されています。

 

Example Configuration.png

 

ここではいくつかの点について注意する必要があります。

  • アクセス レイヤ スイッチは別の VLAN タグを送信および受信する
  • サービス インスタンスの数は任意である
  • VLAN タグは MPLS クラウドに送信される前にポップされる

 

Frame Example 1.png

 

アクセス ポートに接続するクライアントは、タグなしのフレームを送信します。 このフレームは、アクセス レイヤ スイッチによって VLAN タグ 10 が追加され、サービス インスタンスが構成されている PE に送信されます。

青い PE は VLAN タグ 10 を参照し、サービス インスタンス 9 に送信します。 「rewrite ingress pop 1 symmetric」コマンドを構成しているため、最初のタグをポップしてから、MPLS ラベルを適用して MPLS クラウドに転送します。

 

Frame Example 2.png

 

ラベル付きパケットが MPLS クラウドから送られるとき、「xconnect」コマンドに基づいて、赤い PE のサービス インスタンス 18 にタグなしのフレームが送信されます。 ここで、「rewrite ingress pop 1 symmetric」コマンドが構成されていること、またこのフレームがイーグレス フレームであることから、タグを 1 つプッシュする必要があることがわかります。 適用するタグは、「encapsulation dot1q」構成によって決まります。この場合、フレームは VLAN タグ 11 が適用されてから、アクセス レイヤ スイッチに送り返されます。

 

EVC オプション

柔軟なマッチング

EVC が非常に強力である理由の 1 つに柔軟なマッチング基準があります。 EVC は 1 つ以上の VLAN タグまたは CoS 値に基づいて非常に柔軟性の高い方法で着信フレームを分類できるようにします。 例をいくつか示します。

 

構成

効果

encapsulation dot1q 10

単一の VLAN タグ 10 に一致する

encapsulation dot1q 25   second-dot1q 13

最初の VLAN タグ 25 と 2 つ目のタグ 13 に一致する

encapsulation   dot1q any second-dot1q 22

2 つのタグが付いていて、2 つ目のタグ 22 が付いているフレームに一致する

encapsulation dot1q 16 cos 4

CoS 値 4 を持つ単一のタグ 16 に一致する

encapsulation dot1q untagged

ネイティブ(タグなし)VLAN に一致する

encapsulation dot1q default

以前に分類されたことのないすべてのトラフィックのすべてのクラスに一致する

 

これはすべてのオプションではありません。例として一部のオプションのみを紹介しています。 タグ マッチングについてもう 1 つ注意が必要なのは、最長一致の基準に従うという点です。

 

書き換えオプション

多数の柔軟なマッチング オプションとともにさまざまなタグ書き換えオプションを提供しています。

 

構成

効果

rewrite   ingress tag pop 1 symmetric

最上位の 802.1q タグを削除する

rewrite   ingress tag pop 2 symmetric

上位 2 つの 802.1q タグを削除する

rewrite   ingress tag translate 1-to-1 dot1q 28 symmetric

最上位のタグを削除してタグ 28 で置き換える

rewrite   ingress tag translate 2-to-2 dot1 22 second-dot1q 23

上位 2 つのタグを削除してタグ 22 と 23 で置き換える(23 は内側タグになる)

rewrite   ingress tag push dot1q 56 second-dot1q 55

既存のフレームの最上位にある 2 つの新しいタグをプッシュする。 最上位タグを 56、内側タグを 55 にする

 

転送オプション

 

EVC は MPLS 擬似回線に接続して MPLS クラウドを介してトラフィックを送信できます。

より柔軟性を高めるため、EVC はブリッジ ドメインの概念を導入しています。 ブリッジ ドメインは、従来レイヤ 3 SVI と見なされているものです。 構成した EVC によって処理される VLAN タグと異なり、ブリッジ ドメインではデバイスで VLAN をグローバルに構成し、プラットフォーム規模のリソースを使用する必要があります。

以下はブリッジ ドメインを使って構成されたインターフェイスの例です。

 

interface g0/2

service instance 1 ethernet

encapsulation dot1q 18

rewrite ingres tag pop 1 symmetric

bridge-domain 44

!

interface Vlan44

ip address 192.168.1.1 255.255.255.0

 

VLAN タグなしのパケットは VLAN 44 インターフェイスに渡され、通常のルーティングが実行されます。

複数のサービス インスタンスを同じブリッジ ドメインに結び付けて、タグ付きトラフィック転送の柔軟性を高めることができます。

 

interface g0/2

service instance 1 ethernet

encapsulation dot1q 18

rewrite ingres tag pop 1 symmetric

bridge-domain 44

service instance 2 ethernet

encapsulation dot1q 66

rewrite ingress tag pop 1 symmetric

bridge-domain 44

!

interface Vlan44

ip address 192.168.1.1 255.255.255.0

 

この構成で、サービス インスタンスは相互に通信することも、他のルートのサブネットにルーティングすることもできます。 さらに広く見ると、Vlan 44 は 2 つのサービス インスタンスをブリッジングし、MAC ラーニングに基づいてフレームを転送します。 フレームがサービス インスタンス 1 に入ると、VLAN タグが削除され、宛先 MAC ルックアップが行われる Vlan 44 にフレームが渡されます。 宛先が他のサービス インスタンスである場合、フレームはサービス インスタンス 2 に入り、新しい VLAN タグが追加されます。

 

ブリッジ ドメインでは「スプリット ホライズン」(bridge-domain 44 split-horizon)の構成も許可されます。EVC 間の通信を防いで、ブリッジ ドメイン外へのルーティングのみが許可されるようにできます。

 

最後に、複数の EVC を選択し、これらすべてを MPLS 疑似配線を経由して送信できます。

 

interface g0/2

service instance 1 ethernet

encapsulation dot1q 18

rewrite ingres tag pop 1 symmetric

bridge-domain 44

service instance 2 ethernet

encapsulation dot1q 66

rewrite ingress tag pop 1 symmetric

bridge-domain 44

!

interface Vlan44

xconnect 192.168.1.1 55 encapsulation mpls

 

これにより、2 つの異なる VLAN を選択し、VLAN タグを削除し、同じ MPLS エンドポイントに送信することができます。 このシナリオでは MAC ラーニングは実行されず、複数の VLAN を単一の MPLS 疑似配線を介して送信できます。

 

最後に

EVC が動作する方法は従来のスイッチングとは大幅に異なるため、一部のスイッチング プラットフォームでは EVC フレーム操作を転送アクションと切り離して行えません。 me3600x や me3800x のような新しいプラットフォーム は、このような機能を念頭に置いてゼロから設計されました。 7600 プラットフォームでは、スーパーバイザ エンジンや DFC 転送エンジンが実行できない作業を行うためには、新しいイーサネット サービス(ES)モジュールが必要になります。 また、このガイドにはサポート対象となるすべてのプラットフォームと構成は記載されていません。一部の導入オプション、および新しい EVC 環境でトラフィック転送を運用する方法のみを紹介しています。

4226
閲覧回数
5
いいね!
0
コメント