シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

【ASR1000】VASIとNATの設定例

 

ASR1000シリーズで使えるVASIの基本的な設定と

異なるVRFを通過する通信にNAT実施する設定を紹介します。

因みに、ISR(IOS)では異なるVRF間のNATするにはNVIを使用します。

ISRではVASIは設定できません。

NVIについては下記をご参照ください。

NVIの設定例 ~異なるVRF間でNATを行う

 


 

VASIの基本的な設定

NW構成図は下記です。

ASR1000での設定です。

VRFを作成します。

ip vrf A
ip vrf B

InterfaceにVRFとIPアドレスを付与します。

interface GigabitEthernet0/0/1
ip vrf forwarding A
ip address 10.0.0.254 255.255.255.0
negotiation auto

interface vasileft1
ip vrf forwarding A
ip address 172.30.0.254 255.255.255.0
no keepalive

interface GigabitEthernet0/0/0
ip vrf forwarding B
ip address 192.168.0.254 255.255.255.0
negotiation auto

interface vasiright1
ip vrf forwarding B
ip address 172.31.0.254 255.255.255.0
no keepalive

VASIにルーティングします。

ip route vrf A 0.0.0.0 0.0.0.0 vasileft1
ip route vrf B 0.0.0.0 0.0.0.0 vasiright1

VASIはIDを用いてペアに自動的になります。

ここでは1がIDです。

ペアになった時点でvasiright1とvasileft1がUPします。

ペアになるとお互いに自動的にパケットが転送されるようになります。

ただ、G0/0/0やG0/0/1からVASIへルーティングする必要があります。

#ルータA、ルータBでもDefault RouteをASRに向けるなどしてください。


 

VASIを用いた異なるVRFを通過する通信へのNATの設定

VRF AのG0/0/1でPATしてみます。

NAT Insideをvasileft1として、NAT OutsideはG0/0/1とします。

異なるVRFを通過する際にNATをすることができます。

NW構成図は下記です。


ASR1000での設定です。

追加箇所を太文字にしています。

ip vrf A
ip vrf B

interface GigabitEthernet0/0/1
ip vrf forwarding A
ip address 10.0.0.254 255.255.255.0
ip nat outside
negotiation auto

interface vasileft1
ip vrf forwarding A
ip address 172.30.0.254 255.255.255.0
ip nat inside
no keepalive

interface GigabitEthernet0/0/0
ip vrf forwarding B
ip address 192.168.0.254 255.255.255.0
negotiation auto

interface vasiright1
ip vrf forwarding B
ip address 172.31.0.254 255.255.255.0
no keepalive

ip nat inside source list 10 interface GigabitEthernet0/0/1 vrf A overload
access-list 10 permit 192.168.0.1

ip route vrf A 0.0.0.0 0.0.0.0 vasileft1
ip route vrf B 0.0.0.0 0.0.0.0 vasiright1

 

確認してみましょう。

ルータB(192.168.0.1)よりルータA(10.0.0.1)へPingします。

送信元IPアドレスが192.168.0.1から10.0.0.254に変換されます。


 

参考
VRF-Aware Software インフラストラクチャの設定

545
閲覧回数
5
いいね!
0
コメント