シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

C892W を使用したwireless bridging 接続設定

1. Introduction

C892W を使用したwireless bridging 接続のコンフィグ設定を紹介します。

wireless bridge 接続をすることで、wireless 接続client から、C892W に有線で接続されているネットワークへの接続が可能となります

2.  Configurations

本事例では、Wireless 側の接続用にDHCP(WLAN)有線接続用にDHCP(LAN)を設定し、それぞれ、異なるIP アドレスレンジをDHCPに割当てるように設定します。

2-1.  AP へのログイン、ログアウト

C892W では、APRouterがそれぞれ独立して動作しており、AP側の設定については、Router からのログインが必要となります。

ログイン方法については、下記のようになっています。

APへのログイン     : service-module wlan-ap 0 session
APからのログアウト : [Ctrl+Shift+6]を同時に押した後に、[x]を入力
                  service-module wlan-ap 0 session clear

2-2.  AP側 configuration

!
hostname ap
!
dot11 syslog
!
dot11 ssid TEST
   vlan 110
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii 7 xxxxxxxxxxxxxxxxxx
! --- SSID を作成し、特定のradio interfeceへ割当てます
!
bridge irb
!
interface Dot11Radio0
 no ip address
 !
 ssid TEST
 !
 antenna gain 0
 channel 2412
! --- radio channelの周波数を設定します
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.110
 encapsulation dot1Q 110
 no ip route-cache
 bridge-group 110
 bridge-group 110 subscriber-loop-control
 bridge-group 110 block-unknown-source
 no bridge-group 110 source-learning
 no bridge-group 110 unicast-flooding
 bridge-group 110 spanning-disabled
! --- VLAN110 用のDot11Radio を作成します
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 antenna gain 0
 no dfs band block
 station-role root
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
 description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
 no ip address
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.110
 encapsulation dot1Q 110
 no ip route-cache
 bridge-group 110
 no bridge-group 110 source-learning
 bridge-group 110 spanning-disabled
! --- Gi0.110 にbridge-group 110を関連付けます
!
interface BVI1
 ip address 192.168.0.2 255.255.255.0
 no ip route-cache
! --- 管理接続用のBVI 1にIPアドレスを割当てます
!
ip default-gateway 192.168.0.1
!
bridge 1 route ip
! --- 特定のbridge group に対してrouting を有効にします
!
end

2-3.  Router側 configuration

!
hostname C892W
!
service-module wlan-ap 0 bootimage autonomous
!
no ip routing
!--- ip routingをdisableにし、bridging を使用できるようにします
!
ip dhcp pool lan
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 192.168.1.4
! --- 有線接続用にDHCP(LAN)を設定します
!
ip dhcp pool wlan
 network 192.168.0.0 255.255.255.0
 dns-server 192.168.0.4
 default-router 192.168.0.1
! --- AP管理用にDHCP(WLAN)を設定します
!
bridge irb
! --- IRBを有効にし、Interface とbridge group の間でbridge 接続できるようにします
!
interface FastEthernet0
 switchport access vlan 110
 no ip address
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip unnumbered Vlan100
! --- APへの管理接続用にIPを振ります
 no ip route-cache
 arp timeout 0
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 switchport mode trunk
! --- default 設定では、mode trunk となっていません
 no ip address
!
interface Vlan100
 ip address 192.168.0.1 255.255.255.0
 no ip route-cache
!
interface Vlan110
 ip address 192.168.1.1 255.255.255.0
!
!
bridge 1 protocol ieee
! --- Spanning Tree Protocol のTypeを設定します
bridge 1 route ip
! --- 特定のbridge group に対してrouting を有効にします
!
end

3.  Verifications

"show dot11 associations"、"show ip dhcp binding"にて接続状況を確認します。 wireless client に、"192.168.1.4"のIPアドレスが割り当てられています。

ap#sh dot11 associations

802.11 Client Stations on Dot11Radio0:

SSID [TEST] :

MAC Address    IP address      Device        Name            Parent         State
0040.96af.7db4 192.168.1.4     unknown       -               self           Assoc 

C892W#sh ip  dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.1.2         0063.6973.636f.2d35.    Nov 05 2015 11:48 PM    Automatic
                    3035.372e.6138.6565.
                    2e61.3431.392d.566c.
                    3131.30
192.168.1.4         0100.4096.af7d.b4       Nov 06 2015 11:09 AM    Automatic
199
閲覧回数
5
いいね!
0
コメント