シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

Cisco機器を用いた DHCP によるIPアドレス自動取得動作の確認と解説 (DHCPv6)

本ドキュメントは IPv4, IPv6 の DHCP によるIPアドレス払い出しの動作概要と確認方法を説明します。以下のドキュメントも参考にしてください。

Cisco機器を用いた DHCP によるIPアドレス自動取得動作の確認と解説 (概要・IPv4 DHCP)

Cisco機器を用いた DHCP によるIPアドレス自動取得動作の確認と解説 (DHCPv6-PD)

3. Stateless DHCPv6 / Statefull DHCPv6

IPv4 の DHCP は動作として非常にシンプルですが、IPv6 ではアドレスの自動アサインのために RA(Router Advertisement) という機能があり、 同様の目的となる DHCPv6 との住み分けの点から、いくつかの構成パターンを理解する必要があります。
また、前提として DHCPv6 では現状 DHCPv4 の時に実現できていた Default Gateway を自動で割り当てる機能が備わっていないため、ネットワークへ接続した機器を自動で通信させるためには RA によるアドレスアサイン機能を使用する必要があります。

ここでは単純な Stateless DHCPv6 と Stateful DHCPv6 の構成例を下記に示します。

Stateful DHCPv6 は IPv4 DHCP のように DHCP サーバによるアドレス払い出しを行ないます。
一方 Stateless DHCPv6 は DHCPv6 Server による アドレス払い出しを行なわず、 RA(Router Advertisement) によるアドレスと Default Gateway の払い出しを行ないます。

上記構成を元にDHCPv6 の基本的な動作の確認と Stateless DHCPv6 と Statefull DHCPv6 の違いを説明します。

DHCPv6 Server を以下のように構成しています。
- VLAN10, VLAN30 のセグメントに対してアドレス情報を払い出すために、
  アドレスプールを割り当てています (Stateful DHCPv6)
- VLAN20 では DHCPv6 によるアドレスの払い出しをせず、
  DNS情報のみを配布するよう構成しています (Stateless DHCPv6)

 

DHCPv6 Relay を以下のように構成しています。
- VLAN10, VLAN20 には RA による IPv6 を広報しつつ
  Client に DHCPv6 情報を取得させます (ipv6 nd other-config-flag)
- VLAN30 は RA による IPv6 を広報し、
  Client に DHCPv6 情報を取得させないないようにします (no ipv6 nd other-config-flag)

 

各 DHCPv6 Client の設定は図の通りです。

結果は以下のようになります。
Client A: DHCPv6 による情報取得を行い、RA による Default Gateway を割り当てを受け入れる
Client B: RA による IPv6 アドレス、 Default Gateway を割り当て、DNS 情報などの DHCPv6 情報も取得する
Client C: DHCPv6 による情報取得を行い、RA による Default Gateway を割り当てを受け入れる
Client D: RA による IPv6 アドレス、 Default Gateway を割り当てるが、 DNS 情報など DHCPv6 情報を取得しない

 

まず、DCHPv6 サーバでの binding 情報は下記の通りとなります。

後述しますが、Client-A, Client-C に対し、それぞれのVLANセグメントに応じてアドレスが払いだされている状況が確認できます。

DHCPv6-Server#show ipv6 dhcp binding
Client: FE80::A8BB:CCFF:FE02:FB10 
  DUID: 00030001AABBCC02FB00
  Username : unassigned
  VRF : default
  IA NA: IA ID 0x00040001, T1 43200, T2 69120
    Address: 2001:DB8:1000:0:553E:9CE5:6B8A:7E74
            preferred lifetime INFINITY, , valid lifetime INFINITY, 
Client: FE80::A8BB:CCFF:FE02:FD30 
  DUID: 00030001AABBCC02FD00
  Username : unassigned
  VRF : default
  IA NA: IA ID 0x00060001, T1 43200, T2 69120
    Address: 2001:DB8:3000:0:74C8:EAE3:D0D7:C931
            preferred lifetime INFINITY, , valid lifetime INFINITY, 

Client-Aでは以下の通りVLAN 10セグメントのIPv6アドレスをDHCPv6サーバより受信していることがわかります。

また、同時にDNS Server情報も登録されています。

Client-A#show ipv6 dhcp interface
Ethernet0/1 is in client mode
  Prefix State is IDLE
  Address State is OPEN
  Renew for address will be sent in 11:59:03
  List of known servers:
    Reachable via address: FE80::A8BB:CCFF:FE02:FA10
    DUID: 00030001AABBCC02F900
    Preference: 0
    Configuration parameters:
      IA NA: IA ID 0x00040001, T1 43200, T2 69120
        Address: 2001:DB8:1000:0:6C2E:D93E:184:DF2C/128
                preferred lifetime INFINITY, valid lifetime INFINITY
      DNS server: 2001:DB8:F000::FFFF
      Domain name: example.com
      Information refresh time: 0
  Prefix Rapid-Commit: disabled
  Address Rapid-Commit: disabled

実際の設定は下記のようにインストールされました。

この時、デフォルトゲートウェイ(::/0) は "ND" となっており、RAによりデフォルトゲートウェイが自動登録されたことが判ります。

Client-A#show ipv6 interface e0/1
  Global unicast address(es):
    2001:DB8:1000:0:6C2E:D93E:184:DF2C, subnet is 2001:DB8:1000:0:6C2E:D93E:184:DF2C/128 

Client-A#show ipv6 route
ND  ::/0 [2/0]
     via FE80::A8BB:CCFF:FE02:FA10, Ethernet0/1
LC  2001:DB8:1000:0:6C2E:D93E:184:DF2C/128 [0/0]
     via Ethernet0/1, receive

Client-A はネットワークに接続するだけで、lo0.example.com へ通信可能となります。

Client-A#ping ipv6 lo0.example.com    
Translating "lo0.example.com"...domain server (2001:DB8:F000::FFFF) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:9000::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Client-Bでは下記の通り、DHCPv6情報は受信しているものの、アドレスプレフィックスの払い出しを受けていません。

Client-B#show ipv6 dhcp interface
Ethernet0/1 is in client mode
  Prefix State is IDLE (0)
  Information refresh timer expires in 23:59:57
  Address State is SOLICIT (4)
  Retransmission timer expires in 00:00:05
  List of known servers:
    Reachable via address: FE80::A8BB:CCFF:FE02:FA20
    DUID: 00030001AABBCC02F900
    Preference: 0
    Configuration parameters:
      DNS server: 2001:DB8:F000::FFFF
      Domain name: example.com
      Information refresh time: 0
  Prefix Rapid-Commit: disabled
  Address Rapid-Commit: disabled

しかし、IPv6アドレス、デフォルトゲートウェイ共に自動で設定されています。

これはDHCPv6ではなく、RAによる払い出しが行なわれたためです。

Client-B#show ipv6 interface e0/1
  Global unicast address(es):
    2001:DB8:2000:0:A8BB:CCFF:FE02:FC20, subnet is 2001:DB8:2000::/64 [EUI/CAL/PRE]
      valid lifetime 2591984 preferred lifetime 604784

Client-B#show ipv6 route
ND  ::/0 [2/0]
     via FE80::A8BB:CCFF:FE02:FA20, Ethernet0/1
NDp 2001:DB8:2000::/64 [2/0]
     via Ethernet0/1, directly connected
L   2001:DB8:2000:0:A8BB:CCFF:FE02:FC20/128 [0/0]
     via Ethernet0/1, receive

DHCPv6-Relay サーバの interface Ethernet0/2 (VLAN20) には" ipv6 nd other-config-flag" が設定されており、これによりRAルータはアドレスの払い出し先の端末に対し、他の情報は DHCPv6 より取得するよう、通知することが可能です。

 

Client-C は Client-A 同様です。

アドレス情報として VLAN30 のアドレスセグメントが自動的に払いだされています。

Client-C#show ipv6 dhcp interface
Ethernet0/1 is in client mode
  Prefix State is IDLE
  Address State is OPEN
  Renew for address will be sent in 11:58:18
  List of known servers:
    Reachable via address: FE80::A8BB:CCFF:FE02:FA30
    DUID: 00030001AABBCC02F900
    Preference: 0
    Configuration parameters:
      IA NA: IA ID 0x00060001, T1 43200, T2 69120
        Address: 2001:DB8:3000:0:841D:F00A:BCE8:E374/128
                preferred lifetime INFINITY, valid lifetime INFINITY
      DNS server: 2001:DB8:F000::FFFF
      Domain name: example.com
      Information refresh time: 0
  Prefix Rapid-Commit: disabled
  Address Rapid-Commit: disabled

 

Client-C#show ipv6 interface e0/1
  Global unicast address(es):
    2001:DB8:3000:0:841D:F00A:BCE8:E374, subnet is 2001:DB8:3000:0:841D:F00A:BCE8:E374/128 

Client-C#show ipv6 route
ND  ::/0 [2/0]
     via FE80::A8BB:CCFF:FE02:FA30, Ethernet0/1
LC  2001:DB8:3000:0:841D:F00A:BCE8:E374/128 [0/0]
     via Ethernet0/1, receive

Client-D は Client-B 同様、RAによるアドレス自動払い出しが行なわれますが、
DHCPv6-Relay サーバにて " ipv6 nd other-config-flag" が設定されていないため、DHCPv6への情報取得が行なわれません。

Client-D#show ipv6 dhcp interface
--------- no output --------

下記の通り自動的にアドレス情報は設定されますが、DNS情報は存在しないため、FQDNの名前解決はできません。

Client-D#show ipv6 interface e0/1
  Global unicast address(es):
    2001:DB8:3000:0:A8BB:CCFF:FE02:FE30, subnet is 2001:DB8:3000::/64 [EUI/CAL/PRE]
      valid lifetime 2591878 preferred lifetime 604678

Client-D#show ipv6 route
ND  ::/0 [2/0]
     via FE80::A8BB:CCFF:FE02:FA30, Ethernet0/1
NDp 2001:DB8:3000::/64 [2/0]
     via Ethernet0/1, directly connected
L   2001:DB8:3000:0:A8BB:CCFF:FE02:FE30/128 [0/0]
     via Ethernet0/1, receive

参考までに設定情報を下記に記載します。

--- DHCPv6 Server ---
ipv6 unicast-routing
ip host lo0.example.com 2001:DB8:9000::1

interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ipv6 address 2001:DB8:F000::FFFF/128
 ipv6 enable

ipv6 dhcp pool Statefull_DHCPv6_VLAN10
 address prefix 2001:DB8:1000::/64 lifetime infinite infinite
 link-address 2001:DB8:1000::1/64
 dns-server 2001:DB8:F000::FFFF
 domain-name example.com

ipv6 dhcp pool Statefull_DHCPv6_VLAN20
 link-address 2001:DB8:2000::1/64
 dns-server 2001:DB8:F000::FFFF
 domain-name example.com

ipv6 dhcp pool Stateless_DHCPv6_VLAN30
 address prefix 2001:DB8:3000::/64 lifetime infinite infinite
 link-address 2001:DB8:3000::1/64
 dns-server 2001:DB8:F000::FFFF
 domain-name example.com


interface Ethernet0/0
 ipv6 address 2001:DB8:A000::1/64
 ipv6 enable
 ipv6 dhcp server
---DHCPv6 Relay---
ipv6 unicast-routing

interface Ethernet0/0
 ipv6 address 2001:DB8:A000::2/64
 ipv6 enable

interface Ethernet0/1
 ipv6 address 2001:DB8:1000::1/64 
 ipv6 enable
 ipv6 dhcp relay destination 2001:DB8:A000::1 Ethernet0/0
 ipv6 nd other-config-flag

interface Ethernet0/2
 ipv6 address 2001:DB8:2000::1/64 
 ipv6 enable
 ipv6 dhcp relay destination 2001:DB8:A000::1 Ethernet0/0
 ipv6 nd other-config-flag

interface Ethernet0/3
 ipv6 address 2001:DB8:3000::1/64 
 ipv6 enable
 ipv6 dhcp relay destination 2001:DB8:A000::1 Ethernet0/0


interface Loopback0
 ip address 10.10.10.10 255.255.255.255
 ipv6 address 2001:DB8:9000::1/128
 ipv6 enable
1006
閲覧回数
10
いいね!
0
コメント