シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

EIGRP summary route の metric の決まり方について

このドキュメントでは、ip summary-address eigrp コマンドで作成される summary route の metric の決まり方と、それに関連して実装された summary-metric コマンドについて紹介します。

  1. 構成
  2. summary route の metric の決まり方
  3. summary-metric コマンドの使用
  4. 全機器設定

1.構成

----------------------------------------------------------------------------

R2 上で R3 向け interface で 10.1.0.0/16 に summarize する設定を行う

ip summary-address eigrp 1 10.1.0.0 255.255.0.0

(全ての設定例はドキュメント最後に掲載)

(10.1.1.0/24)--1M--+

(10.1.2.0/24)-64K-[R1]-(10.12.1.0/24)-[R2]-(172.20.23/24)-[R3]

(10.1.3.0/24)-10M--+

(※以下、出力例はすべて 15.1(4)M3 を使用)

----------------------------------------------------------------------------

2.summary route の metric の決まり方


EIGRP では、summary route の metric は component route (summary に含まれる経路) のうち一番小さい metric のものが採用されます。

----------------------------------------------------------------------------

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 172.20.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet0/0

P 10.1.3.0/24, 1 successors, FD is 307200

        via 10.12.1.1 (307200/281600), Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

        via Summary (307200/0), Null0   <-- component route 間で一番小さい 307200 となる

P 10.1.2.0/24, 1 successors, FD is 40051200

        via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

        via 10.12.1.1 (2611200/2585600), Ethernet0/0

R2#

----------------------------------------------------------------------------

component route に更新があり、一番小さいメトリックが変更される場合には、summary route の metric も更新されます。

component route に複数の metric のパターンがある場合には、設計時に注意する必要があります。

----------------------------------------------------------------------------

例:一番小さい metric をもつ 10.1.3.0/24 が down した場合

R2#debug ip eigrp summary

EIGRP-IPv4 Summary debugging is on

R2#

06:41:46.167: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 307200, add 0 auto 0

06:41:46.167: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.167: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.167: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

06:41:46.167: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 0, add 0 auto 0

06:41:46.167: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.167: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.167: EIGRP-IPv4(1): summary_process: 3 components with static metric(0)

06:41:46.167: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16 with 3 components and metric 307200

06:41:46.167: EIGRP-IPv4(1): summary_metric overlapping: 10.1.2.0/24 metric 40051200

06:41:46.167: EIGRP-IPv4(1): summary_metric overlapping: 10.1.1.0/24 metric 2611200

06:41:46.167: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16, from 10.1.1.0/24, metric 2611200

06:41:46.167: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(307200) new(2611200) processed(yes)

06:41:46.355: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 0, add 0 auto 0

06:41:46.355: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.355: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.355: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

06:41:46.355: EIGRP-IPv4(1): summary_decr: 10.1.0.0/16 count(2)

06:41:46.355: EIGRP-IPv4(1): summary_process: 2 components with static metric(0)

06:41:46.355: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16 with 2 components and metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_metric overlapping: 10.1.2.0/24 metric 40051200

06:41:46.355: EIGRP-IPv4(1): summary_metric overlapping: 10.1.1.0/24 metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16, from 10.1.1.0/24, metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(2611200) new(2611200) processed(yes)

R2#

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 172.20.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

        via Summary (2611200/0), Null0    <-- component route 間で一番小さい 2611200 となる

P 10.1.2.0/24, 1 successors, FD is 40051200

        via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

        via 10.12.1.1 (2611200/2585600), Ethernet0/0

R2#

----------------------------------------------------------------------------

3.summary-metric コマンドの使用


summarize される component route が多い場合に、component route の更新が多く発生すると、metric の更新も頻繁に行われるため、構成によっては high CPU 状態になる可能性がございます。

このような状況に対応するため summary-metric コマンドが実装されました。

このコマンドは 12.2(33)SRE, 12.2(33)SXJ, 12.2(33)XNE/2.5.0, 15.0(1)M, 15.1(1)SG 以降で実装されています。

このコマンドは、component route の metric にかかわらず summary に対する metric を明示的に設定するものです。

----------------------------------------------------------------------------

R2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#router eigrp 1

R2(config-router)#summary-metric 10.1.0.0/16 10000 200 255 0 1500

09:09:26.023: EIGRP-IPv4(1): summary metric cmd for 10.1.0.0/16

09:09:26.023: EIGRP-IPv4(1): summary metric dly(51200) bw(256000) r(255), l(0), mtu(1500) dist(5)

09:09:26.023: EIGRP-IPv4(1): summary_update - summary changed

09:09:26.023: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

09:09:26.039: EIGRP-IPv4(1): summary_process: 2 components with static metric(1)

09:09:26.039: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(4294967295) new(307200) processed(yes)

R2(config-router)#end

R2#

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status

P 172.20.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

        via Connected, Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

        via Summary (307200/0), Null0   <-- component route の値にかかわらず 307200 となる

P 10.1.2.0/24, 1 successors, FD is 40051200

        via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

        via 10.12.1.1 (2611200/2585600), Ethernet0/0

R2#

----------------------------------------------------------------------------

4.全機器設定

----------------------------------------------------------------------------

!

hostname R1

!

interface Ethernet0/0

ip address 10.12.1.1 255.255.255.0

!

interface Ethernet1/0

bandwidth 1000

ip address 10.1.1.1 255.255.255.0

!

interface Ethernet2/0

bandwidth 64

ip address 10.1.2.1 255.255.255.0

!

interface Ethernet3/0

bandwidth 10000

ip address 10.1.3.1 255.255.255.0

!

router eigrp 1

network 10.0.0.0

!

----------------------------------------------------------------------------

!

hostname R2

!

interface Ethernet0/0

ip address 10.12.1.2 255.255.255.0

!

interface Ethernet1/0

ip address 172.20.1.2 255.255.255.0

ip summary-address eigrp 1 10.1.0.0 255.255.0.0

!

router eigrp 1

summary-metric 10.1.0.0/16 10000 200 255 0 1500

network 10.0.0.0

network 172.20.0.0

!

----------------------------------------------------------------------------

!

hostname R3

!

interface Ethernet1/0

ip address 172.20.1.3 255.255.255.0

!

router eigrp 1

network 172.20.0.0

!

----------------------------------------------------------------------------

2247
閲覧回数
15
いいね!
0
コメント