シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

NAT Box to Box High Availabitliy 冗長動作概要 (基本設計)

このドキュメントでは NAT Box to Box High Availabitliy (以下、NAT B2B HA)  の冗長動作に関する基本機能設計について説明します。

1. Control/Data Link 冗長構成

a. Control Link 障害

NAT B2B HA においては Control Link に物理的な障害等が発生し、 HA を構成する機器すべてがActive となるような状態 (以下 split-brain) での冗長性が確保できません。
Control Link 障害による split-brain を避けるために Control Link を接続するネットワークは最大限の信頼性を確保することが推奨されています。
単一 Control Link 障害による split-brain を避けるために Control Link には Port-Channel 等の 冗長Link 構成が有効です。

下記にサンプルの構成図とコンフィグを記載します。

 

 

 

R1#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   control Port-channel1.1001 protocol 1
   data Port-channel1.1002
!
interface Port-channel1
no ip address
!
interface Port-channel1.1001
encapsulation dot1Q 1001 primary Ethernet0/1 secondary Ethernet1/1
ip address 10.1.1.2 255.255.255.0
!
interface Port-channel1.1002
encapsulation dot1Q 1002 primary Ethernet1/1 secondary Ethernet0/1
ip address 10.2.2.2 255.255.255.0
!
interface Ethernet0/1
no ip address
channel-group 1
!
interface Ethernet1/1
no ip address
channel-group 1
!

R2#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   priority 200 failover threshold 150
   control Port-channel1.1001 protocol 1
   data Port-channel1.1002
   asymmetric-routing interface Port-channel1.1002
!
interface Port-channel1
no ip address
!
interface Port-channel1.1001
encapsulation dot1Q 1001 primary Ethernet0/1 secondary Ethernet1/1
ip address 10.1.1.1 255.255.255.0
!
interface Port-channel1.1002
encapsulation dot1Q 1002 primary Ethernet1/1 secondary Ethernet0/1
ip address 10.2.2.1 255.255.255.0
!
interface Ethernet0/1
no ip address
channel-group 1
!
interface Ethernet1/1
no ip address
channel-group 1
!

Control Link を 手動で shutdown した場合は、shutdown した機器の RG group が AdminDown となります。
ACTIVE側の機器にて Control Link を shutdown した場合は INIT (Disable) となり Failover が発生します。

R1#show redundancy application protocol group 1

RG Protocol RG 1
------------------
        Role: Init
        Negotiation: Disabled [RG-VP-Request]
        Priority: 105
        Protocol state: Disable
        Ctrl Intf(s) state: AdminDown
        Active Peer: Not exist
        Standby Peer: Not exist
        Log counters:
                role change to active: 1
                role change to standby: 1
                disable events: rg down state 1, rg shut 0
                ctrl intf events: up 1, down 0, admin_down 1
                reload events: local request 0, peer request 0



 

 

b. Data Link 障害

Data Link において障害が発生した場合は ACTIVE の Router はそのまま ACTIVE として動作し、 STANDBY の Router は INIT となります。
Data Link を 手動で shutdown した場合は、shutdown した機器の RG group が AdminDown となります。
ACTIVE側の機器にて Data Link を shutdown した場合は INIT (Disable) となり Failover が発生します。

 

2. Timer Tuning

NAT BtoB HA の障害時動作のチューニングに用いられる二つの代表的な timer について記載します。

1. timers hellotime [msec] number holdtime [msec] number

hollo の送出間隔、hello を受信しなかった場合に対向を応答不可と判断するまでのholdtime を変更できます。

デフォルトは hellotime:3sec、 holdtime:10sec です。

 


R1#
redundancy
 application redundancy
  group 1
  protocol 1
   timers hellotime msec 500 holdtime msec 2000 

R2#
redundancy
 application redundancy
  group 1
  protocol 1
   timers hellotime msec 1000 holdtime msec 3000 

R1#show redundancy application protocol group 1

RG Protocol RG 1
------------------
        Role: Active
        Negotiation: Enabled
        Priority: 105
        Protocol state: Active
        Ctrl Intf(s) state: Up
        Active Peer: Local
        Standby Peer: address 10.0.0.2, priority 100, intf Et0/1
        Log counters:
                role change to active: 2
                role change to standby: 2
                disable events: rg down state 1, rg shut 0
                ctrl intf events: up 2, down 0, admin_down 1
                reload events: local request 0, peer request 0

RG Media Context for RG 1
--------------------------
        Ctx State: Active
        Protocol ID: 1
        Media type: Default
        Control Interface: Ethernet0/1
        Current Hello timer: 500
        Configured Hello timer: 500, Hold timer: 2000
        Peer Hello timer: 1000, Peer Hold timer: 3000
        Stats:
                Pkts 393, Bytes 24366, HA Seq 0, Seq Number 393, Pkt Loss 0
                Authentication not configured
                Authentication Failure: 0
                Reload Peer: TX 1, RX 0
                Resign: TX 0, RX 1
        Standby Peer: Present. Hold Timer: 2000
                Pkts 163, Bytes 5542, HA Seq 0, Seq Number 286186, Pkt Loss 0


2. timers delay <seconds> [reload <seconds>]

機器が障害からの復旧やリロードによる復旧後に、 RG role のネゴシエーションを開始するまでの時間を指定します。
Default値 は delay 10sec 、 reload timer が 120sec となっています。
障害復旧後のルーティングプロトコルの復旧時間等に合わせたチューニングが必要な場合に利用されます。

起動後、下記のように timers reload <seconds> に応じた Negotiation Delay Timer がカウントダウンされます。
Timer が Expire するまでは Pre-init 状態を維持します。

 

R1#show redundancy application protocol group 1
RG Protocol RG 1
------------------
        Role: Init
        Negotiation: Delayed; remaining 48 sec
        Priority: 105
        Protocol state: Pre-init
        Ctrl Intf(s) state: Up
        Active Peer: Not exist
        Standby Peer: Not exist
        Log counters:
                role change to active: 0
                role change to standby: 0
                disable events: rg down state 0, rg shut 0
                ctrl intf events: up 1, down 0, admin_down 0
                reload events: local request 0, peer request 0


Delay Timer の Expire 後 Standby-cold 状態へ遷移します。


%RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Init to Standby

R1#show redundancy application protocol group 1
RG Protocol RG 1
------------------
        Role: Standby
        Negotiation: Enabled
        Priority: 105
        Protocol state: Standby-cold
        Ctrl Intf(s) state: Up
        Active Peer: address 10.0.0.2, priority 100, intf Et0/1
        Standby Peer: Local
        Log counters:
                role change to active: 0
                role change to standby: 1
                disable events: rg down state 0, rg shut 0
                ctrl intf events: up 1, down 0, admin_down 0
                reload events: local request 0, peer request 0


Preempt 設定が有効な場合は再度 Active へ復旧します。

%RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Standby to Active

R1#show redundancy application protocol group 1
RG Protocol RG 1
------------------
        Role: Active
        Negotiation: Enabled
        Priority: 105
        Protocol state: Active
        Ctrl Intf(s) state: Up
        Active Peer: Local
        Standby Peer: Not exist
        Log counters:
                role change to active: 1
                role change to standby: 1
                disable events: rg down state 0, rg shut 0
                ctrl intf events: up 1, down 0, admin_down 0
                reload events: local request 0, peer request 0

下記ドキュメントも参考にしてください。

 

 

 

バージョン履歴
改訂番号
1/1
最終更新:
‎10-21-2014 11:15 AM
更新者:
 
ラベル(1)