シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

NAT Box to Box High Availabitliy 冗長動作概要 (障害時切替動作)

このドキュメントでは NAT Box to Box High Availabitliy (以下、NAT B2B HA)  の障害時切り替わり動作について簡単に説明します。

構成例、正常時の通信状況は下記図の通りです。機器の Configuration は 本ドキュメントの最後に記載します。

1.リンク障害時動作 - Active側 Inside LAN I/F 障害

下記図のように Active NAT router の LAN側 I/F にて障害が発生した際の切り替わり動作を確認します。

1-1.LAN to LAN 通信の切り替わり

Active NAT router にて Inside LAN側 I/F にて障害が発生した際、
Priority が decrement され Priority:5 となり、Priority:100 である R2 が即座に Active に切り替わります。

R2#
%RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Standby to Active
R1#
%RG_FAULTS-6-PRICHANGE: RG Infra RG[1] Priority update. new priority [5] old priority [105] Reason: Fault occurred on the traffic interface

R1# show redundancy application protocol group 1
RG Protocol RG 1
------------------
        Role: Standby
        Negotiation: Enabled
        Priority: 5
        Protocol state: Standby-hot
        Ctrl Intf(s) state: Up
        Active Peer: address 10.0.0.2, priority 100, intf Et0/1
        Standby Peer: Local
        Log counters:
                role change to active: 1
                role change to standby: 2
                disable events: rg down state 0, rg shut 0
                ctrl intf events: up 1, down 0, admin_down 0
                reload events: local request 0, peer request 0*Oct 21 06:59:35.478: %RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Standby to Active

R1 は Standby となり VMAC,VIP を shut 状態にします。
R2 は Active となり VMAC,VIP を no shut 状態にし、 GARPを送出することで通信を自身に誘導します。
NAT table は常に同期されているため、R2 にて NAT変換は継続されます。
これにより LAN to LAN 通信は復旧します。 TCPセッション(telnet)も切断されません。

R1#show redundancy application if-mgr group 1
 RG ID: 1
 ==========

 interface      Ethernet1/0
 ---------------------------------------
 VMAC           0007.b421.0065
 VIP            172.16.1.254
 Shut           shut
 Decrement      100

 interface      Ethernet0/0
 ---------------------------------------
 VMAC           0007.b421.0064
 VIP            192.168.1.254
 Shut           shut
 Decrement      100

 interface      Ethernet0/2
 ---------------------------------------
 Decrement        100

R2#show redundancy application if-mgr group 1
 RG ID: 1
 ==========

 interface      Ethernet1/0
 ---------------------------------------
 VMAC           0007.b421.0065
 VIP            172.16.1.254
 Shut           no shut
 Decrement      100

 interface      Ethernet0/0
 ---------------------------------------
 VMAC           0007.b421.0064
 VIP            192.168.1.254
 Shut           no shut
 Decrement      100

 interface      Ethernet0/3
 ---------------------------------------
 Decrement        100

障害復旧時、 preempt が設定されている場合、同様の切り替わり動作により R1 へ通信が復旧します。

 

1-2.LAN to WAN 通信の切り替わり

1-1と同様にStandby NAT Router は即座に Active に切り替わります。

R2#
%RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Standby to Active

NAT inside 側の LAN 通信においては、1-1 と同様の動作により切り替わります。
R2は元々WAN server への ルーティング経路を保持しているため、R2 → WAN への通信には影響がありません。
WAN → R2 への通信については R2が NAT Inside Global:10.255.255.50 を WAN 側へ広報するまで切り替わりません。

 

経路切り替えの流れは下記のようになります。

R1 には 下記設定が入っていますので、Active → Standby への切り替わりから VIP の shut により、NAT Inside Global:10.255.255.50 経路のOSPFへの広報を止めます。

track 100 ip route 192.168.1.254 255.255.255.255 reachability  
ip route 10.255.255.50 255.255.255.255 Ethernet0/0 track 100 
router ospf 1 
 redistribute static subnets

一方 R2 にも同様の設定が入っているため Active に昇格した後、下記メッセージのタイミングで NAT Inside Global:10.255.255.50 経路をWAN側OSPFへ広報します。

R2#
%TRACK-6-STATE: 100 ip route 192.168.1.254/32 reachability Down -> Up

NAT table は常に同期されているため、R2 にて NAT変換は継続されます。
これにより LAN to WAN 通信は復旧します。TCPセッション(telnet)も切断されません。
通信復旧までの時間は track による 経路切り替えの時間に依存します。

障害復旧時、 preempt が設定されている場合、同様の切り替わり動作により R1 へ通信が復旧します。

 

2.リンク障害時動作 - Active側 Outside LAN I/F 障害

障害時 の挙動は 1 と同様なので割愛します。

 

3.リンク障害時動作 - Active側 Outside WAN I/F 障害

障害時 の挙動は 1 と同様なので割愛します。

 

4.ノード障害時動作 - Active NAT Router 障害

Active NAT Router 障害時の動作を下記図に示します。

Active NAT Router に障害が発生した場合、 Standby NAT Router は Active から Hello の送信がなくなったことを検知し、holdtime 後に自身を Active Role へ昇格させます。

R2#
%RG_MEDIA-3-TIMEREXPIRED: RG id 1 Hello Timer Expired.
%RG_PROTOCOL-5-ROLECHANGE: RG id 1 role change from Standby to Active

R2 が Active に昇格した後の 通信の切り替わりの流れについては概ね前項と同様のため割愛します。

Note:Active NAT Router を 手動で reload した場合は Down 前に Standby 側へ Ressign Message を送付するため Standby NAT Router は即座に Active Role へ昇格します。

 

5. Configuration

上記試験で用いた Config を下記に示します。

R1#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   priority 105
   control Ethernet0/1 protocol 1
   data Ethernet0/1
!
track 100 ip route 192.168.1.254 255.255.255.255 reachability
!
interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100
!
interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.1 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 172.16.20.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 ip ospf 1 area 0
 redundancy rii 102 decrement 100
!
interface Ethernet1/0
 ip address 172.16.1.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 redundancy rii 101
 redundancy group 1 ip 172.16.1.254 exclusive decrement 100
!
router ospf 1
 router-id 10.1.1.1
 redistribute static subnets
!
ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130
ip nat inside source static 192.168.1.100 172.16.1.50 redundancy 1 mapping-id 120
ip route 10.255.255.50 255.255.255.255 Ethernet0/0 track 100

R2#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   control Ethernet0/1 protocol 1
   data Ethernet0/1
!
track 100 ip route 192.168.1.254 255.255.255.255 reachability
!
interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100
!
interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.2 255.255.255.0
!
interface Ethernet0/3
 ip address 172.16.30.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 ip ospf 1 area 0
 redundancy rii 102 decrement 100
!
interface Ethernet1/0
 ip address 172.16.1.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 redundancy rii 101
 redundancy group 1 ip 172.16.1.254 exclusive decrement 100
!

router ospf 1
 router-id 10.1.1.2
 redistribute static subnets
!
ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130
ip nat inside source static 192.168.1.100 172.16.1.50 redundancy 1 mapping-id 120
ip route 10.255.255.50 255.255.255.255 Ethernet0/0 track 100

 

下記ドキュメントも参考にしてください。

 

532
閲覧回数
0
いいね!
0
コメント