キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

NAT Box to Box High Availabitliy 基本動作確認 (Part 2)

このドキュメントでは NAT Box to Box High Availabitliy (以下、NAT B2B HA)  の基本的な動作概要と確認方法を説明します。

3. LAN to WAN の動作確認
本項では下記図のような通信状況の動作確認方法を示します。
 
 

Client B より LAN Server 宛てに telnet 接続を実施します。

Client B#telnet 172.16.100.100
Trying 172.16.100.100 ... Open

R1 にて該当通信のNATエントリが生成されます。

R1#show ip nat translation | i tcp
tcp 10.255.255.50:11046 192.168.1.200:11046 172.16.100.100:23 172.16.100.100:23

R1 にてNAT通信が発生したことがわかります。

R1#show ip nat statistics | i packets
CEF Translated packets: 440, CEF Punted packets: 4

R2 にも同時に、同じNATエントリが生成されます。

R2#show ip nat translation | i tcp
tcp 10.255.255.50:11046 192.168.1.200:11046 172.16.100.100:23 172.16.100.100:23

R2 は Standby 状態ですので、通信は経由されません。

R2#show ip nat statistics | i packets
CEF Translated packets: 0, CEF Punted packets: 0

LAN-LAN構成 も LAN-WAN構成も 基本的な正常動作の見え方としては大きな差異はございませんが、Configuration には多少差異がありますので、ご注意ください。

R1#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   priority 105
   control Ethernet0/1 protocol 1
   data Ethernet0/1

interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100

interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.1 255.255.255.0

interface Ethernet0/2
 ip address 172.16.20.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 redundancy rii 102 decrement 100
 ip ospf 1 area 0

router ospf 1 
router-id 10.1.1.1
redistribute static subnets

track 100 ip route 192.168.1.254 255.255.255.255 reachability  

ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130

ip route 10.255.255.50 255.255.255.255 Ethernet0/0 track 100 
R2#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   control Ethernet0/1 protocol 1
   data Ethernet0/1

interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100

interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.2 255.255.255.0


interface Ethernet0/3
 ip address 172.16.30.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 redundancy rii 102 decrement 100
 ip ospf 1 area 0

router ospf 1 
router-id 10.1.1.2
redistribute static subnets

track 100 ip route 192.168.1.254 255.255.255.255 reachability  

ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130

ip route 10.255.255.50 255.255.255.255 Ethernet0/0 track 100 

 

4. MAC address resolution

NAT B2B HA 構成に対する通信機器の MAC table を下記図に示します。

NAT B2B HA を利用している NAT Router の VIP において、通信機器に対し通知している Virtual MAC を以下のコマンドで確認できます。

R1#show redundancy application if-mgr group 1

 RG ID: 1
 ==========

 interface      Ethernet1/0
 ---------------------------------------
 VMAC           0007.b421.0065
 VIP            172.16.1.254
 Shut           no shut
 Decrement      100

 interface      Ethernet0/0
 ---------------------------------------
 VMAC           0007.b421.0064
 VIP            192.168.1.254
 Shut           no shut
 Decrement      100

 interface      Ethernet0/2
 ---------------------------------------
 Decrement        100

R2#show redundancy application if-mgr group 1

 RG ID: 1
 ==========

 interface      Ethernet1/0
 ---------------------------------------
 VMAC           0007.b421.0065
 VIP            172.16.1.254
 Shut           shut
 Decrement      100

 interface      Ethernet0/0
 ---------------------------------------
 VMAC           0007.b421.0064
 VIP            192.168.1.254
 Shut           shut
 Decrement      100

 interface      Ethernet0/3
 ---------------------------------------
 Decrement        100

 

下記ドキュメントも参考にしてください。

 

 

 

バージョン履歴
改訂番号
1/1
最終更新:
‎10-20-2014 02:44 PM
更新者:
 
ラベル(1)