シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel

NAT Box to Box High Availabitliy Asymmetric Routing 機能動作概要

このドキュメントでは NAT Box to Box High Availabitliy (以下、NAT B2B HA)  の Asymmetric Routing について簡単に説明します。

 

1.NAT B2B HA Asymmetric Routing 基本動作

Asymmetric Routing を使用している場合は、下記のように非対称通信経路による Standby 側の受信トラフィックを NAT 変換することが可能です。

 

本試験構成では WAN Server は常時 WAN-R4 への経路を優先してパケットを送信しますが、NAT Router は R1 が Active となっています。

Asymmetric Routing による通信の流れの確認方法を説明します。

 

まず、NAT通信が発生していないことを確認します。

R1#show ip nat redundancy 1 | i Packet
                Forwarded Packets: 0,   Dropped Packets : 0
                Redirected Packets: 0

R2#show ip nat redundancy 1 | i Packet
                Forwarded Packets: 0,   Dropped Packets : 0
                Redirected Packets: 0

次に、ClientB -> WAN Server へ通信を発生させます。
Asymmetric Routing が動作している場合は下記のように
R1 では Forwarded Packets が上昇し、R2 の Redirected Packets が上昇していることがわかります。


R1#show ip nat redundancy 1 | i Packet
                Forwarded Packets: 33933,       Dropped Packets : 0
                Redirected Packets: 0

R2#show ip nat redundancy 1 | i Packet
                Forwarded Packets: 0,   Dropped Packets : 0
                Redirected Packets: 7603

Asymmetric Routing を有効にした場合のコンフィグは下記のようになります。

R1#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   priority 105
   control Ethernet0/1 protocol 1
   data Ethernet0/1
   asymmetric-routing interface Ethernet0/1
!
interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100
!
interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.1 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 172.16.20.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 ip ospf 1 area 0
 redundancy rii 102 decrement 100
 redundancy asymmetric-routing enable
!
router ospf 1
 router-id 10.1.1.1
 redistribute static subnets
!
ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130
ip nat inside source static 192.168.1.100 172.16.1.50 redundancy 1 mapping-id 120
ip route 10.255.255.50 255.255.255.255 Ethernet0/0

R2#
redundancy
 application redundancy
  group 1
   name RG1
   preempt
   control Ethernet0/1 protocol 1
   data Ethernet0/1
   asymmetric-routing interface Ethernet0/1
!
interface Ethernet0/0
 description ## To Client ##
 ip address 192.168.1.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 redundancy rii 100
 redundancy group 1 ip 192.168.1.254 exclusive decrement 100
!
interface Ethernet0/1
 description ## Control-Link ##
 ip address 10.0.0.2 255.255.255.0
!
interface Ethernet0/3
 ip address 172.16.30.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 ip ospf 1 area 0
 redundancy rii 102 decrement 100
 redundancy asymmetric-routing enable
!
router ospf 1
 router-id 10.1.1.2
 redistribute static subnets
!
ip nat inside source static 192.168.1.200 10.255.255.50 redundancy 1 mapping-id 130
ip nat inside source static 192.168.1.100 172.16.1.50 redundancy 1 mapping-id 120
ip route 10.255.255.50 255.255.255.255 Ethernet0/0

 

2.Asymmetric Routing 有効時の 障害動作

Asymmetric Routing 有効時の障害時の通信経路は下記のようになります。

Asymmetric Routing が無効である場合と異なり、track による経路切り替えを待つ必要はありません。
R2 が Active へ昇格したタイミングで通信が復旧します。

 

下記ドキュメントも参考にしてください。

 

361
閲覧回数
0
いいね!
0
コメント