シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

RIP の概要

はじめに
Routing Information Protocol(RIP)とはdistance vector型のルーティングプロトコルです。 30秒毎に、activeインターフェースからルーティングテーブルについての全ての情報を送信します。リモートネットワークまでの経路を決めるため、 ホップカウントを利用しますが、デフォルトで最大ホップカウントは15ポップスまでとしており、16ホップ以上場合は通りません。 小型ネットワークの場合、効果的に動いていますが、複数ルータや遅いWANリンクのネットワークは非常に非効率的です。 また、変数帯域幅のリンクときは全く効果がありません。 RIPv1はクラスフルルーティングを利用するので、ネットワーク内の全ての設備は同じサブネットマスクを使わなければなりません。 これは、RIPv1のアップデートがサブネットマスクの情報を送信しないためです。 RIPv2は”プレフィックスルーティング”を与えるので、 アップデートにサブネットマスクの情報を追加し、送信します。これはクラスレスルーティングと呼ばれます。 よって、RIPv1は現在、あまり使われていません。

 

RIPの設定
それでは、RIPの設定を見てみましょう。

ま ず、 configモードで”router rip”コマンドを利用して、プロトコルを有効にします。 それから”network”コマンドでルーティングプロトコルがどっちのクラスフルネットワークをアドバタイズするかを設定します。これで、ルータに設定 したのそれぞれのインターフェースの指定されたアドレス範囲がRIPのルーティングプロセスに有効にします。

このトポロジーを参考して下さい

RIP layout

 

RouterA

RouterAの現在のインターフェースを見てみましょう。

RouterA#sh ip int brief
Interface                      IP-Address      OK?    Method    Status                               Protocol
FastEthernet0/0        10.10.10.1        YES    manual     up                                     up
FastEthernet0/1        unassigned       YES    unset        administratively down      down
Serial0/0/0                172.16.10.1      YES     manual     up                                     up
Serial0/0/1                172.16.10.5      YES    manual      up                                     up

RouterA#config terminal
RouterA(config)#router rip
RouterA(config-router)#network 10.0.0.0
RouterA(config-router)#network 172.16.0.0
RouterA(config-router)#version 2
RouterA(config-router)#no auto-summary

設 定は難しくなく、 2つまたは3つのコマンドで終わります。 何を設定したかというと、RIPのプロトコルを有効にし、直接接続しているのネットワークを追加し、クラスレスのRIPv2を有効し、最後に自動集約を無 効にしました。RIPやEIGRPはデフォルトで自動集約行っていますが、 一般的に好ましくないので、手動集約した方がよいでしょう。

サ ブネットの情報を入れずに、クラスフルのネットワークアドレスのみに気付くことが出来ますか。 ルーティングプロトコルを利用する場合、 サブネットマスクの情報を入れるのはプロトコルの役目です。 しかし、RouterBやRouterCはRIPまだ設定していませんので、ルーティングテーブルに他のRIPルートを見ることができません。

 

RouterB

それでは、2つのネットワークに接続しているRouterBを設定しましょう。 両方に直接接続しているのクラスフルネットワークを登録します。

RouterB#show ip interface brief
Interface                 IP-Address       OK?   Method   Status                     Protocol
FastEthernet0/0        192.168.10.1     YES   manual   up                          up
FastEthernet0/1        unassigned       YES   unset    administratively down   down
Serial0/0/0              172.16.10.2      YES   manual   up                          up
Serial0/0/1              unassigned       YES   unset     administratively down  down
Vlan1                     unassigned       YES   unset     administratively down  down

RouterB#configure terminal
RouterB(config)#router rip
RouterB(config-router)#network 192.168.10.1
RouterB(config-router)#network 172.16.10.2
RouterB(config-router)#version 2
RouterB(config-router)#no auto-summary
RouterB(config-router)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 172.16.10.1, 00:00:15, Serial0/0/0
     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.10.0 is directly connected, Serial0/0/0
R       172.16.10.4 [120/1] via 172.16.10.1, 00:00:15, Serial0/0/0
C     192.168.10.0/24 is directly connected, FastEthernet0/0

このルーティングテーブルを見てましょう。 RouterAでRIPを設定したので、 隣接するルートが表示されます。 RouterA経由の10.10.10.10や172.16.10.4のネットワークが発見されました。
しかし、まだ終了ではありません。

 

RouterC

それで、RouterCを設定しましょう:
RouterC#conf t
RouterC(config)#router rip
RouterC(config-router)#network 192.168.20.0
RouterC(config-router)#network 172.16.0.0
RouterC(config-router)#no auto-summary
RouterC(config-router)#version 2
RouterC(config-router)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 172.16.10.5, 00:00:14, Serial0/0/1
     172.16.0.0/30 is subnetted, 2 subnets
R       172.16.10.0 [120/1] via 172.16.10.5, 00:00:14, Serial0/0/1
C       172.16.10.4 is directly connected, Serial0/0/1
R     192.168.10.0/24 [120/2] via 172.16.10.5, 00:00:14, Serial0/0/1
C     192.168.20.0/24 is directly connected, FastEthernet0/0

徐々 に新しい”R”ルートが表示されます! この”R”はネットワークがRIPルーティングプロトコルを使用して自動的に追加されたことを示しています。 [120/1]の部分はルートのadministrative distance(120)やルートのメトリックです。RIPの場合はリモートネットワークまでのホップ数です(1)。

ルーティングプロトコルのデフォルトAD:

ルートの原因デフォルトAD
接続インターフェース0
スタティックルート1
EIGRP90
OSPF110
RIP120
外部EIGRP170
Unknown255 (このルートは使わない)

 

こ のような小さなネットワークの場合、RIPは問題なく動いていますが、エンタプライズレベルネットワークの場合、あまり使われていません。 最大ホップ数は15から、非常に制限的な要因です。 また、30秒毎に完全なルーティングテーブル更新が行うので、大きなインターネットワークは完全に停止します。

 

ホップ数

RIP のルーティングテーブルやリモートネットワークをアドバタイズするパラメーターを見てみましょう。 下記の10.1.3.0のネットワークの[120/15]をご覧下さい。 これは、 ADは120(RIPのデフォルト)で、ホップ数は15です。ルータは隣接ルータへの更新を送信するたびに、ホップ数が各ルートのために増分ずつ上がるこ とに気を付けて下さい。 それでは違うネットワークやルータの出力を見てみましょう。

Router#show ip route
        10.0.0.0/24 is subnetted, 12 subnets
C    10.1.11.0 is directly connected, FastEthernet0/1
L    10.1.11.1/32 is directly connected, FastEthernet0/1
C    10.1.10.0 is directly connected, FastEthernet0/0
L    10.1.10.1/32 is directly connected, FastEthernet0/0
R    10.1.9.0 [120/2] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.8.0 [120/2] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.12.0 [120/1] via 10.1.11.2, 00:00:00, FastEthernet0/1
R    10.1.3.0 [120/15] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.2.0 [120/1] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.1.0 [120/1] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.7.0 [120/2] via 10.1.5.1, 00:00:15, Serial0/0/1
R    10.1.6.0 [120/2] via 10.1.5.1, 00:00:15, Serial0/0/1
C    10.1.5.0 is directly connected, Serial0/0/1
L    10.1.5.1/32 is directly connected, Serial0/0/1
R    10.1.4.0 [120/1] via 10.1.5.1, 00:00:15, Serial0/0/1

この[120/15]では注意が必要です。 このルータからテーブルを受け取り、次のルータでホップ数が16に上昇するので、10.1.3.0ネットワークへのルートが破棄されます。

RIPの伝播を阻止する

LAN やWAN上の全てのリンクをアドバタイズすると、負荷が上がるのでお勧めしません。LANやWAN全体に伝播する不要なRIPアップデートを停止するに は、いくつかの方法があります。 最も簡単な方法は、passive-interfaceコマンドを使用することです。このコマンドは、指定されたインターフェイスから送信されたRIP アップデートブロードキャストを防止しますが、同じインタフェースがRIPアップデートを受信することができます。 それでは設定例を見てましょう。

RouterA#config terminal
RouterA(config)#router rip
RouterA(config-router)#passive-interface FastEthernet0/1

このコマンドはインターフェースFastEthernet 0/0のRIPアップデートの送信を防止するが、 受信はできます。

RIP上のデフォルトルートのアドバタイズ

ネッ トワーク内RIP以外のルーティングプロトコルを使用したい場合は、Redistribution機能を使います。RouterAのFa0/0インター フェイスには、インターネットへのいくつかの種類の接続をイメージして下さい。 これは、一般的な構成です。 RIPの場合、シリアルインターフェースの代わりにLANインタフェースを使用し、ISPに接続することも可能です。 RouterAにインターネットの接続を追加すると、ASの全てのルータ(RouterB, RouterC)にインターネットの宛先を教えなければなりません。そうしないとリモート要求をもらう時に、パケットを破棄します。その一つの解決策は、 各ルータにRouterAまでのデフォルトを設定することで、また、RouterAからISPまでデフォルトルートを設定することです。 この方法は中規模や小規模ネットワークでも問題なく設定できます。 しかし、 我々のネットワークで各ルータ上はRIPv2を利用するので、 RouterAでISPまでのデフォルトルートを追加します。それから、インターネットへの宛先をASに参加する全てのルータにアドバタイズするため、他 のコマンドを設定します。

それでは、RouterAの追加する設定を見てみましょう:

RouterA(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
RouterA(config)#router rip
RouterA(config-router)#default-information originate

RouterAのルーティングテーブルに、この部分が追加されました。

S*   0.0.0.0/0 is directly connected, FastEthernet0/0

RIP propagation

RouterCから同じ情報を見るかどうかを確認しましょう。

Gateway of last resort is 172.16.10.5 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
R       10.10.10.0 [120/1] via 172.16.10.5, 00:00:27, Serial0/0/1
R       10.10.11.0 [120/1] via 172.16.10.5, 00:00:27, Serial0/0/1
     172.16.0.0/30 is subnetted, 2 subnets
R       172.16.10.0 [120/1] via 172.16.10.5, 00:00:27, Serial0/0/1
C       172.16.10.4 is directly connected, Serial0/0/1
R     192.168.10.0/24 [120/2] via 172.16.10.5, 00:00:27, Serial0/0/1
C     192.168.20.0/24 is directly connected, FastEthernet0/0
R*    0.0.0.0/0 [120/1] via 172.16.10.5, 00:00:27, Serial0/0/1

正 常に同じ情報が出ています。 RIPの注入ルート、また、デフォルトルートであることをアドバタイズするので、先程の"default-information originate"コマンドが正常に動作しているということです。 最後にGateway of last resortの設定が変更されていることに気を付けてください。

284
閲覧回数
0
いいね!
0
コメント