シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

ASR1000シリーズルータにてLocal PBRが機能しない

2013年4月26日(初版)

TAC SR Collection
主な問題

ASR1000シリーズルータにて、自発パケットに対する Policy Based Routing(Local PBR) が機能しないことがあります。また、自発パケットは宛先ルートがルーティングテーブルに載っていない場合ドロップされます。

Local PBR は以下のような設定をしているものが対象になります。

interface Loopback0

ip address 10.0.1.1 255.255.255.255

interface GigabitEthernet0/0/0

ip address 10.0.0.1 255.255.255.0

!

ip local policy route-map LPBR

!

ip access-list extended acl-local

permit ip host 10.0.1.1 any

!

route-map LPBR permit 10

match ip address acl-local

set ip next-hop 10.0.0.2

この例は Loobback0 をソース IP アドレスとする自発パケットが 10.0.0.2 に PBR で送信される設定です。

原因

この問題は CSCts02779 として報告されています。

解決策

不具合の暫定回避策 :

ルーティングテーブルに宛先へのルートがない場合、route-map の next-hop を指定したスタティックルートを追加してください。

上の例で 10.0.1.2 に対して通信を試みる場合は、以下のスタティックルートを追加すれば上記の Local PBR と同じ効果が得られます。

ip route 10.0.1.2 255.255.255.255 10.0.0.2


改修版ソフトウェア :

CSCts02779 の問題が改修されたソフトウェアを使用して下さい。

備考 本不具合は、Bug Search Tool でも確認できます。

399
閲覧回数
0
いいね!
0
コメント