シスコサポートコミュニティ
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

OSPF の maximum-path の設定を使用していると経路が削除されない場合がある

2013年04月18日(初版)

TAC SR Collection
主な問題

OSPF の maximum-path の設定を使用していると経路が削除されない場合があります。

この問題は以下の条件を満たすと発生する場合があります。

-maximum-path が設定されている。

-特定の経路に対し、等コストの経路が複数存在する(show ip ospf rib上で)。

-上記の特定の経路が DOWN する。

この問題の発生例を以下に示します。

<Topology>

+------+             +------+

|      |E0/0-----E0/0|      |

|  R1  |             |  R2  |

|      |E0/1-----E0/1|      |

+------+             +------+

<R1 の設定>

interface Ethernet0/0

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/1

ip address 192.168.2.1 255.255.255.0

!

router ospf 1

  0.0.0.0 255.255.255.255 area 0

  maximum-path 1

!

<R2 の設定>

interface loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0/0

ip address 192.168.1.2 255.255.255.0

!

interface Ethernet0/1

ip address 192.168.2.2 255.255.255.0

!

router ospf 1

  0.0.0.0 255.255.255.255 area 0

!

上記の状態(R2 の loopback0 への経路を R1 で学習している状態)で R2 の loopback0 を shutdown すると、2.2.2.2/32 が R1 の Routing Table から削除されず経路が残り続けます。

以下に loopback0 を shutdown した後の R1 のログを示します。

show ip ospf rib から 2.2.2.2/32 は削除されていますが、Routing Table からは 2.2.2.2/32 が削除されていません。

R1#show ip ospf rib

---snip---

OSPF local RIB

Codes: * - Best, > - Installed in global RIB

*   192.168.1.0/24, Intra, cost 10, area 0, Connected

      via 192.168.1.1, Ethernet0/0

*   192.168.2.0/24, Intra, cost 10, area 0, Connected

      via 192.168.2.1, Ethernet0/1

R1#show ip route

---snip---

      2.0.0.0/32 is subnetted, 1 subnets

O        2.2.2.2 [110/11] via 192.168.1.2, 00:04:14, Ethernet0/0

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.1.0/24 is directly connected, Ethernet0/0

L        192.168.1.1/32 is directly connected, Ethernet0/0

      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.2.0/24 is directly connected, Ethernet0/1

L        192.168.2.1/32 is directly connected, Ethernet0/1

原因

この問題は CSCtn58033 として報告されています。

解決策

不具合の暫定回避策 :

maximum-path の設定を外してください。もしくは事象発生後に clear ip route を実施してください。

改修版ソフトウェア :

CSCtn58033 の問題が改修されたソフトウェアを使用して下さい。

備考 本不具合は、Bug Search Tool でも確認できます。

298
閲覧回数
0
いいね!
0
コメント