Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

ACS 4.0, copying DB over to new server


I am running ACS 4.0 on a windows 2000 server.

I have created a backup using the GUI and attempted to restore it on a new server. It only pulls through the Users and groups which seems correct as is reported all over the internet.

The server has the same name/IP and ACS version.

Is my only option to get the network configuration data etc copied across by setting it up as a replication server?

The active server was installed by an employee that has since resigned and I have no idea what password was used to encrypt the database, is there a way to recover it?

any advice would be appreciated, thanks in advance



Re: ACS 4.0, copying DB over to new server

Hi Marc,

When you restore your ACS config into another ACS you are asked if you want to restore system configuration as well, this will import the Network Configuration Data, did you check that option too?


Re: ACS 4.0, copying DB over to new server

An ACS backup should include everything! Otherwise backup would be the wrong name ;)

Like the other chap said check which options you chose to restore from the backup.

New Member

Re: ACS 4.0, copying DB over to new server

Thanks for the responses guys

I have tried restoring the data by using the GUI and clicking both options

I have also tried using the CSUTIL -r all .

If I select only users and groups, I am able to restore the objects.

If I click system configuration, the server hangs, and it fails to load the CSxxx services.

Event viewer reports the CSauth service terminated with service=specific error 75

while the only error I see in the CSlog.log is SL"loadallhosts host_setipstring failed, not sure if thats relevant.

the only other thing I have not tried yet is exporting the DB using the CSutil command although documentation states that its the same as clicking the backup in the Gui




Re: ACS 4.0, copying DB over to new server

Looks like the network config database is failing to initialise. You'll need to open a TAC case for this.

Try looking in the csauth service log file as there will most likely be a string of error messages.

Also the setipstring failure makes it look like one or more devices in the network config db perhaps has a corrupt ip address. Are you using device names instead of addresses - maybe a name isnt getting resolved.

Out of interest - does the backup restore on the original server ok?

New Member

Re: ACS 4.0, copying DB over to new server

Hi Darran

I will have a look as the csauth log

I have checked the live server again and have noticed its linked to the windows auth database(AD), the new server is at my desk(offsite) and not on the domain, so that may possibly be the issue.

I have not tried restoring on the original server yet, I will try taking the new server to the live site, join the domain etc and try a restore. If it works I will post it here.

Thanks again for the advice.

New Member

Re: ACS 4.0, copying DB over to new server


I've the same problem and trying to restore the db with CsUtil an error message with "possible blank or wrong password" appear.


CreatePlease to create content