Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ACS 4.X issues - cant backup end result


We had a 2 MS Windows 2003 Servers that was running 4.0. We managed to upgrade the DR server to 4.2 without any issues, but when we tried to upgrade the PR server, we got CRYPTO errors. We found the answer to this problem here by deleting the files from whoever installed the original app. Then we tried a backup on the 4.0 version - but couldn't get this to work. after several days of debating and searching the net for answers we decided to competely remove the 4.0 version of the server. This was done as per cisco instructions - i.e. Add and remove programes then use the clean.exe script on the CD.

Once this was done we installed 4.2 which actaully worked, i then managed to replicate the DB from the DR server onto this server, but when i tried a backup i got the following in the report logs....

CSBackupRestore(OUT) export function exportUsersSPC in DLL "file path" \*ACS4.2 \ \Support\backupRestoreSupport.dll failed.

In the CSAuth log .....

OBDC Operation failed with the following info. Mesage [Sybase] [ODBC Driver] [adaptive Server anywhere] cannot access file "path file"\ * ACS 4.2\CSAuth\System Backups\\20-Nov-2009 10-50-06 Scratch\SPC\spc.dat ~ ' Invalid Argument, sqlState=S1000, NativeError=-602

(Please note that for some reason the log is viewed via notepad and this is showing some stranges symbols with the line text above not sure if thats a error too??)

Any help pleasee - i'm losing my hair on this one!!!


Cisco Employee

Re: ACS 4.X issues - cant backup end result

Yeah the problem is a known internal bug, internal meaning only cisco can see it, my advise is to go ahead and have a tac case opened on regards to this, have them attach your case to the bug and wait for a fix.  This is the bug ID CSCsz94250

New Member

Re: ACS 4.X issues - cant backup end result

Many thanks Ivan, i'm in the progress on upgrading to 4.2.1 (15) - we all think, this best before we raised a TAC call.