Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ACS 5.1 backup issues

Dear friends,

Platform is ACS 1120 Ver 5.1. I tried using the acs backup and just the backup command and both are currently giving me problems.

1. When i backup ACS using the "acs backup" command, and then remove a few commands from acs configuration, i should be able to get back those commands into the configuration when i run a restore. Right? However, i dont see that. Following are the screenshots:

Backup of data:

ACS/admin# acs backup gcc-backup repository gcc-repository

ACS backup file 'gcc-backup-100925-1336.tar.gpg' successfully copied to repository 'gcc-repository'

Backup history:

ACS/admin# show backup history
Sat Sep 25 13:36:34 AST 2010: backup gcc-backup-100925-1336.tar.gpg to repository gcc-repository: success

Repository contents:

ACS/admin# show repository gcc-repository

gcc-backup-100925-1336.tar.gpg

I tried removing the following commands:

ACS/admin(config)# no snmp-server contact GCC-IT
ACS/admin(config)# no snmp-server location GCC-DC

Sat Sep 25 14:56:31 AST 2010: restore gcc-backup-100925-1334.tar.gpg from repository gcc-repository: success

ACS/admin# restore gcc-backup-100925-1336.tar.gpg repository gcc-repository application acs
Restore requires a restart of application services. Continue? (yes/no) [yes] ? yes
Stopping ACS.
Stopping Management and View....................
Stopping Runtime...........................
Stopping Database....
Cleanup.....
Starting acs

ACS/admin# show restore ?
  history  Display restore history

ACS/admin# show restore history
Sat Sep 25 15:46:30 AST 2010: restore gcc-backup-100925-1336.tar.gpg from repository gcc-repository: success

However, the two snmp commands are not reverted back.

2. Also, if i just run the backup command, i get some error though there is a 54 MB file copied successfully to the FTP server:

The following are the captures:

ACS/admin# backup bkp repository gcc-repository
% Creating backup with timestamped filename: bkp-100925-1517.tar.gpg
tar: backup/acs/view/avreports/repository/public/public: Cannot stat: No such file or directory
tar: Error exit delayed from previous errors

show backup history

Sat Sep 25 15:17:49 AST 2010: backup bkp-100925-1517.tar.gpg to repository gcc-repository: success

Please advise what the above error means?

Thanks a lot

Gautam

7 REPLIES
New Member

Re: ACS 5.1 backup issues

Dear friends,

I made a change in the GUI by removing a user and then restoring from backup and it worked fine.

So i guess that the ACS config that they are referring to is the GUI config?

I got the answer for point 1. However, can anyone just give me some clue for the issue i am facing in point 2?

Thanks a lot

Gautam

Re: ACS 5.1 backup issues

Gautam,

One of my customer had a same issue and we got the fix.

Could you also try taking a backup on your ACS appliance with the following command on the
ACS cli: backup repository

And then restore the same backup onto the same ACS with the following command from the
cli:  restore repository

thanks,
Vinay
Thanks & Regards
New Member

Re: ACS 5.1 backup issues

Dear Vinay,

I tried the same thing. Please find below the captures:

ACS/admin# backup bkp repository gcc-repository
% Creating backup with timestamped filename: bkp-100925-1517.tar.gpg
tar: backup/acs/view/avreports/repository/public/public: Cannot stat: No such file or directory
tar: Error exit delayed from previous errors

show backup history

Sat Sep 25 15:17:49 AST 2010: backup bkp-100925-1517.tar.gpg to repository gcc-repository: success

Thanks a lot

Gautam

New Member

Re: ACS 5.1 backup issues

I wish I new.  I am having the same backup issue.  On phone with TAC now.

New Member

Re: ACS 5.1 backup issues

Hi

I have make an upgarde from ACS 5.1 to 5.2 and after a restore I can't make a baxckup i get the same error

Thanks

Jorn

New Member

Re: ACS 5.1 backup issues - Same issue on 5.2

Hi,

observed the same error message yesterday on 5.2 a fresh reimaged ACS Appliance.

Did a Backup on 5.1, Installed 5.2, restored the 5.1 Backup to the appliance

After that tried another backup on the CLI:

svacs1/admin# backup Test123 repository RepoBackup

% Creating backup with timestamped filename: Test123-101020-1322.tar.gpg

tar: backup/acs/view/avreports/repository/public/public: Cannot stat: No such file or directory

tar: Error exit delayed from previous errors

svacs1/admin#

From my point of view, the error message looks exactly like

the output of the native unix tar-command.

The directory names seem to indicate a repository for reports should be archived in the tar file,

but the specified files/directory does not exist in the appliances' file system.

Anyone already opened a SR with the CiscoTAC ?

Got useful Answers or even a BugID ?

Frank

Cisco Employee

Re: ACS 5.1 backup issues - Same issue on 5.2

Hi all,

you can have a look at the following bug: CSCtj35006

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtj35006

This is just a cosmetic issue and you can check on the ADE.log file for the actual result of the backup task.

I hope this helps.

Regards,

Federico

1865
Views
0
Helpful
7
Replies