Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ACS 5.2 upgrade

This past weekend we did an upgrade from 5.1 to 5.2 (backup, re-image, restore backup). 

We are running on 5.2 now J.  Two issues though when issuing a backup command from CLI using the below command I get an error.

backup testbk repository NMS1

% Creating backup with timestamped filename: testbk-101115-1450.tar.gpg

tar: backup/acs/view/avreports/repository/public/public: Cannot stat: No such fi

tar: Error exit delayed from previous errors

and also I’m seeing the below error in the system log couple times a minute.

Nov 15 14:13:12 AHA-ACS-1 adclient[5119]: WARN  <fd:38 rt_daemon(4958)> Failed to send message: Socket closed

Nov 15 14:13:22 AHA-ACS-1 adclient[5119]: WARN  <fd:24 rt_daemon(4958)> Failed to send message: Socket closed

Nov 15 14:13:37 AHA-ACS-1 adclient[5119]: WARN  <fd:49 rt_daemon(4958)> Failed to send message: Socket closed

Nov 15 14:14:53 AHA-ACS-1 adclient[5119]: WARN  <fd:28 rt_daemon(4958)> Failed to send message: Socket closed

Nov 15 14:15:23 AHA-ACS-1 adclient[5119]: WARN  <fd:39 rt_daemon(4958)> Failed to send message: Socket closed

Any ideas? 

Thanks,

Mike

5 REPLIES
Cisco Employee

Re: ACS 5.2 upgrade

1) Is your GUI backup working fine ?

Did you try the "acs backup ..." command ?

2) Looks like the AD client is disconnecting. Having any trouble with AD ? Did you configure AD at all ?

Nicolas.

New Member

Re: ACS 5.2 upgrade

Thanks Nicolas for responding.  Yes the GUI works fine and users are being authenticated for vpn and wireless.  So ACS is working like it should after the upgrade. What is the difference from "acs backup" versus using just the "backup" command?

Cisco Employee

Re: ACS 5.2 upgrade

This question was tackled here :

https://supportforums.cisco.com/message/3206319#3206319

===

Don't forget to rate answers that you find useful

New Member

Re: ACS 5.2 upgrade

Hi...

There is a known bug regarding the backup complaint/error message.  It's basically a complaint message and you've probably realized by now that your backup does complete.  That being said, below is the reply we got from Cisco regarding that error message:

CSCtj35006    'No such file or directory' error appears during CLI backup.

Reason for this error:

At the time of restoring the 5.1 backup on top of 5.2, somehow "public ->
../../public" link file is creating in the following directory.
/opt/CSCOacs/view/data/repository/public.

This link file is creating when we are restoring 5.1 backup on top of 5.2.

Because of this link we are getting the error(No such file or directory) at
the time of taking the backup of 5.2 after restore.

Since this is a newly filed bug, options are:

1)  Ignore and wait/monitor for the fix
Or

2)  From the OS (needs a patch to be applied to access OS) delete the directory.

New Member

Re: ACS 5.2 upgrade

Thanks.  I suppose if it "aint" broke don't fix it would come in to play here.  As long as the backup proces is working

I'll leave things alone.

2721
Views
8
Helpful
5
Replies
CreatePlease login to create content