Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

ACS 5.4 FTP \ in username

Hi,

I have an ACS 5.4 with the latest patch installed and I want to add an external repository by FTP, except the FTP server is IIS 6.0 on Windows 2k3 and it requires the username to be: DOMAIN\username

It seems the \ character is not unsupported by ACS; GUI gives an error, CLI actually accepts the command but clears the \ from the running (replaces it with DOMAINusername)...

show repository in CLI fails because of this, IIS logs a username/password error in event viewer.

I also tried DOMAIN@username; username@DOMAIN.LOCAL (FQDN), username@DOMAIN... (also tried in lowercase)

anyone ever tried this?

Thanks,

Patrick

4 REPLIES
Cisco Employee

Re: ACS 5.4 FTP \ in username

Patrick,

As far as I know ACS 5.x doesn't accept any special characters (\, /, @) in username field while creating repo and few other customers also faced the same issue. This is not supported with GUI and CLI. Last I checked this on ACS 5.3. You need to use a simple user account without any special character. I'll also check if there is any enhancement request filed to support this.

~BR
Jatin Katyal

**Do rate helpful posts**

~BR Jatin Katyal **Do rate helpful posts**
Community Member

Guys has this issue ever got

Guys has this issue ever got a solution? I am having the same problem on ACS 5.5.0.46.6.

It seems @ is allowed in the field but I have no confirmation that domain@username works fine.

Can anyone confirm domain@username works?

 

Thanks!

Microsoft team ended up

Microsoft team ended up fixing it in the Windows FTP server by assigning a default domain... check resolution 4 in the following link:

http://support.microsoft.com/kb/200475

No fix in ACS as far as I know.

Patrick

Community Member

Very well, works for me with

Very well, works for me with ACS 5.5 and IIS 6.0

I can use domain acc now without stating a domain.

Thx

371
Views
5
Helpful
4
Replies
CreatePlease to create content