Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ACS and WIndows Server 2012

Hi all, does anyone happen to know if there is  Remote Agent that will install and run on Windows Server 2012? I know we are way behind on code releases, we are running 4.2.0 ACS. We have been waiting for ISE to incorporate TACACS+, as that is the only thing we still use ACS for in our enviroment. Our server team is wanting to upgrade our Domain Controllers to Server 2012, and I am not sure there is a remote agent that would allow us to still tie back our ACS accounts to domian credentials. Please advise.

 

If we upgrade to ACS 5.X am I correct in thinking that like ISE, there is no need to load a remote agent on the DC's?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Remote agent doesn't support

Remote agent doesn't support windows 2012. Only ACS 5.4 patch 2 supportes windows 2012 and that doesn't need remote agent as it uses inbuild Adagent to talk to active directory.

ACS 5.4 patch 2 supports Windows 2012 AD.

http://www.cisco.com/c/en/us/td/docs/net_mgmt/cisco_secure_access_control_system/5-4/release/notes/acs_54_rn.html

 

Regards,

Jatin Katyal

*Do rate helpful posts*

~BR Jatin Katyal **Do rate helpful posts**
5 REPLIES
Cisco Employee

Remote agent doesn't support

Remote agent doesn't support windows 2012. Only ACS 5.4 patch 2 supportes windows 2012 and that doesn't need remote agent as it uses inbuild Adagent to talk to active directory.

ACS 5.4 patch 2 supports Windows 2012 AD.

http://www.cisco.com/c/en/us/td/docs/net_mgmt/cisco_secure_access_control_system/5-4/release/notes/acs_54_rn.html

 

Regards,

Jatin Katyal

*Do rate helpful posts*

~BR Jatin Katyal **Do rate helpful posts**
New Member

Thank you for the reply Jatin

Thank you for the reply Jatin. Sorry but I should have mentioned that the functional level of the AD will remain at 2008 for the time being. We just want to install the existing 4.2 remote agent on the 2012 Server, and I am not sure that will even install ont hat OS version.  Any idea if it will?

Cisco Employee

I don't think so because

I don't think so because functional level can only be checked during the auth phase. During installation it will check a underlying OS. ACS 4.2 doesn't even work well with Windows 2008 R2. Windows 2012 will not give you any luck for sure.

Supported OS with ACS 4.2

http://www.cisco.com/c/en/us/td/docs/net_mgmt/cisco_secure_access_control_server_for_windows/4-2/installation/guide/windows/IGwn42/install.html#wp1041324

You can give a try, will take few minutes.

 

Regards,

Jatin Katyal

*Do rate helpful posts*

~BR Jatin Katyal **Do rate helpful posts**
New Member

Jatin, thank you again for

Jatin, thank you again for your help. I feared that would be the answer. Sounds like we have to upgrade or get Cisco to support TACACS for within ISE very soon :)

 

Jeff

Cisco Employee

Well tacacs will be

Well tacacs will be introduced in ISE 2.0. Currently, the ISE engeering team working/discussing to release ISE 1.3 this summer so difficult to comment on ISE 2.0 release date, should not be available for next year atleast.

 

Regards.

Jatin Katyal

*Do rate helpful posts* 

~BR Jatin Katyal **Do rate helpful posts**
262
Views
0
Helpful
5
Replies
CreatePlease to create content