Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ACS Upgrade problem

HI

I want to upgrade my ACS-Server from version 4.1.1 to 4.1.3 on a W2003.

When i reach the point where the software wants to remove the previous version i always get the information that another process is blocking tha action. I have disabled the interface, stopped all processe i know, but the problem still exists.

I did the same for my Backup-ACS and there it was no problem. The only different is that there i have W2K.

5 REPLIES

Re: ACS Upgrade problem

The error that we are getting is generally due to huge accumulation of logs in ACS installation folder :

Please remove all the file from following location and then try ( these files are debug files, so we donot require them) :

\CSAuth\Logs

\CSRadius\Logs

\CSTacacs\Logs

\CSLog\Logs

\CSMon\Logs

\CSAdmin\Logs

\CSDbsync\Logs

Please take a backup of following folder, if auditing is required in our organization :

\Log

After taking backup of this folder, please remove logs from following location:

\Logs\AdminAudit

\Logs\Backup and Restore

\Logs\DBReplicate

\Logs\Failed Attempts

\Logs\RADIUS Accounting

\Logs\ServiceMonitoring

\Logs\TACACS+ Accounting

\Logs\TACACS+ Administration

- Stop any anitvirus software that might be running.

- Ensure that if you are using CSMARS, and you are using pnlogagent, then that service is stopped, which can be done from services.msc.

- In the end, Also make sure that Drive on which ACS is installed or installation folder or sub-folders are not shared.

Regards,

Prem

Community Member

Re: ACS Upgrade problem

Hi Prem

I did your recommentation step by step, but i have still the same problem.

Regards,

norbert

Re: ACS Upgrade problem

Hi norbet,

That is strange though.

First of all, take a database backup of 4.1.1

System configuration > ACS Backup > Backup Now (2 0r 3 backups). And keep it in a safe place.

And now open Service.msc, and check what all services are running. And try to identify any service, which might be constantly monitoring the system.

Antivirus or Pnlogagent was what I can think of.

Try rebooting and see of that helps.

But thing is accessing/scanning/or doing something with the files on location.

Try to compare what stuff/software/services you had on W2k as compared to W2k3 server.

THT

Regards,

Prem

Community Member

Re: ACS Upgrade problem

Hi

I have some news. I tried two days along to upgrade ACS4.1 to 4.1.3 but not successfully.

So i tried to deinstall the software from the "Add/Reomove" section from the Control panel in W2003. And ther i received the error message that file "C:\progr.files\acs4.1\DeIsl1.isu" could not be found. I have no idea why the file was not in this directory. So i copied this file from my backup ACS in the right place and then the upgrade was no problem.

regards

norbert

Re: ACS Upgrade problem

Good Job,

But yes that is weired, do you happen to have any AV, might be that file got quarantined, due to *some* reason.

If you do, make sure from now on you evade ACS installation folder and sub folder from being scanned.

Regards,

Prem

198
Views
15
Helpful
5
Replies
CreatePlease to create content