Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CDA GUI login

Is there a way to reset the GUI admin password. I can ssh into the CDA with admin, but not the GUI.

Thanks,

Avery

3 REPLIES
Cisco Employee

CDA GUI login

I am working on the assumption that you are talking about the Context Directory Agent.

Resetting the password for the GUI login may prove a more time consuming task than hoped for.


Note The  username and password specified during the initial setup program can be  used for both the CLI and the GUI. If you change the GUI password using  the user interface, the CLI password does not change and vice versa.



http://www.cisco.com/en/US/docs/security/ibf/cda_10/Install_Config_guide/cda_install.html

Given this information, the users created through CLI only have CLI access.

You may have to backup your config and perform an application reset-config to set up a new admin user for the GUI:

application reset-config

To reset the Cisco CDA application configuration and clear the Cisco CDA database, use the application reset-config command  in the EXEC mode. (This command does not reset your initial chassis  configuration settings like the IP address, netmask, administrator user  interface password, and so on.) Part of this reset function requires you  to enter new Cisco CDA administrator name and passwords.


http://www.cisco.com/en/US/docs/security/ibf/cda_10/Install_Config_guide/cda_cmd_ref.html#wp1053239

Wish I had better news for you, but this may be the only way...

Please Rate Helpful posts and mark this question as answered if, in fact, this does answer your question.  Otherwise, feel free to post follow-up questions.

Charles Moreton

Cisco Employee

CDA GUI login

If it's the GUI password you have forgotten, you can reset it using the CLI command "application reset-passwd cda 
New Member

I know this an old post, but

I know this an old post, but I ran across this issue very recently and was able to fix it with this command.  It turns out that when I'd setup the initial password, I used an invalid character in the password.  The setup script didn't reject the password and it worked for logging into the CLI, but not the GUI.  Using the "application reset-passwd cda <username>" command told me which characters were valid and let me enter in a password that worked for both interfaces.

711
Views
5
Helpful
3
Replies