Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco NAC: Windows 7 update issue with NAC Agent Compliance Module Ver 3.5.1549.2 !!!

Hi,

Currently, i deployed a Cisco NAC Appliance with sofware version = 4.8.2. My NAC agent software version = 4.8.3.3 and

Compliance Module version = 3.5.1549.2.

Some machines are having the older compliance module sofware versions are like 3.5.2.5. So, when users are connecting to the network and CAM is offering the newer compliance module sofware version i-e., 3.5.1549.2.

The issue is that, Win-XP users are getting the update from CAM but Win-7 users are  getting stuck while getting update of compliance module from CAM...

Any comment or idea?

Regards,

Mubasher Sultan

3 REPLIES

Cisco NAC: Windows 7 update issue with NAC Agent Compliance Modu

Mubasher,

Can you please elaborate the issue? I dont follow what the issue is with regards to the compliance module. Is the agent software being upgraded or is there a message on the agent that states updating compliance module pack and it sets there and hangs?

Thanks

Tarik Admani

Tarik Admani *Please rate helpful posts*

Cisco NAC: Windows 7 update issue with NAC Agent Compliance Modu

Hi,

When user connects to the network. It gets prompted about the upgrade of current compliance module to the latest version which is 3.5.1549.2... If user chooses to upgrade, then it get stuck and nothing happens. I can't even see the user in the list of online either in In-band or Out-of-band in Cisco NAC...

The same process works well for the Win-XP users.

Hope, it is clear.

Regads,

Mubasher Sultan

Cisco NAC: Windows 7 update issue with NAC Agent Compliance Modu

Hi,

The problem is solved after upgrading the NAC software to 4.9.1.

Alternative solution was to regenerate the certificates haing upper or lower cases together.

Hope it will help to others

Regards,

Mubasher Sultan

1433
Views
0
Helpful
3
Replies
CreatePlease to create content