Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CTA doesn't load Posture Plugin

Hi. We have developped a Posture Plugin Dll and an ACS server. The server part works well, but I can't have the CTA to load our DLL. Thus, our ACS server doesn't receive our VAF and the device is quarantined.

I ran the ctastat.exe utility which tells that the plugin is operational. I ran the ppta.exe and everything works fine. I'm sure the Dll is never loaded because I put some trace in the DLL_ATTACH_PROCESS function.

So I wonder, apart from defining the external posture validation (with the URL to our ACS), are there any other setting that I should define ?

Thank you

Stephane

1 REPLY
Silver

Re: CTA doesn't load Posture Plugin

Each NAC-compliant application is responsible for installing its own posture plugin on end systems.Plugins for Windows environments are located in \Program Files\Common Files\PostureAgent\Plugins\Install .When CTA receives a posture request, it scans the PostureAgnt\Plugins\Install directory for new or updated posture plugins.Refer the following URL for more info

http://www.cisco.com/en/US/products/ps5923/products_maintenance_guide_chapter09186a00806870db.html#wp1035428

122
Views
0
Helpful
1
Replies