Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How do I remove a network device from ISE 1.2.1.198?

I have a distributed deployment running ISE 1.2.1.198. Last week I created a dummy switch entry in the Network Devices list using a /24 subnet as the IP address (just to see if I could). My problem now is I can't remove this device. When I go to the Network Devices list page I can see a nice big red X with delete written next to it. Trouble is this remains greyed out even when I have devices selected.

Has anyone else come across this? Am I doing something remarkably silly here?

 

Thanks

Alan

9 REPLIES
Gold

IF you had created the root

IF you had created the root network device then:

Root Network Device Groups

Cisco ISE includes two predefined root NDGs: All Device Types and All Locations. You cannot edit, duplicate, or delete these predefined NDGs, but you can add new device groups under them.

You can also create a root Network Device Group (NDG), and then create child NDGs under the root group in the Network Device Groups page. When you create a new root NDG, you must provide the name and type of the NDG. This information is not required when you create a child under the root NDG.

To delete network devices, complete the following steps:


Step 1 Choose Administration > Network Resources > Network Devices.

Step 2 From the Network Devices navigation pane on the left, click Network Devices.

The Network Devices List page appears.

Step 3 Check the check boxes next to the devices that you want to delete and click Delete > Delete Selected. You can alternatively choose the network device listed in the navigation pane on the left and from the action icon (), and click Delete device.


Note You can click Delete > Delete All to delete all the devices that you have defined


A dialog box appears with the following message:

Are you sure you want to delete "Device name"?

Step 4 Click OK to delete the device.

To delete an NDG, complete the following steps:


Note You cannot delete an NDG that has a subgroup under it



Step 1 Choose Administration > Network Resources > Network Device Groups.

Step 2 From the navigation pane on the left, click Group Types.

The Network Device Groups listing page appears.

Step 3 From the Group Types navigation pane on the left, choose the parent NDG whose child NDG you want to delete.

The Network Device Group listing page appears with a list of child NDGs.

Step 4 Check the check box next to the NDG that you want to delete and click Delete. Alternatively, you can choose the child NDG that you want to delete from the navigation pane on the left and click Delete Group from the action icon.

A dialog box appears with the following message:

Are you sure you want to delete?

Step 5 Click OK to delete the NDG.

 

New Member

Hi Mohana,Thanks for the

Hi Mohana,

Thanks for the reply but the problem is not that I can't find the Delete button but that it is greyed out and thus will not delete the device I wish to remove.

Please see Capture1.jpg attached. This shows no devices selected and the Edit, Duplicate, Export, Generate PAC and Delete buttons all greyed out.

Now please see Capture2.jpg. This shows the switch I wish to delete XXX-1-Switch selected. Note that the Edit and Duplicate options are now available to me but the Export, Generate Pac and Delete buttons are still greyed out and thus unavailable.

Please note that in both cases the only action icon is at the top of the page and all that allows me to do is change the columns that are displayed on the main Network Devices page. The only other action icon that appears is when I edit the switch and all that allows me to do is add or delete ip addresses.

This is not a major for me as I still have a lot of devices to add to this deployment so I can get around my problem by simply editing this device when the next one is added changing the properties to match those of the new device. However I can see how being able to remove devices from the list may very well be something that myself and others may wish to do in the future so my question really is - am I missing something here or should I bring this to the attention of TAC so that if there is a problem it can be rectified in a future patch or release?

 

Thanks

Alan

New Member

That's an odd one. Perhaps

That's an odd one. Perhaps restart the services on your PAN or before that have you tried another browser? Worst case you may need TAC to manually delete it from the database via sql commands. I'm assuming. Goodluck with it :)
New Member

Thanks, Ryan. Glad it's not

Thanks, Ryan. Glad it's not just me that thinks it's strange. I've tried a number of browsers and I'm sure I've restarted the PAN but I'll try that again to make sure.

 

Cheers

Alan
 

New Member

Hi Alan,    Try using IE

Hi Alan,

    Try using IE latest version and change the compatibility mode to IE 9 or 10 and then try to delete it. Also make sure that IE doesnt give any certificate error. If it does then install teh certificate and then try it again.

 

Cheers

Minakshi(Rate the helpful posts)

New Member

Hi Minaksh, I don't think it

Hi Minaksh,

 

I don't think it is a browser issue. As well as the production devices I have also got three VMs running 1.2.1.198 in a Test and Development lab and I do not have the same problems there - ie on the admin node for that cluster I am able to delete devices without any problem - please see VM Capture.jpg attached - unlike the production box - Prod Capture.jpg. These two sessions are running as different tabs in the same browser session.

 

Thanks

Alan

New Member

Steve,   Try  to restore the

Steve,

 

  Try  to restore the  production database on the LAB device and then see if you able to delete it. In case if you feel the same issue there, Then you will need to contact TAC for manually removing the database as it could be a corrupted entry

 

Cheers

Minakshi(Do rate the helpful post)

New Member

Thanks, Minakshi.I have come

Thanks, Minakshi.

I have come to the conclusion it is time to contact TAC. My lab VM is working fine it is my production deployment running on Cisco hardware that has the issue.

 

Cheers

Alan (not Steve) :-)


 

New Member

To all who are interested.In

To all who are interested.

In the course of talking to TAC about this issue I have discovered something quite interesting. The problem occurs when there is more than one page worth of devices listed in the Network Devices page.

When I first go to the page the Delete button is available to me - please see Delete button showing.jpg. However the device I wish to delete is the last one on the page and when I scroll down to get to it - lo and behold, the Delete button becomes greyed out - please see Delete button missing.jpg

I have found that I can sort my devices so the one I wish to delete is at the top of the page and I can also use a Filter to narrow down the list of devices displayed. Using both of these methods I am able to keep that pesky Delete button under control.

I'm just waiting now to see if TAC confirm I need to re-create my deployment - this will not make me happy.

 

Alan

299
Views
0
Helpful
9
Replies