Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Invalid patch when installing 5.3.0.40

I am trying to upgrade from Version 5.2.0.26.10 to 5.3.0.40. I have upgraded the ACS many times before without any problems. However, now I get "Invalid patch".

This is the procedure I follow;

ACS/admin(config)# repository FTP
ACS/admin(config-Repository)# url ftp://10.50.0.251
ACS/admin(config-Repository)# user anonymous password plain asdf@aasdf.ss
ACS/admin(config-Repository)# exit
ACS/admin(config)# exit

ACS/admin# show repository FTP
.
..
5.3.0.40.tar.gpg


ACS/admin# acs patch install 5.3.0.40.tar.gpg repository FTP
Invalid patch '5.3.0.40.tar.gpg', cannot unpack.
% Error: Failure to open / validate the patch

I downloaded the patch twice in case the first download was corrupt, renamed it from ACS_5.3.0.40.tar.tar to 5.3.0.40.tar.gpg and use FTP when transfer. Still, it does not work. Help anyone?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Invalid patch when installing 5.3.0.40

This is not a patch install rather an application upgrade since going from one release to another

The command to be used is application upgrade. See

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.3/installation/guide/csacs_upg.html#wp1194859

application upgrade ACS_5.3.tar.gz repository-name

One other comment is that when you upgrade to ACS 5.3 you should have patch 4 ready to install as part of this upgrade. See latest update in ACS 5.3 release notes

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.3/release/notes/acs_53_rn.html#wp207609

Relevant section is

"IWhen you install ACS 5.3 or upgrade any older version of ACS to ACS 5.3, you are stongly recommended to install the cummulative patch 5.3.0.40.4 as a part of this installation or upgrade process. This patch includes some important fixes that are related to the upgrade process and Active Directory operations.

f you use Upgrading an ACS Server Using Application Upgrade Bundle method to upgrade ACS, then you must install the cummulative patch 5.3.0.40.4 after the successful completion of the upgrade process.

Note that, while upgrading ACS with upgrade bundle method, some log collection related processes may not be restarted successfully. The log collection related processes will be restarted after installing the cummulative patch 5.3.0.40.4 If you use Upgrading an ACS Server Using Application Upgrade Bundle method to upgrade ACS, then you must install the cummulative patch 5.3.0.40.4 after the successful completion of the upgrade process.
Note that, while upgrading ACS with upgrade bundle method, some log collection related processes may not be restarted successfully. The log collection related processes will be restarted after installing the cummulative patch 5.3.0.40.4"

3 REPLIES
Gold

Invalid patch when installing 5.3.0.40

This is not a patch install rather an application upgrade since going from one release to another

The command to be used is application upgrade. See

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.3/installation/guide/csacs_upg.html#wp1194859

application upgrade ACS_5.3.tar.gz repository-name

One other comment is that when you upgrade to ACS 5.3 you should have patch 4 ready to install as part of this upgrade. See latest update in ACS 5.3 release notes

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.3/release/notes/acs_53_rn.html#wp207609

Relevant section is

"IWhen you install ACS 5.3 or upgrade any older version of ACS to ACS 5.3, you are stongly recommended to install the cummulative patch 5.3.0.40.4 as a part of this installation or upgrade process. This patch includes some important fixes that are related to the upgrade process and Active Directory operations.

f you use Upgrading an ACS Server Using Application Upgrade Bundle method to upgrade ACS, then you must install the cummulative patch 5.3.0.40.4 after the successful completion of the upgrade process.

Note that, while upgrading ACS with upgrade bundle method, some log collection related processes may not be restarted successfully. The log collection related processes will be restarted after installing the cummulative patch 5.3.0.40.4 If you use Upgrading an ACS Server Using Application Upgrade Bundle method to upgrade ACS, then you must install the cummulative patch 5.3.0.40.4 after the successful completion of the upgrade process.
Note that, while upgrading ACS with upgrade bundle method, some log collection related processes may not be restarted successfully. The log collection related processes will be restarted after installing the cummulative patch 5.3.0.40.4"

New Member

Re: Invalid patch when installing 5.3.0.40

Perfect, thank you that worked. However, some additional input for the rookies like myself out there;

ACS/admin# application upgrade 5.3.0.40.tar.gz FTP

Do you want to save the current configuration ? (yes/no) [yes] ? yes

Generating configuration...

Saved the running configuration to startup successfully

After this command you will see the file being transferred from your FTP application, but you won't get any updated status messages in the CLI. You just have to wait 5-10 minutes, then this message pops up;

% CARS Install application required post install reboot...

Broadcast message from root (pts/0) (Wed May 23 16:24:03 2012):

The system is going down for reboot NOW!

Then what's happening? Nothing, wait a little longer, estimated 2-4 minutes, then this message pops up;

Application upgrade successful

TBGACS02/admin#

Connection timed out

Now the ACS finally restarts - estimated 15 minutes from when you enter the "application upgrade". After reboot the process 'view-database' never starts, it hangs on restarting. I did an ACS STOP and ACS START, then after a few minutes all services was up and running. I then continued to install all the 4 patches until the 5-3-0-40-4. However, you rookies, when installing the patches you must use the "old" acs patch install -command..

Thanks to jrabinow for providing me with the answer and document link.

Gold

Invalid patch when installing 5.3.0.40

Just FYI. Patches are cumulative and so you only need to install the latest

1524
Views
0
Helpful
3
Replies
CreatePlease to create content