Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issues Upgrading ACS 3.3 to 4.0

Guys,

I have a Cisco ACS server 3.3 running on a win2k platform and i have to upgrade to ACS4.0 on win2k.

- backing up 3.3 and restoring files on 4.0 using web interface doesn't work;

- the same operation using csutils.exe doesn't work (csutil -b [...] and then csutil -r [...])

- i have installed the new machine with ACS3.3, i have imported user/group/data with csutil, then i have installed ACS 4.0 using setup.exe; the result is that ACS's services fail to start

Anyone knows what I have to do?

Thanks,

Rob

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Issues Upgrading ACS 3.3 to 4.0

Hi Antonio,

- backing up 3.3 and restoring files on 4.0 using web interface doesn't work.

*It wont work, as in ACS we can backup and restore database among ACS's of same versions only, same applies for replication.

- the same operation using csutils.exe doesn't work (csutil -b [...] and then csutil -r [...])

*Answer will be same as above.

- i have installed the new machine with ACS3.3, i have imported user/group/data with csutil, then i have installed ACS 4.0 using setup.exe; the result is that ACS's services fail to start.

*Normal cause for this is that you might be hitting a bug, according to which when we try to upgrade a database of ACS 3.3(x) build xx to ACS 4.0 and we have trailing spaces in AAA client and/or AAA servers entry in databaae, then that may cause an issue. But we may not be hitting that bug.

Correct way to upgrade :

[1] Verify we are following correct and supported upgradation path :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/rnwin401.htm#wp37488

[2] Then follow following steps to upgrade :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/install/install.htm#wp1041858

Summarizing above link, just run setup of ACS 4.0 over existing setup of ACS 3.3, and setup will prompt you itself, to save previous configuration, select yes at that point.

Let me know if this helps. Please rate if it help.

Regards,

Rafael Lanna

2 REPLIES
Bronze

Re: Issues Upgrading ACS 3.3 to 4.0

Hi Antonio,

- backing up 3.3 and restoring files on 4.0 using web interface doesn't work.

*It wont work, as in ACS we can backup and restore database among ACS's of same versions only, same applies for replication.

- the same operation using csutils.exe doesn't work (csutil -b [...] and then csutil -r [...])

*Answer will be same as above.

- i have installed the new machine with ACS3.3, i have imported user/group/data with csutil, then i have installed ACS 4.0 using setup.exe; the result is that ACS's services fail to start.

*Normal cause for this is that you might be hitting a bug, according to which when we try to upgrade a database of ACS 3.3(x) build xx to ACS 4.0 and we have trailing spaces in AAA client and/or AAA servers entry in databaae, then that may cause an issue. But we may not be hitting that bug.

Correct way to upgrade :

[1] Verify we are following correct and supported upgradation path :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/rnwin401.htm#wp37488

[2] Then follow following steps to upgrade :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/install/install.htm#wp1041858

Summarizing above link, just run setup of ACS 4.0 over existing setup of ACS 3.3, and setup will prompt you itself, to save previous configuration, select yes at that point.

Let me know if this helps. Please rate if it help.

Regards,

Rafael Lanna

Silver

Re: Issues Upgrading ACS 3.3 to 4.0

I have actually upgraded from a v3.x to v4.0 by importing the user db with csutil... and it can work - did for me.

FWIW the network config is *not* included in the dump.txt file so it wont be that preventing ACS from starting up.

What you have to look out for, is that if groups/users refer to NDGs if their T+ enable config... this will likely get screwed because they hold an id and not the name of the NDG.

Darran

144
Views
0
Helpful
2
Replies
CreatePlease to create content