Cisco Support Community
Community Member

Parser Views Configuration and Issues


I'm a CCNA/CCNP R&S and started my CCNA Security.  I was trying to deploy a parser view on one of my routers just to give someone limited access.  One thing I noticed is that when I created the view and start putting in the allowed commands I run into a problem.  If I do the following "commands exec include all show" then for some reason in the running configuration it leaves the all keyword out.  When you log into the view it only allows a show command with two options.  It seems to only be allowing specific commands and not taking the all keyword.  I've attaced some output for your viewing. 

Has anyone encountered a similar problem?  I've tried rebooting the router, changing the IOS on the router.  Now I initially created 2 views which had this problem.  After the IOS change, they started working right.  So I created a 3rd view to just make sure all was working and unfortunately the 3rd view is having the same problem.  I've tried rebooting it to no avail.  Any ideas on if this is just buggy, or what the issue might be?  Thanks!



parser view kelly

secret 5 $xxxxxxxxxxxxxxxxxxx

commands exec include configure terminal

commands exec include show running-config

commands exec include show     <---------this only allows "show parser" and "show flash"    It left out the "all" keyword


Router#enable view

Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#parser view kelly
Router(config-view)#commands exec include all show   <----show's I'm putting in the "all" keyword. 

Community Member

Parser Views Configuration and Issues

I've had that same problem in the past.  What I've had to do to resolve that (if you want to call it that) was to just go back into the view and remove the "commands" command and re-add it.  This usually resolved the problem. 

Community Member

Re: Parser Views Configuration and Issues

Please use "show run view full" instead. 

CreatePlease to create content