Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problems upgrading ACS 3.3 to ACS 4.0

I have a Cisco ACS server 3.3 running on a win2k platform and i have to upgrade to ACS4.0 on win2k.

- backing up 3.3 and restoring files on 4.0 using web interface doesn't work;

- the same operation using csutils.exe doesn't work (csutil -b [...] and then csutil -r [...])

- i have installed the new machine with ACS3.3, i have imported user/group/data with csutil, then i have installed ACS 4.0 using setup.exe; the result is that ACS's services fail to start

Any idea?!

THX a lot.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: problems upgrading ACS 3.3 to ACS 4.0

Good to hear that :)

If the post helped you, please rate it, It encourages me.

Regards,

Prem

:)

3 REPLIES
New Member

Re: problems upgrading ACS 3.3 to ACS 4.0

Hi Antonio,

- backing up 3.3 and restoring files on 4.0 using web interface doesn't work.

*It wont work, as in ACS we can backup and restore database among ACS's of same versions only, same applies for replication.

- the same operation using csutils.exe doesn't work (csutil -b [...] and then csutil -r [...])

*Answer will be same as above.

- i have installed the new machine with ACS3.3, i have imported user/group/data with csutil, then i have installed ACS 4.0 using setup.exe; the result is that ACS's services fail to start.

*Normal cause for this is that you might be hitting a bug, according to which when we try to upgrade a database of ACS 3.3(x) build xx to ACS 4.0 and we have trailing spaces in AAA client and/or AAA servers entry in databaae, then that may cause an issue. But we may not be hitting that bug.

Correct way to upgrade :

[1] Verify we are following correct and supported upgradation path :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/rnwin401.htm#wp37488

[2] Then follow following steps to upgrade :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_soft/csacs4nt/acs40/install/install.htm#wp1041858

Summarizing above link, just run setup of ACS 4.0 over existing setup of ACS 3.3, and setup will prompt you itself, to save previous configuration, select yes at that point.

Let me know if this helps.

Regards,

Prem

:)

New Member

Re: problems upgrading ACS 3.3 to ACS 4.0

Prem, thanks a lot, running setup over existing previous version works!

The problem of services: to make a test, i was upgrading a virtual machine with the real configuration (such as replica servers..) and in the virtual environment those servers were down(because they didn't exist), so services failed to start correctly and the upgrading process stopped.

Regards,

Antonio.

New Member

Re: problems upgrading ACS 3.3 to ACS 4.0

Good to hear that :)

If the post helped you, please rate it, It encourages me.

Regards,

Prem

:)

129
Views
0
Helpful
3
Replies
CreatePlease login to create content