Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with ACS upgrade

Hello,

We ae using the ACS release 2.1 and we are migrating this server to the release 3.1, the problem is that when we tryed to migrate from 2.1 directly to 3.1 the database did not make it, i.e. we could not migrate the user, groups and network config to the new version. In fact there is a note in the 3.1 documentation that states the folowing: upgrading to ACS 3.1.1 has been tested from versions 3.0.2.5, 3.0.1.40 and 2.6.4. Does anyone have faced a similar problem before? if you have any recomendation please let me know.

Thanks in advance,

Best regards

Carlos C.

3 REPLIES
Cisco Employee

Re: Problems with ACS upgrade

Its not possible to "migrate" the database of 2.1 to 3.1. You could do an 'in-place' upgrade to 2.6.4 and then to the 3.1.

Backing up database in one version and restoring it onto a different version will not work.

e.g. Backup database from 2.6.4, install 2.6.4 on anew server, restore the database from the old server onto this new server and then do an 'in-place' upgrade to the 3.1.

Hope this helps.

Thanks,

yatin

Silver

Re: Problems with ACS upgrade

Carlos,

You have to do a sequential upgrade with the appropriate service packs and the OS. From acs 2.1 to ACS 2.4 (3), then to 2.6.4 and then 3.1. My suggestion would be to have a good back up copy of your database and move it into a different directry than the base and then proceed with the upgrade.

It would make sense to open up a TAC case, as you may need to get all the intermediate releases and only TAC can publish those files for you.

I hope this helps ! Thanks,

Mynul

New Member

Re: Problems with ACS upgrade

Thank you very much for your answer, as I review on the ACS 3.1 documentation a few minutes ago the procedure would be the same as you said, using version 3.0 as the intermediate.

Best regards and thanks for your help

165
Views
0
Helpful
3
Replies
CreatePlease login to create content