Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Radius accounting for SSL VPN user sessions

Hi,

I have configured an SSL VPN with IOS and for security reasons I need the accounting for users sessions.

The WebVPN is working fine as well as the start-stop accounting but I'm not able to configure the sessions accounting.

The "radius user sessions accountig for ssl vpn" feature is available from IOS release 12.4(9)T.

Different documents refer to different commands to implement this feature (in some documents is describe the command "webvpn aaa accounting-list list-name", in other documents the command is "aaa accounting-list list-name"), but in any case I have "Unrecognized command" from router.

I have same result using different version and feature set: "advancedip 12.4(15)T1", "advancedip 12.4.(24)T" and "advancedenterprise 12.4(24)T".

Has somebody an idea on what I'm wrong?

Thanks in advance.

Andrea

2 REPLIES
Cisco Employee

Re: Radius accounting for SSL VPN user sessions

Hi Andrea,

You need to use this command:

"webvpn aaa accounting-list list-name"

Before configuring RADIUS accounting for SSL VPN user sessions, you should first have configured AAA-related commands (in global configuration mode) and have set the accounting list.

Router> enable

Router# configure terminal

Router(config)# aaa new-model

Router(config)# aaa accounting network SSL-VPN start-stop group radius

Router(config)# webvpn aaa accounting-list SSL-VPN

HTH

JK

-Plz rate helpful posts.

~BR Jatin Katyal **Do rate helpful posts**
New Member

Re: Radius accounting for SSL VPN user sessions

Hi,

first of all thanks for you feedback....

Off course I configured the AAA-related commands but the problem is that it looks like the "webvpn aaa accounting-list" command does't exist and it is not accepted from the router. Below is the output from router using question mark:

rou-rm01-access(config)#webvpn aaa accounting?

% Unrecognized command

Same result is for global command "aaa accounting-list".

I also attach the router configuration that I'm using for aaa and SSL VPN:

!

aaa new-model

!

aaa group server radius vpn-srv-radius

server-private 10.0.99.4 auth-port 1812 acct-port 1813 key xxxx

ip vrf forwarding vpn-server

ip radius source-interface FastEthernet1/1

!

aaa accounting network SSL-Teleaperture start-stop group vpn-srv-radius

!

webvpn context Teleaperture

!

aaa authentication list SSL-Teleaperture

aaa accounting list SSL-Teleaperture

!

The SSL VPN is working properly, including radius authentication and "start-stop" accounting.

My problem is in configuring accounting for user sessions.

Regards,

Andrea

489
Views
0
Helpful
2
Replies