Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Restart ACS 4.0 then CSRadius and CSTacacs not starting automatically

Hi,

i have installed the ACS 4.0 on WIN 2003 Server (engl. with SP1) machines, but if i reload the Hardware the Authentication Services (CSRadius and CSTacacs) don't starting automatically.

Any Ideas?

Thanks and best regards!

Alexander

11 REPLIES
Silver

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

You mean if you re-boot the server?

This happens on my PC also. I have to manually start CSRadius and CSTacacs. My guess is they are timing out waiting for CSAuth to be up and running.

Darran

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi,

I'm having exactly the same issue. Could I ask if you resolved the problem and if so how ?.

Or, does anyone else have any ideas - any feedback would be most welcome.

Best Regards,

Malcolm

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi,

Same problem here. These 2 services always fail at startup.

Thanks,

pq

Silver

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Im installing various versions of ACS all the time and so dont remember whether I actually fixed it or not.

Something I think you can do is to set a dependancy between CSAuth and CSRadius in the windows services control panel.

Once done the service manager will not even attempt to start CSRadius until CSAuth is running.

Note there may be unexpected results... if you net stop csauth it will automatically stop csradius first.

Darran

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi All,

This is a well known bug, associated with ACS installed on windows 2003 server.The bug id is CSCsb81671.

This bug has a patch available which you can get from Cisco TAC.

I hope this helps.

Thanks

Gagan

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi All,

In bug toolkit I cannot find any patch for this bug and the workaround is not useful

thanks

renato

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi Renato,

You cannot get the patch via the bug toolkit, you need to contact the Cisco TAC (technical assistance center) to get the patch.

Provide them the bug id.

Thanks

Gagan

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi Gagan, I'm not able to contact the TAC because the product results not in maintenance, anyway I cannot understand why ACS patches are available only through TAC, not from the download site

thanks

renato

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

had the same issue-- had to go to the MS management console thru >My Computer>Computer Management> Then Services

Noticed the services did not start--

Had to reset the password for the logon.

Worked fine then

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

I had a similar issue here on an ACS 1111 appliance I upgraded to ver 4.0 from 3.2.3 Eventually a vicious power down resolved this.

In your case - have you checked that the services are configured to start automatically and that the user account tied to these is active?

Community Member

Re: Restart ACS 4.0 then CSRadius and CSTacacs not starting auto

Hi there,

I've now solved this problem. It's a known bug in the acs database, to do with spaces in the database file. You need a fix program which should be sourced from TAC. I have more info on this though so please email me if you'd like the details etc.

Best Regards,

Malcolm

731
Views
0
Helpful
11
Replies
CreatePlease to create content