Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SSH session premature timeout

Hi,

I have been noticing this issue on most of the devices I touch. Here is the pertinent configuration.

ip ssh ver 2

ip ssh source lo0

ip ssh rsa key SSH-KEY

!

line vty 0 15

trans in telnet ssh

exec-time 30 0

If I telnet to the device, the session will time out in 30 minutes. If I ssh to it, my ssh session will time out after exactly 5 minutes. This is consistent and it aggravates most of my customers. Does anyone know where to set this timer?

It is not "ip ssh time....".

Thank You,

Brian ": )

2 REPLIES

Re: SSH session premature timeout

Hi Brian

Have you tried out ip ssh timeout command to define the required timeout period ?

If not can you configure up the same and check ..

You can also verify the below link on config parameters..

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124tcr/tsec_r/sec_i2ht.htm#wp1226972

regds

New Member

Re: SSH session premature timeout

Yes, I tried that command, but it only goes up to 120 seconds and applies to the session negotiation only. The exec timeout on the vty lines is supposed to take over after the session is set up.

I am going to explore keepalives from SecureCRT but I was hoping there was a fix inside IOS. Maybe it is a bug.

": )

410
Views
0
Helpful
2
Replies
CreatePlease login to create content