Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

TACACS+ Authorization Failed ASR1001

Hi,

I am using the below command structure the same as all of other routers. However, when I attempt to type commands it says "Authorization failed." The only difference between this routers and our others is it is an Cisco ASR1001. Is there any special configuration required for this router that I am missing?

aaa authentication login default group TACACS-SERVERS local

aaa authorization exec default group TACACS-SERVERS local

aaa authorization commands 1 default group TACACS-SERVERS local

aaa authorization commands 15 default group TACACS-SERVERS local

aaa accounting exec default start-stop group TACACS-SERVERS

aaa accounting commands 1 default start-stop group TACACS-SERVERS

aaa accounting commands 15 default start-stop group TACACS-SERVERS

aaa accounting connection default start-stop group TACACS-SERVERS

aaa accounting system default start-stop group TACACS-SERVERS

  • AAA Identity and NAC
Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

TACACS+ Authorization Failed ASR1001

When you log in to the router are you authenticating with your TACACS credentials or with the local credentials? I am guessing that it is the local credentials and that the router is not authenticating or authorizing with the TACACS server. If that is correct you should investigate and find the cause of the failure to use TACACS.

I would also suggest a change that might be helpful. Change this line from

aaa authorization commands 15 default group TACACS-SERVERS local

to

aaa authorization commands 15 default group TACACS-SERVERS if-authenticated

HTH

Rick

3 REPLIES
Hall of Fame Super Silver

TACACS+ Authorization Failed ASR1001

When you log in to the router are you authenticating with your TACACS credentials or with the local credentials? I am guessing that it is the local credentials and that the router is not authenticating or authorizing with the TACACS server. If that is correct you should investigate and find the cause of the failure to use TACACS.

I would also suggest a change that might be helpful. Change this line from

aaa authorization commands 15 default group TACACS-SERVERS local

to

aaa authorization commands 15 default group TACACS-SERVERS if-authenticated

HTH

Rick

New Member

TACACS+ Authorization Failed ASR1001

Thanks a bunch! Issues fixed!

Hall of Fame Super Silver

TACACS+ Authorization Failed ASR1001

I am glad that the issue is fixed and that my suggestion was helpful. Thank you for posting back to the forum to let us know that it is fixed and for using the rating system to mark this question as answered.

HTH

Rick

458
Views
0
Helpful
3
Replies
This widget could not be displayed.