Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

unable to use ACS 5.3 gui even after reset-management-interface command

Hi,

I am unable to use the GUI on our ACS 5.3.40 VM. I have already tried the reset-management-interface command twice and stopped and started the application and performed a reload. I've also cleared my Internet Explorer browser cookies / data etc.

The  ACS application services are still running according to  the CLI status.

The reset-management-interface command said it was successful both times.

We have a working DR which the GUI-less PR one replicates too, but of course I am trying to avoid any rebuilds and of the role swapping.

What else can I try?

FYI The fault occurred when I decided to replace a local certificate on the PR. I wanted to issue a certicate with a shorter expiration time (2017) than the existing one (2018). When I generated one , in the CN= field I put CN=fqdn of the ACS. This was accepted and the browser said it would restart.

It would be great if someone could advise, I can work on it over the weekend as it's possible peolple will be asking to inspect the certificate dates on Monday 10th March.

Many Thanks.

Stuart.

1 REPLY
New Member

Hi, here is some extra

Hi, here is some extra information from acsRuntime.log I have errors like :

When I manually created a certificate

ERROR PKILogic::onGenerateSelfSignedCertificateEx2Request:Generation failed ; error=Invalid certificate subject DN length,PKILogic.cpp:378Eap, 07/03/2014 18:05:165,WARN ,3010931616,NIL-CONTEXT,configureCTL = Failed to initializeCTL,EapConfigObjectBase.cpp:335

When I ran the reset certificate CLI command

ERROR, 3056110496,NIL-CONTEXT,DeviceAttrFactory::createAttrValue with marker = " .DeviceAttrFactory.cpp:29 Shellprofile, 07/03/2014

 

When I attempt to use the GUI.... ERROR,2954697632,onException - reason activemq::to::SocketInputStream::read - The connection is broken; state connected; stack trace: activemq::io::SocketInputStream::read - The connection is broken

 

Will a restore help?

150
Views
0
Helpful
1
Replies