Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

ACE 4710 multiple services running on load balanced Servers

Our Exchange 2010 hub servers run multiple services/ports:  smtp, www, pop3,135, 143, https, 993, 995, 6001,6002,6003,60200,60201,8400, and 8402

what is the best way of balancing these servers so that if only one of the services failed on a server, it would switch only the failed service to remaining servers.

At present I only use an smtp probe, so as log as that sevrice is running the server is marked good. It seems to me the setup could get quite complicated so any responses welcome.

3 REPLIES

ACE 4710 multiple services running on load balanced Servers

Hello,

It is hard to say without checking the configuration first, but we can try to configure a customized class-map, policy-map, serverfarm,etc to hear on the specific ports which you are using, meaning, you can have specific configuration based on each port which you are using, without affecting the rest, that would be the best way I would say since it will be focused on each port and not a mixed of many ports.

Just imagine a probe for that, what would it be supposed to check if it has many ports configured? You see what I mean (Divide and conquer would be the best)

Please attach the configuration related to the issue then we can have a better idea about what you mean and what you are looking for.

Jorge

ACE 4710 multiple services running on load balanced Servers

Jorge,

Please see config below

logging enable

logging buffered 5

logging monitor 5

 

 

 

access-list ALL line 10 extended permit ip any any

access-list ALL line 18 extended permit icmp any any

 

ip domain-name simplot.com.au

ip name-server 172.16.7.210

ip name-server 172.16.5.228

probe icmp icmp

interval 7

faildetect 2

passdetect interval 30

passdetect count 2

receive 5

probe tcp tcp25

port 25

interval 20

passdetect interval 60

passdetect count 2

open 1

rserver host chihub73

description hub73

ip address 172.16.6.196

inservice

rserver host chihub74

description hub74

ip address 172.16.6.197

inservice

serverfarm host Exchange

description DSI servers

failaction purge

probe tcp25

fail-on-all

rserver chihub73

inservice

rserver chihub74

inservice

sticky ip-netmask 255.255.255.255 address source Sticky

serverfarm Exchange

 

class-map type management match-any EXCH

201 match protocol snmp any

202 match protocol https any

203 match protocol telnet any

204 match protocol icmp any

class-map match-any EXCH_vip

2 match virtual-address 172.16.93.2 tcp eq smtp

3 match virtual-address 172.16.93.2 tcp eq www

4 match virtual-address 172.16.93.2 tcp eq pop3

5 match virtual-address 172.16.93.2 tcp eq 135

6 match virtual-address 172.16.93.2 tcp eq 143

7 match virtual-address 172.16.93.2 tcp eq https

8 match virtual-address 172.16.93.2 tcp eq 993

9 match virtual-address 172.16.93.2 tcp eq 995

10 match virtual-address 172.16.93.2 tcp eq 6001

11 match virtual-address 172.16.93.2 tcp eq 6002

12 match virtual-address 172.16.93.2 tcp eq 6003

13 match virtual-address 172.16.93.2 tcp eq 60200

14 match virtual-address 172.16.93.2 tcp eq 60201

15 match virtual-address 172.16.93.2 tcp eq 8400

16 match virtual-address 172.16.93.2 tcp eq 8402

policy-map type management first-match EXCHANGE

class EXCH

permit

policy-map type loadbalance first-match ldap-slb

class class-default

sticky-serverfarm Sticky

policy-map multi-match multi-vips

class EXCH_vip

loadbalance vip inservice

loadbalance policy ldap-slb

loadbalance vip icmp-reply

nat dynamic 6 vlan 93

interface vlan 93

description client server vlan

ip address 172.16.93.4 255.255.255.0

peer ip address 172.16.93.1 255.255.255.0

access-group input ALL

nat-pool 6 172.16.93.8 172.16.93.20 netmask 255.255.255.0 pat

service-policy input EXCHANGE

service-policy input multi-vips

no shutdown

ip route 0.0.0.0 0.0.0.0 172.16.93.254

snmp-server contact "Comms team"

snmp-server location "Chifley park CR"

snmp-server community OVSimplot group Network-Monitor

snmp-server trap-source vlan 93

 

 

ACE 4710 multiple services running on load balanced Servers

Hello,

I would say if you can break it down like this:

class-map match-any sample_vip_135

2 match virtual-address 10.10.10.2 tcp eq 135

:

:

serverfarm host Exchange_sample_vip_135

description DSI servers

failaction purge

fail-on-all

rserver sample1 135

inservice

rserver sample2  135

inservice

As you can see, you can specify the vip for a specific port, then you need to configure a policy for load balance and add it under the policy multimatch in question, and the rest of the config in general. You can create a serverfarm focus on each port and you can specify the port.

Hope this helps!!!

Jorge

725
Views
0
Helpful
3
Replies