Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ACE always balances to the same server :o(

Dear colleagues:

I am new in this area so I followed examples from config guides. The requirement is to balance two real servers in a round-robin fashion but with source IP stickyness (more than one session from the same source IP must be directed to the same real server).

So I put all these commands on the ACE, but it always contacts the same real server although sessions come from two different source IPs:

rserver host SERVER_19

ip address 10.150.3.19

inservice

rserver host SERVER_20

ip address 10.150.3.20

inservice

serverfarm host REAL_SERVERS

probe HTTP_probe

rserver SERVER_19

   inservice

rserver SERVER_20

   inservice

sticky ip-netmask 255.255.255.255 address source WEB_SERVERS

  timeout 720

  serverfarm REAL_SERVERS

  replicate sticky

  timeout activeconns

policy-map type loadbalance first-match SLB_LOGIC

class class-default

   sticky-serverfarm WEB_SERVERS

class-map match-all VIP-30

2 match virtual-address 10.150.3.30 tcp eq www

policy-map multi-match CLIENT_VIPS

class VIP-30

   loadbalance vip inservice

   loadbalance policy SLB_LOGIC

   loadbalance vip icmp-reply active

Am I missing something? Your kind answers will be greatly appreciated

Rogelio Alvez

Argentina

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

ACE always balances to the same server :o(

hello,

as i stated earlier, your confiugration is good, and ACE is able to forward traffic to both servers (not simultaneously, as per your CU testing). So next time before tesitng make sure an empty sticky database, and single connections from multiple machines open parallely. capture show conn detail and sh sticky database, this will help in case it didn't work..........

4 REPLIES
Bronze

ACE always balances to the same server :o(

Hello,

As you must have already read roundrobin is default alogritham in ACE. Also you configuration looks good.

now i have few queries regarding how you are testing and seeing the connection:

--> have you tried opening multiple connection from different IP's (let say 4 machines) simultaneously, is all four connection going to same real server.

--> if yes for above then i will ask for removing that server from serverfarm (no inservice) and then initiate all connection again, just to confirm whehther connection is being forwarded to server or not...

New Member

ACE always balances to the same server :o(

Hello Gaurav:

Yes, I knew that roundrobin is the default predictor. And that is the algorithm I want to be executed. Regarding your queries:

1. At time of thest the customer just had two client laptops from which to try the connections. According to him, connections from both of these two laptops went to the same server (let´s call it server A).

2. I asked the customer to unplug that server (server A) from the switch, and the ACE -as expected- detected it as unavailable. Customer started the connections again from the 2 laptops, and now these connections were redirected to the only available server (server B).

I have not mentioned before that the ACE is actually a 4710 cluster, and working in bridging mode, but I do not think this could be a reason for the problem.

I also asked the customer (I am not in front of the customer installation itself, just remotely configuring the equipments) to try from lets say 3 or 4 different laptops at the same time.

I wanted basically to know that I was not doing anything wrong from a configuration viewpoint.

Something else that might be useful to know -as requested by customer, and configured by me via ACL- is that both real servers can be reached by their real IPs, because from time to time the customer wanst to reach them individually for maintenance purposes. That works OK too.

Please let me know if you want me to gather more information from the environment.

Thank you very much in advance.

Rogelio

Bronze

ACE always balances to the same server :o(

hello,

as i stated earlier, your confiugration is good, and ACE is able to forward traffic to both servers (not simultaneously, as per your CU testing). So next time before tesitng make sure an empty sticky database, and single connections from multiple machines open parallely. capture show conn detail and sh sticky database, this will help in case it didn't work..........

New Member

ACE always balances to the same server :o(

Hello Gaurav:

You were right as it also was my configuration. Customer misinterpreted the observation.

Thank you very much for your input.

Best regards, Rogelio

771
Views
0
Helpful
4
Replies
CreatePlease to create content