Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ACE Appliance Redundancy

Hi,

I've been testing redundancy of a pair of ACE 4710 Appliances (A3(1) software) in our lab and run into a peculiarity in the FT configuration. I configure the FT exactly as in the configuration guide and it works perfectly as long as I use a cross-over cable between the FT interfaces. This is the relevant config (other ACE same apart from IP's reversed).

interface gigabitEthernet 1/4

ft-port vlan 10

ft interface vlan 10

ip address 192.168.1.1 255.255.255.0

peer ip address 192.168.1.2 255.255.255.0

no shutdown

ft peer 1

heartbeat interval 300

heartbeat count 10

ft-interface vlan 10

query-interface vlan 90

ft group 1

peer 1

associate-context Admin

inservice

As I said - works great with a crossover cable. However, the appliances will be far enough apart that I need to use a normal switched connection and this just refuses to work (both appliances on consecutive ports on the same switch). The connections come up and there are no errors on the switch ports or the appliances, but the heartbeat packets don't seem to get through. The odd thing is that if I swap the "ft-port vlan 10" command for a normal "switchport access vlan 10" command then it works fine.

Can anyone explain this weirdness? what exactly does the "ft-port" do?

thanks,

Andrew.

4 REPLIES

Re: ACE Appliance Redundancy

"ft-port vlan X" command simply makes that

port dedicated to FT traffic, it does not setup any kind of bridging or trunking.

If you are using cat6K then the the default for a port on a 6k is to trunk with another

switch.

Since the native default native vlan on any trunk is Vlan 1. and since you do not have any vlans assigned to that port, it is only pushing vlan1 traffic and vlan 10 is sitting

idle.

I think assigning Vlan 10 as the native will allow ACE to push the traffic onto the switch.

Try the following

interface gigabitEthernet 1/4

ft-port vlan 10

switchport trunk native vlan 10

HTH

Syed Iftekhar Ahmed

Re: ACE Appliance Redundancy

Hi Syed,

I was using a Cat3550 switch, with the ports set up as normal access ports, like this:

interface FastEthernet0/35

switchport access vlan 10

switchport mode access

spanning-tree portfast

So, on the ACE I tried not using "ft-port" and just used "switchport access vlan 10" which worked fine, and the FT worked as expected. As soon as I use "ft-port" it breaks until I add the "switchport trunk native vlan 10" command. What's going on here? does the ft-port command turn the FT port into a trunk port? I'm definitely missing something here and the Cisco docs are not clear on this point.

thanks,

Andrew.

New Member

Re: ACE Appliance Redundancy

Andrew,

Have you resolved this yet?

I have just setup two ACE4710's, same issue on FT connection. The reply about assigning the ft vlan to the interface is not an acceptable command.

The switches that I am using are 3750's, these are recording interface errors, and when you do a show int f4/0/47 controllers, you see the issue is related to runts, undersized packets. I have seen similar issues before on 3750's.

I have had to leave the FT connection as a cross over to make it work.

Any ideas?

Thanks

Gary

Re: ACE Appliance Redundancy

From the following link

http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA1_7_/command/reference/if.html#wp1068700

"ACE automatically includes the FT VLAN in the VLAN trunk link"

It means FT ports are put by default in trunk mode. Could you guys change the ports on the switches to trunk port and see if it works.

Syed

501
Views
0
Helpful
4
Replies