Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ACE: Can't allocate resource class due to resource in use

When I try to enter the member [resource_class] command under the context config mode I get...

Error: resources in use

Any idea how I get around this?

Note: I am trying to do this so that I can configure stickiness in my context and I get

Error: sticky resource not available

6 REPLIES
New Member

Re: ACE: Can't allocate resource class due to resource in use

The issue you are running into is that you have already allocated all of the sticky database resources. If for example you define a resource-class with a limit-resource command which specifies a minimum of 20% of the sticky database resources then you can only have 5 contexts as members of this resource-class (5 x 20 = 100). You will then get the "resources in use" message when you try to add a sixth context as a member.

New Member

Re: ACE: Can't allocate resource class due to resource in use

This is the first resource class/context relatoionship I have created. There is the default class however, do I need to cut that down? I was planning to divide it between the 5 contexts anyway so 20% is fine. Have I understood correctly?

New Member

Re: ACE: Can't allocate resource class due to resource in use

is this any help?

ace-1/Admin# sh resource usage

Allocation

Resource Current Peak Min Max Denied

-----------------------------------------------------------------------------

Context: Admin

conc-connections 10 11 0 8000000 0

mgmt-connections 4 14 0 5000 0

proxy-connections 0 0 0 1048574 0

xlates 0 0 0 1048574 0

bandwidth 502 93472 0 500000000 410

connection rate 0 40 0 1000000 0

ssl-connections rate 0 0 0 1000 0

mgmt-traffic rate 156 26863 0 125000000 0

mac-miss rate 0 8 0 2000 0

inspect-conn rate 0 0 0 6000 0

acl-memory 6360 6520 0 78610432 0

regexp 0 0 0 1048576 0

syslog buffer 3562496 3562496 0 4194304 0

syslog rate 0 11 0 3000 0

Context: C1

conc-connections 2 8 0 8000000 0

mgmt-connections 22 56 0 5000 0

proxy-connections 0 8 0 1048574 0

xlates 0 0 0 1048574 0

bandwidth 276 387123 0 500000000 0

connection rate 2 30 0 1000000 0

ssl-connections rate 0 0 0 1000 0

mgmt-traffic rate 92 13673 0 125000000 0

mac-miss rate 0 2 0 2000 0

inspect-conn rate 0 0 0 6000 0

acl-memory 3664 20288 0 78610432 0

regexp 0 0 0 1048576 0

syslog buffer 631808 631808 0 4194304 0

syslog rate 2 24 0 3000 0

Context: C2

conc-connections 0 0 0 8000000 0

mgmt-connections 0 0 0 5000 0

proxy-connections 0 0 0 1048574 0

xlates 0 0 0 1048574 0

bandwidth 0 514 0 500000000 0

connection rate 0 2 0 1000000 0

ssl-connections rate 0 0 0 1000 0

mgmt-traffic rate 0 390 0 125000000 0

mac-miss rate 0 0 0 2000 0

inspect-conn rate 0 0 0 6000 0

acl-memory 0 5120 0 78610432 0

regexp 0 0 0 1048576 0

syslog buffer 0 0 0 4194304 0

syslog rate 0 0 0 3000 0

New Member

Re: ACE: Can't allocate resource class due to resource in use

I think it is due to the fact that the resources themselves are in use, as the error says, not that they are allocated. How do I get around this, do I have to wipe he config, then create the resource classes? But I don't know what kind of resources are required for each application until SIT testing is done, and for that, I need the config in place.

New Member

Re: ACE: Can't allocate resource class due to resource in use

Could you attach or include your running-config from the Admin context as well as a copy of the output of 'show resource allocation'? These would be most helpful.

- David

New Member

Re: ACE: Can't allocate resource class due to resource in use

It's ok, I have it working now. I had to allocate all the 'not in use' resources individually, this included sticky. So it's fine now. Thanks for your help.

528
Views
0
Helpful
6
Replies
CreatePlease to create content