Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ACE Module not booting up.

Hi All,

My ACE module doesn not boot when i issue the reload command. Also no power enable module 7/power enable module 7 does not work.  The only solution is to physically remove and re-insert the module on the switch.

Please find the output of ACE module booting up below ,it looks like there is a memory error of some sort.  You will also notice that the ACE went into rommon, this was because I was performing a test to get the ACE to boot from an image on the Supervisor.

Unmounting ext3 filesystems...

Unmounting FAT filesystems...

Unmounting done...

INIT: Switching to runlevel: 6

INIT: Sending processes the KILL signal

Rebooting... <1>

sbmac stopped<0>Rest

System Bootstrap, Version 12.2[120],

Copyright (c) 1994-2007 by Cisco Systems, Inc.

Slot 7: Running DEFAULT rommon image ...

ACE platform with 1056876 Kbytes of main memory

Autoboot: failed, boot string  not found

rommon 1 > boot eobc:

boot string configured on SUP is "sup-bootflash:c6ace-t1k9-mz.A2_3_1.bin&qu

ot;

Download Start

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!

Download Completed! Booting the image.

Uncompressing Linux...

Starting the kernel...

INIT: version 2.78 booting

Mounting Second Ramdisk ....

Second Ramdisk successfully mounted

Configuring network interfaces.

CF dump: Register callback functions

dosfsck 2.11, 14 April 2006, FAT32, LFN

/dev/cf: 10 files, 26399/63414 clusters

FAT FS is ok

Compact Flash size 1278624(in 1k blocks) ...

Core file size 208900

Available free size in cf is 796640 (in 1k blocks) ...

set_coredump 2.11, 14 April 2006, FAT32, LFN

first_cluster = 0x608e num_cluster = 0x40 (64)

inserting procfs

inserting isan_kthread

inserting wiremod

inserting klib

inserting resdrv

inserting tlv

inserting sse

inserting kpss

inserting sdwrap

creating sdwrap device

inserting klm_tl

creating tl device

inserting klm_scp

inserting klm_mts

creating mts0 device

creating mtscfg0 device

inserting utaker

creating utaker0 device

creating utaker1 device

inserting sysmgr-hb

creating sysmgr-hb device

inserting modlock

creating modlock device

inserting bufmgr

inserting pkt_fifo

inserting encdec

creating encdec device

inserting pseudo

inserting drammap mod

creating drammap device

inserting ixp_dnld

creating ixp_dnld device

inserting sysdrv

creating sysdrv device

New registry installed.

INIT: Entering runlevel: 3

inserting i2c module

inserting ssa driver

inserting cde driver

inserting bf_dnld driver

inserting pfm_drv driver

inserting regaccess driver

inserting bf_nvram driver

Firmware compiled 19-Sep-07 18:27 by integ Build [26368]

ACE Daughter boards DB1 not present DB2 not present.

downloading fpga to cde 1

Read 2398454 bytes from ./cde1_core.bit

FPGA Date: 2007/12/18 Time: 22:22:1 0

CDE 1 download successful

downloading fpga to cde 2

Read 2377744 bytes from ./cde2_core.bit

FPGA Date: 2007/12/18 Time: 22:22:17

CDE 2 download successful

FPGA Programming Done

CDE 1 revision ID 0403

CDE 2 revision ID 0402

enabling cde 0 interrupts

finished CDE setup

Configuring NP 1 Memory

Configuring NP 2 Memory

.............................

Waiting for NP 1 SRAM memory to clear...sData bus error, epc == 00401618, ra ==

004015a8

A_BUS_ERR_DATA_0 0x896c1f00001f6c89

A_BUS_ERR_DATA_1 0x5fdffeff

A_BUS_ERR_DATA_2 0x5fdffeff

A_BUS_ERR_DATA_3 0xffffffff5fdffeff

A_BUS_L2_ERRORS 0x0

A_BUS_MEM_IO_ERRORS 0x10000

uccess

Downloading NP 1 Image

..... 0x4b4b74 (4934516) bytes downloaded

/itasca/etc/rc3.d/S11_setup: line 59:   618 Bus error               ./ixp_prog q

nx.bin 1

Loading Nitrox driver.

Writing register at address 3838 with e00

size = 8108

% IXP 1 XScale Core reset detected !!

Ctx memory range(0x0000000-0x10000000)

Cleared 262144 1024-byte blocks in 5 requests.

Writing register at address 3898 with 1

Writing register at address 38b8 with 1

N2 SPI INIT PROGRAM.

Initializing Nitrox SPI1

configuring using falling clocks

Initializing CDE SPI registers

Nitrox init completed.

inserting IPCP klm

n2_perf_stats loaded

||||$T0a25:c21ecb88;48:801f97f0;1d:8076ff40;#16

Could someone let me know if this is Software issue or the Hardware.

Thanks in advance.Looking forward to hear something on this.

Regards,

Alex.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: ACE Module not booting up.

Definitely looks like hardware...bad SRAM memory.

Waiting for NP 1 SRAM memory to clear...sData bus error, epc == 00401618, ra ==

004015a8

A_BUS_ERR_DATA_0 0x896c1f00001f6c89

A_BUS_ERR_DATA_1 0x5fdffeff

A_BUS_ERR_DATA_2 0x5fdffeff

A_BUS_ERR_DATA_3 0xffffffff5fdffeff

A_BUS_L2_ERRORS 0x0

A_BUS_MEM_IO_ERRORS 0x10000

uccess

Gilles.

5 REPLIES
Cisco Employee

Re: ACE Module not booting up.

Definitely looks like hardware...bad SRAM memory.

Waiting for NP 1 SRAM memory to clear...sData bus error, epc == 00401618, ra ==

004015a8

A_BUS_ERR_DATA_0 0x896c1f00001f6c89

A_BUS_ERR_DATA_1 0x5fdffeff

A_BUS_ERR_DATA_2 0x5fdffeff

A_BUS_ERR_DATA_3 0xffffffff5fdffeff

A_BUS_L2_ERRORS 0x0

A_BUS_MEM_IO_ERRORS 0x10000

uccess

Gilles.

Community Member

Re: ACE Module not booting up.

Hi Giles,

Thanks for answering this.

So should I proceed with hardware replacement?

Thanks

Alex

Cisco Employee

Re: ACE Module not booting up.

Alex, yes I would suggest to replace the card.

Gilles.

Community Member

Re: ACE Module not booting up.

Hello Guys. Now, I have the same problem with boot ACE. 

rommon 8 > boot disk0:c6ace-t1k9-mz.A4_1_0.bin
.Loading disk0:c6ace-t1k9-mz.A4_1_0.bin. Please wait ....
Uncompressing Linux...
Starting the kernel...


INIT: version 2.85 booting
Configuring network interfaces.
FAT FS is ok

New registry installed.
INIT: Entering runlevel: 3such f
setting /usr/sbin/ipmaddr add 01:00:81:00:00:00 dev eth0
Firmware compiled 22-Jul-10 14:50 by jcbryant Build [25856]

Starting CDE setup
CDE 1 revision ID 050a
CDE 2 revision ID 0501
Finished CDE setup
ACE Daughter boards DB1 present DB2 present.
Powering up DC1 (of DC1/DC2)... Succeeded..
DC1 present, checking if 'DC Rommon' needs upgrade...
DC1 'DC Rommon' is latest, no upgrade needed.
DC1 present, checking if 'DC Controller' needs upgrade...
DC1 'DC Controller' is latest, no upgrade needed.
Powering up DC2 (of DC1/DC2)... Succeeded..
DC2 present, checking if 'DC Rommon' needs upgrade...
DC2 'DC Rommon' is latest, no upgrade needed.
DC2 present, checking if 'DC Controller' needs upgrade...
DC2 'DC Controller' is latest, no upgrade needed.
Waiting for NP's to boot
Data bus error, epc == 00400e2c, ra == 00400dd8
Data bus error, epc == 00400e2c, ra == 00400dd8
Data bus error, epc == 00400ae8, ra == 00400a98
/itasca/etc/rc3.d/S11_setup: line 310: 750 Bus error ./dc_prog 0 (wd: /itasca/ixp)
/itasca/etc/rc3.d/S11_setup: line 310: 751 Bus error ./dc_prog 1 (wd: /itasca/ixp)
/itasca/etc/rc3.d/S11_setup: line 310: 752 Bus error ./octeon_poll 0x52000000
Data bus error, epc == 00400ae8, ra == 00400a98
/itasca/etc/rc3.d/S11_setup: line 310: 754 Bus error ./octeon_poll 0x52000000

What to do with this problem?

Thank you.

Community Member

Re: ACE Module not booting up.

Also 

Data bus error, epc == 00400ae8, ra == 00400a98
/itasca/etc/rc3.d/S11_setup: line 310: 792 Bus error ./octeon_po ll 0x52000000
This service preferaData bus error, epc == 00403ccc, ra == 00403c84
bly be started by the System Manager.
Data bus error, epc == 00400ae8, ra == 00400a98
Command line arguments (3):
0: /itasca/bin/sme
1: -c
2: 2

Environment variables:
0: CONSOLE=/dev/console
1: TERM=linux
2: INIT_VERSION=sysvinit-2.85
3: PATH=/sbin:/bin:/usr/sbin:/usr/bin
4: runlevel=3
5: RUNLEVEL=3
6: PWD=/itasca/bin
7: previous=N
8: PREVLEVEL=N
9: HOME=/
10: SHLVL=3
11: _=/itasca/bin/sme
12: OLDPWD=/itasca/ixp
/itasca/etc/rc3.d/S11_setup: line 310: 794 Bus error /itasca/bin /sme -c 2
/itasca/etc/rc3.d/S11_setup: line 310: 795 Bus error ./octeon_po ll 0x52000000
Data bus error, epc == 00400ae8, ra == 00400a98
/itasca/etc/rc3.d/S11_setup: line 310: 797 Bus error ./octeon_poll 0x52000000
Data bus error, epc == 00400ae8, ra == 00400a98

Please help....

1076
Views
0
Helpful
5
Replies
CreatePlease to create content