Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ACE Module - problem with RDP after upgrade to A2(3.2)

Hello,

I had the RDP working fine with the version A2(3.1) with redundant ACE Modules.

After an Upgarde to A2(3.2) all the existing RDP sessions were still working, but the ACE did not redirect any new RDP sessions. Instead other applications as HTTP and HTTPS did work.

After a Rollback to A2(3.1) the new RDP sessions were working again.

Did someone has the same problem, or is there any known bug?

Kind regards

Jean-Marc

9 REPLIES
Cisco Employee

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

What do you exactly mean by "existing RDP session after upgrade". Do you have two ACEs in FT and you upgraded one and made it active so it took over existing RDP connections. Are you load-banasing RDP as any other later 4 service or are you using "policy-map type loadbalance rdp" for it?

New Member

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

Yes, we have 2 ACE Modules in FT and we upgraded so it took over the existing sessions.We are loadbalancing RDP at L7. with "policy-map type loadbalance rdp first-match ...". We also use PAT on the source addresse. I attached an extract of the configuration.

Kind regards

Jean-Marc

Cisco Employee

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

And for other services that work, do you also use predictor leastconns and source NAT (apart or in combination)?

New Member

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

Yes, other applications, I mostly tested one with SSL Termination on another Contexte, also use Predictor and Source NAT. This apllication was working with both versions A2(3.2) and A2(3.1). I don't have any feedback for other applications.

Cisco Employee

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

Have you been able to narrow this down to where does it actually brake? Does the client side TCP session get established? Does the ACE try to establish TCP session to the server and does to forward RDP traffic?

New Member

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

I didn't have many time to troubleshoot. But it seems the TCP session was established between the client and the ACE (telnet VIP 3389), and the ACE did not forward RDP traffic.

Cisco Employee

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

I would suggest that you open a TAC SR to have this investigated. There is to few info to determine what has happened. The best way would be to schedule a Maintenance Window and attempt the same thing again together with TAC engineer over the WebEx.

New Member

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

OK, Many thanks for your help.

Regards Jean-Marc

New Member

Re: ACE Module - problem with RDP after upgrade to A2(3.2)

FYI DDTS CSCtl63354 has been logged for this issue.

762
Views
0
Helpful
9
Replies
CreatePlease login to create content