Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

ACE module - Resouce in use


I try to free some memory on a ACe module because I get the resource in use message.

I spotted 2 contexts with the default RC, however when I try to assign a resource class with a lower percentage to these contexts I get the "Error: resouce in use" message even though these RC have a lower resource allocation.

Did anybody come accress this situation and fixed it?



Re: ACE module - Resouce in use

The default resource class allows a context to operate within a range that can vary from no resource access (0%) to complete resource access (100%).So there is no guaranteed minimum reserved by default RC.

If you are assigning a RC that guarantees x% resource (x might be a small amount but it tries to reserve some % of resource for that context) and there is no resource available to allocate then you will get this error.

As resources are allocated the minimum value is tallied to prevent oversubscription of guaranteed resources.

Show resource usage all command will give you a clear picture of available and allocated resources.


Syed Iftekhar Ahmed

Community Member

Re: ACE module - Resouce in use


Do you have any other RCs configured and currently in use by other contexts? If so, the total RCs in use should not exceed 100%.

For example if you have two RCs configured each of 45% and both allocated to contexts, this means you have already allocated 90% of your resources. You cannot in this case create a new RC of 20% and allocate it to another context, as it exceeds the RC allocation available.

I hope that helps. If not, please provide more details as to the number of RCs you have configured, the percentage allocations per RC and the RC allocation per context.

Cisco Employee

Re: ACE module - Resouce in use

most probably your syslog buffer is full.

This is a resource like the other and when it is full, you csn't add new context.

Make sure you never set the max unlimited for the syslog resource.

In order to get out of this issue, you will need to clear logg in all the contexts.


Community Member

Re: ACE module - Resouce in use

Thanks All for your reply,

The only configuration is the :

resource-class ContextID

limit-resource all minimum 5.00 maximum equal-to-min

i know i'm "short" of memory there but how could I resize the memory allocation if the command to allocate less memory does not go through.

I guess in order to assigne that Rc to the context i should have at least the same percentage of free memory as the percentage I want to allocate to the context.

Looks like the only way to change this is to configure a more detailed memory allocation wihtin the RC (syslog, bandwidth, acl, ...) so I would assign less memory to various resources within the context.

But then again, I guess the fact that I ran out of memory will prevent me from changing the existing resource allocation. sounds to me like a dead end at this stage.

Any idea?


CreatePlease to create content